[gtk+] Created tag 3.7.10



The signed tag '3.7.10' was created.

Tagger: Cosimo Cecchi <cosimoc gnome org>
Date: Mon Feb 18 20:49:38 2013 -0500

    3.7.10

Changes since the last tag '3.7.8':

Adel Gadllah (1):
      Fix compiler warnings

Alexander Larsson (26):
      gdkwindow: Store the implicit paint in a list
      gdkwindow: Allow gdk_window_set_opacity on non-native children
      Add gtk_widget_(un)register_window
      Add gtk_widget_get/set_opacity
      Add widget transparency test to testgtk
      TextHandle: Don't draw handles if not visible
      Add singleton for css number 1.0
      css: Support opacity
      css: Add opacity reftest
      Clean up the opacity handling
      Add opacity_group hack
      Make GtkIconInfo a GObject
      Add gtk_icon_info_load_icon_async
      GtkIconTheme Don't leak pixbuf in symbolic icon cache
      GtkIconTheme: Add async versions of symbolic icon loaders
      Update README.in for the GtkIconInfo type change
      Add new GtkIconInfo calls to the reference docs
      gtk3-demo: Fix up resource handling
      Fix GtkIconInfo docs
      Fix up s/gtk_frame_clock/gdk_frame_clock/ in docs
      Fix gtk_widget_add_tick_callback sometimes not working
      Add a few missing gtk_widget_unregister_window calls
      GtkEntry: Fix text handle painting
      win32: Fix build
      Remove unnecessary copy of GdkFrameClockIdlePrivate
      win32: Request higher precision timers during animations

Anish A (4):
      Updated Malayalam Localization
      Revert "Updated Malayalam Localization"
      Updated Malayalam Localization
      Revert "Updated Malayalam Localization"

Aurimas Černius (2):
      Updated Lithuanian translation
      Updated Lithuanian translation

Bastien Nocera (1):
      GtkAccelLabel: Don't show "+" if there's no more keys to add

Baurzhan Muftakhidinov (1):
      Updated Kazakh translation.

Carles Ferrando (1):
      [l10n] Updated Catalan (Valencian) translation

Changwoo Ryu (1):
      immodule: Fix context ID lookup on module with multiple contexts

Cosimo Cecchi (10):
      settings: add a gtk-recent-files-enabled GtkSetting
      recentmanager: follow gtk-recent-files-enabled GtkSetting
      filechooser: follow the gtk-recent-files-enabled GtkSetting
      Fix a typo in the README
      immodule: fix a GCC warning
      tests: workarounds to keep treeview scrolling tests running
      docs: add some missing gtk-doc blocks and Since tags for new API
      docs: add some missing methods
      release: update NEWS for 3.7.10
      3.7.10

Federico Mena Quintero (18):
      filechooser: Get the filechooser tests to build
      filechooser: Move some of the tests to GTestDataFunc
      filechooser: Do tests with g_assert_cmpstr(), not g_assert(passed)
      filechooser: Add a couple of tests for GtkFileChooserButton; they fail now
      filechooser: Test canceling the dialog inside a GtkFileChooserButton
      filechooserbutton: Don't set a starting folder in the underlying dialog
      filechooserbutton: Simplify the code to preserve the selection while the dialog is running
      filechooser: Remove some unused code
      filechooserbutton: Fix preserving the selection after cancelling the dialog
      filechooserbutton: Add test for setting/getting the current folder; currently fails
      filechooserbutton: Restore to an empty previous selection properly
      filechooserbutton: Remove unused function prototypes
      filechooser: Fix cast
      filechooserbutton: Keep track of the current_folder while the dialog is inactive
      filechooserbutton: In SELECT_FOLDER mode, consider an empty selection to mean current_folder
      filechooserbutton: Add a battery of tests for GtkFileChooserButton
      filechooser: Oops, cancel a file operation that was missing
      filechooserbutton: Add tests for SELECT_FOLDER mode with the dialog active

Gil Forcada (1):
      [l10n] Updated Catalan translation

Jan Arne Petersen (1):
      wayland: Handle wl_output in GdkWaylandScreen

Jasper St. Pierre (7):
      gdkframeclock: Fix doc comments
      gtkicontheme: Mark copy/free compat symbols as skip
      Fix deprecations for GtkIconInfo
      gtkplug: Remove a no-op func
      gdkframeclockidle: Don't expose sleep_source source funcs
      Update gdk.symbols
      Update gtk.symbols

Jiro Matsuzawa (1):
      [l10n] Update Japanese translation

Juan Pablo Ugarte (1):
      Added scroll and touch events to GtkToolPalette

Khaled Hosny (1):
      Update Arabic translations

Marc-André Lureau (1):
      Fix a small typo s/parater/parameter

Marek Černocký (1):
      Updated Czech translation

Matthias Clasen (6):
      post-release bump
      Add a test for setting accessible name from gtkbuilder
      Correct the documentation for how to set accessible names
      Plug a few memory leaks
      Mention the de-facto standard filename extension
      Remove remnants of localization from gtk-demo

Owen W. Taylor (57):
      GdkDisplayX11: Don't use substructure events in internal accounting
      Add GdkFrameClock
      Use GdkFrameClock for relayout
      GdkFrameClock: Make the phase explicit when requesting the frame
      GdkFrameClock: add freeze/thaw
      Switch to an extended form of _NET_WM_SYNC_REQUEST_COUNTER
      Use _NET_WM_FRAME_DRAWN to synchronize frame drawing
      Freeze the update counter for unmapped windows
      GdkWindowX11: start off with an odd frame-counter value
      GdkFrameClockIdle: add throttling to 60fps
      Add an UPDATE phase and GdkFrameClockTarget, use for GtkStyleContext
      Add back GtkTimeline
      GtkTimeline: remove settable FPS
      Hook GtkTimeline up to GdkFrameClock
      GtkTimeline: introspection fixes, add :progress-type property
      GtkTimeline: Wrap around the progress correctly when looping
      Add a test of an animated resizing window
      GtkScrolledWindow: use GdkFrameClock for kinetic scrolling
      Compress motion synchronized with the paint cycle
      GdkFrameClock: Reverse order of resume-events and afterpaint
      gdk_display_get_event: don't unqueue events from the windowing system when paused
      GdkDisplay: handle multiple calls to _gdk_display_pause_events()
      GdkWindowX11: Only start a frame when we emit damage
      Add GdkFrameHistory and GdkFrameTimings, handle _NET_WM_FRAME_TIMINGS
      GdkFrameClockIdle: don't start the tiemout/idle when in a frame
      Add gdk_frame_timings_get/set_slept_before()
      GdkWindowX11: Communicate gdk_frame_timings_get_slept_before() to the compositor
      animated-resizing: make circle size a #define
      animated-resizing: enhance output
      Add GDK_DEBUG=frames
      Add gdk_frame_timings_get_predicted_presentation_time()
      video-timer: add a test case for display at a constant frame rate
      video-timer: add simple example of PLL-style clock adjustment
      Fix up for newer draft of wm-spec
      Reimplement _NET_WM_SYNC_REQUEST inside X11 backend
      GdkX11DeviceManagerXI2: handle focus events not on a known window
      Add gtk_widget_add_tick_callback(), remove GtkTimeline, etc.
      GdkWindow: make the frame clock an inherent property of the window
      Change GdkFrameClock from an interface to a class
      Merge GdkFrameHistory into GdkFrameClock
      GdkFrameTimings: strip down to a minimal public API
      GdkFrameClock: Clean up the public API
      GdkFrameTimings: add documentation
      GdkFrameClock: update documentation
      Merge with Merge GdkFrameHistory into GdkFrameClock
      gdk_frame_clock_get_frame_time(): use gint64 for time
      Small documentation fixes for frame synchronization
      Ignore window manager protocol messages for destroyed windows
      Don't compress motion events for different devices
      GtkTickCallback: document use of G_SOURCE_CONTINUE/REMOVE for return value
      GtkContainer: fix disconnection from frame clock
      GtkScrolledWindow: use gtk_widget_add_tick_callback()
      GdkFrameClockIdle: remove timeouts in dispose
      GdkWindowX11: the root window is not a toplevel
      Add gdk_frame_clock_begin/end_updating()
      gtk_widget_on_frame_clock_update: ref the widget
      GdkWindow: don't leak the newly created frame clock

Paolo Borelli (1):
      [entry] unregister icon windows

Piotr Drąg (2):
      Updated POTFILES.in
      Updated Polish translation

Rico Tzschichholz (2):
      Revert "Drop things that break distcheck"
      Revert "Visual C++: Update gtka11y projects completion"

Rob Bradford (8):
      wayland: Advertise the cursor theme through GtkSettings as Adwaita
      wayland: Pull the cursor theme name out from the setting for it
      wayland: Use g_value_set_static to avoid string copies
      build: Bump atk dependency to 2.7.5
      gdkwindow: Do not rely on a previous slave device when updating grab
      wayland: React to G_IO_ERR and G_IO_HUP on the wayland socket
      wayland: Add basic multiple output support
      wayland: Add support for output device removal

Shushi KUROSE (1):
      [l10n] Update Japanese translation

Simon Feltman (1):
      gtkcellrenderertext: Sink floating entry before using as signal argument

Thomas Wood (10):
      wayland: fix the direction of scrolling
      wayland: use the GdkCursorType enum information to lookup the cursor name
      wayland: avoid returning NULL when getting a cursor
      wayland: remove debug message
      tooltip: set the transient parent when using the Wayland backend
      wayland: set the "transient inactive" flag on tooltip surfaces
      gdkwindow: don't use last_slave for the source device if it is NULL
      wayland: skip pointer and keyboard events without a surface
      wayland: look further through the hierarchy for the surface with the grab
      wayland: attempt to determine the possible parent surface for popups

Torsten Schönfeld (1):
      GtkViewport: annotate the adjustment args of the constructor

William Jon McCann (1):
      Don't crash if inhibit is called with an unrealized window

jjacky (1):
      Fix #673243: accelerators not visible on GtkRadioMenu

Мирослав Николић (1):
      Updated Serbian translation


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]