[gnome-shell/wip/paging-release2: 4/23] iconGrid: Rename childrenInRow to columnsForWidth
- From: Carlos Soriano <csoriano src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gnome-shell/wip/paging-release2: 4/23] iconGrid: Rename childrenInRow to columnsForWidth
- Date: Sat, 31 Aug 2013 10:48:59 +0000 (UTC)
commit e775d96ef62cd615961b6dd27a2fed00564d941c
Author: Carlos Soriano <carlos soriano89 gmail com>
Date: Thu Aug 22 23:27:05 2013 +0200
iconGrid: Rename childrenInRow to columnsForWidth
Since the parameter of the function is the width, reflect that in
the function name. Also, since we are counting columns, not only
children for each row, reflect that in the function name also.
https://bugzilla.gnome.org/show_bug.cgi?id=706081
js/ui/iconGrid.js | 2 +-
js/ui/searchDisplay.js | 2 +-
2 files changed, 2 insertions(+), 2 deletions(-)
---
diff --git a/js/ui/iconGrid.js b/js/ui/iconGrid.js
index 5368489..cb942c7 100644
--- a/js/ui/iconGrid.js
+++ b/js/ui/iconGrid.js
@@ -330,7 +330,7 @@ const IconGrid = new Lang.Class({
return childBox;
},
- childrenInRow: function(rowWidth) {
+ columnsForWidth: function(rowWidth) {
return this._computeLayout(rowWidth)[0];
},
diff --git a/js/ui/searchDisplay.js b/js/ui/searchDisplay.js
index 2177874..9d47e44 100644
--- a/js/ui/searchDisplay.js
+++ b/js/ui/searchDisplay.js
@@ -320,7 +320,7 @@ const GridSearchResults = new Lang.Class({
},
_getMaxDisplayedResults: function() {
- return this._grid.childrenInRow(this._bin.width) * this._grid.getRowLimit();
+ return this._grid.columnsForWidth(this._bin.width) * this._grid.getRowLimit();
},
_renderResults: function(metas) {
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]