[gtk+] (195 commits) ...Merge branch 'merge-places-sidebar'



Summary of changes:

  d2050e5... Copy nautilus-places-sidebar.[ch] as gtkplacessidebar.[ch] (*)
  660bef2... Replace 'NautilusPlacesSidebar' with 'GtkPlacesSidebar' (*)
  f8fea85... Remove Nautilus includes (*)
  c64d6b0... Export GtkPlacesSidebar and the Class types, for subclassin (*)
  2f9964f... Remove unused structs (*)
  4484d75... Update the top comment in gtkplacessidebar.c (*)
  f7312ce... Don't take a NautilusWindow argument in gtk_places_sidebar_ (*)
  554bb2e... Connect to the volume monitor at the time of its creation (*)
  1093e14... Add gtk_places_sidebar_set_current_uri() (*)
  4284d74... Remove the 'nautilus' prefix from some constants (*)
  5d1620f... Add a GtkPlacesOpenMode enum to say how a shortcut should b (*)
  f2d46f3... New 'location-selected' signal (*)
  91b3ad9... Rename NautilusShortcutsModelFilter to ShortcutsModelFilter (*)
  d0196e9... Split out a GtkBookmarksManager from gtkfilesystem.[ch] (*)
  30c2fc3... Make GtkFileChooserDefault use GtkBookmarksManager (*)
  60f8411... Make gtk_places_sidebar_set_current_uri() handle NULL URIs  (*)
  06bfe5b... Make GtkFileChooserButton use GtkBookmarksManager (*)
  163beca... Remove the bookmarking bits from GtkFileSystem (*)
  3696938... Read the legacy bookmarks file (*)
  b8b6d59... Cancel and disconnect from the bookmarks monitor when done (*)
  0be8218... Create the bookmarks manager from the places sidebar (*)
  0bc1be0... Make the main update_places() use GtkBookmarksManager (*)
  c2a922b... Replacement for nautilus_get_home_directory_uri() (*)
  6287ee4... Remove the last use of nautilus_window_slot_get_current_uri (*)
  acccb10... Remove the use of NautilusWindow (*)
  644d8e4... Replace nautilus_window_set_initiated_unmount() with an ini (*)
  0f2f7ae... Use our own function to compute icon sizes (*)
  d027b2d... Tentatively accept any drags of URI lists (*)
  f68609f... Use macros for themed icon names (*)
  01020cc... Replace an icon-size macro from Nautilus (*)
  7be8819... Add functions to say whether multiple tabs/windows are supp (*)
  28f44a3... Function to set whether to show the Desktop item (*)
  a4ac2d5... Replacement for eel_gtk_tree_view_set_activate_on_single_cl (*)
  4759365... New signal show-error-message (*)
  76ec7fb... Replacement for the NautilusIconInfo machinery (*)
  06a9d19... Don't use gtk_icon_theme_get_default(); use the screen-spec (*)
  3e26fda... Replace an icon name with a macro (*)
  c942ed7... Use the correct icon for trash (*)
  f404eb4... Get icons for user-special directories (*)
  cbd3c6c... Replace eel_create_spotlight_pixbuf() (*)
  92e1b8e... Replace eel_gtk_menu_append_separator() (*)
  2aaf82c... Replacement for eel_pop_up_context_menu() (*)
  9de31fc... Replacement for nautilus_get_desktop_directory() (*)
  8f786e0... Insert bookmarks during drag-and-drop operations (*)
  5661b7b... Don't leak the bookmarks when enumerating them (*)
  b31b7e3... Remove stale code to deal with preferences (*)
  4f9b06d... Add a bunch of '#if DO_NOT_COMPILE' to remove nautilus-isms (*)
  19ef718... Add gtkplacessidebar.[ch] to Makefile.am and fix compilatio (*)
  c242e88... #if out a few things (*)
  2aec19e... #if out another bunch of stuff, to make the fucking thing c (*)
  86c784e... Fix compilation (*)
  e49edba... Add missing includes (*)
  2e9f9d2... Fix compilation (*)
  4fe3cd8... Create the places sidebar instead of the old custom treevie (*)
  abdef8a... Use the correct GTK_TYPE_PLACES_OPEN_MODE instead of a gene (*)
  a7ea37f... Sync with NautilusPlacesSidebar (*)
  86c3274... Connect to location-selected on the places sidebar, and act (*)
  f05874a... If a bookmark doesn't have an explicit label, use the displ (*)
  865e8d3... Make removing bookmarks work (*)
  992602e... Make renaming bookmarks work (*)
  caf659e... Add set_show_properties and set_show_trash APIs (*)
  8b1eb6d... Factor out code to find a bookmark in the list of bookmarks (*)
  6ed2217... Implement bookmark reordering, at least the core (*)
  6868e0e... Remove unused field (*)
  e3d12e8... Add machinery for Nautilus to set up the trash state (*)
  ddefb86... I guess I can call myself a coauthor of this now (*)
  4de4d6a... Use symbolic icons (*)
  1dfd0e8... Merge master into places-sidebar to keep up with developmen (*)
  03119a2... Sync from Nautilus - Fix leaks https://bugzilla.gnome.org/s (*)
  dc40569... Sync from Nautilus: bookmark: remove unused GIcon argument  (*)
  2af5ce9... Add comment about missing way to get symbolic icons for boo (*)
  eb40a6c... Sync from Nautilus commit b72d57b038e50172fac2fafdc6c266603 (*)
  948a7be... Enable code to reorder bookmarks by dragging (*)
  d02f884... Oops, reorder the bookmarks list correctly (*)
  61a9a46... Present error dialogs from the places sidebar (*)
  e97869a... Note on more things that Nautilus needs to do (*)
  cdefdcb... Add a show-file-properties signal for Nautilus to use (*)
  a4cd479... Remove some notes on things that Nautilus should do but alr (*)
  84f218a... Remove some more comments on things that Nautilus needs to  (*)
  18f3c4d... Set GTK_STYLE_CLASS_SIDEBAR on the sidebar (*)
  de5f5b7... Copy code from Nautilus to mount volumes (*)
  26a29c7... Fix code to unmount volumes (*)
  5741b0e... Note about missing empty-trash functionality when unmountin (*)
  ec9bdc6... New way to show  in the sidebar (*)
  043cac1... Add a new org.gtk.SettingsFileChooser startup-mode settings (*)
  e6b9ad4... Switch to Recent Files or $CWD at startup (*)
  fe68140... Add menu items to the places sidebar to configure the start (*)
  791bd3c... Update the widgets until all of them have been created (*)
  f623329... Allow switching to recent:/// even though GIO thinks it is  (*)
  fc6bfcd... Actually switch to recent:/// in its key shortcut handler (*)
  e0b30d0... Turn gtk_places_sidebar_set_current_uri() into _set_current (*)
  b706e1b... Highlight the currently-viewed location in the places sideb (*)
  637bd8f... Oops, actually update the internal location of the places s (*)
  bd9532d... Restore the originally-selected location when dynamically u (*)
  c16654b... Ahem, read radio menu items like I knew how to do it (*)
  e09b568... Remove the menu items to select recent-files or CWD (*)
  0a0eee8... Rename function for clarity (*)
  08334f5... Free URI lists (*)
  0a2f9b7... New signal drag-action-requested (*)
  a5184c2... Emit drag-action-requested and feed the result to gdk_drag_ (*)
  f46b26d... New signal drag-action-ask (*)
  221ea9d... New signal drag-perform-drop (*)
  4fe86f1... Emit drag-perform-drop when we need the caller to do the dr (*)
  10b22e0... New API to set whether URI drops are accepted (*)
  56331a4... Port code to add a bookmark for a volume (*)
  b22e553... Oops, signals returning an int must be G_SIGNAL_RUN_LAST (*)
  d257cd0... Oops, forgot to commit this header file. (*)
  686814e... Removed unneeded signal initiated-unmount (*)
  be492a2... Use the right signal id (*)
  6fcf8a7... Remove comments on things that Nautilus no longer needs to  (*)
  221095d... Add list of pending things in GtkPlacesSidebar (*)
  e7d6e78... Sync from nautilus commit 0177dd24a5f7f9f5302745a865eb970a3 (*)
  1bd5eea... Sync from nautilus commit b2e8339d9f49770db0f6a523c8bf77b11 (*)
  35866c8... Sync from Nautilus commit bde2536ee72672c4cd58af7cbb3cf42a4 (*)
  489000b... Remove obsolete comment (*)
  eecda25... Allow not setting a changed callback on GtkBookmarksManager (*)
  1681cf9... Remove the old shortcuts pane code from GtkFileChooserDefau (*)
  19001ba... One less to-do (*)
  e4c70bb... New machinery to add application-specific shortcuts (*)
  976672a... Implement the application-side shortcuts in GtkFileChooserD (*)
  0dca40e... Remove an obsolete function (*)
  f3beff7... Implement the 'Add to bookmarks' command as before (*)
  e6ba6e7... Implement the Home keyboard shortcut (*)
  8b0aea9... Implement the Desktop keyboard shortcut (*)
  c26293e... Implement the Alt-number quick bookmark shortcuts (*)
  016dd28... Remove an obsolete function (*)
  c1c1823... Go back to our machinery for Recent files instead of readin (*)
  bd28aad... Remove unused code (*)
  9124766... Implement the Search keyboard shortcut (*)
  e4d5e66... Remove another to-do (*)
  72ce506... Rename signal location-selected to open-location (*)
  c4f40a9... Remove the GError from the shortcut-related functions (*)
  42d239f... Remove gtk_places_sidebar_set_show_cwd(), implement that in (*)
  e00498f... New signal populate-popup (*)
  fc01ce0... Rebuild the popup menu every time it is used (*)
  55927f2... Remove the multiple-tab/windows-supported APIs (*)
  335ce0e... Remove the Empty Trash menu item (*)
  d0d0235... Remove the Properties menu item (*)
  bfa1f4a... Emit the populate-popup signal so the caller can spice thin (*)
  8dd233d... New public function to get the selected location from menu  (*)
  ff04160... Remove to-do items for Nautilus; they are done now (*)
  ee26120... Add a GtkTrashMonitor private API (*)
  439a770... Use GtkTrashMonitor instead of an API to set the trash stat (*)
  0b41832... New API, gtk_places_sidebar_set_open_flags() (*)
  da2e081... Make the set_location()/get_location() API consistent (*)
  8a4e96f... Oops, removed unused icon field (*)
  306dcd3... Add missing docstrings to public functions (*)
  4cad0db... Add docstrings for the signals (*)
  52d07c9... Add toplevel docs for the sidebar (*)
  223a30d... Add GtkPlacesSidebar to the gtk-doc machinery (*)
  26a5391... Add some missing docs for GtkPlacesSidebar (*)
  eea192a... Sync from Nautilus commit 480b1daf8814063f348d0f75082353a2f (*)
  2cf8970... Sync from Nautilus commit 463e8d1b1922474e4cf591a3029ea8138 (*)
  ceb631b... Fix a FIXME about using symbolic icons (*)
  0523b2f... Avoid an useless ref/unref (*)
  a97a5d3... Don't unconditionally unref potentially NULL objects (*)
  7fa38fd... Use g_clear_object() (*)
  aafd97b... Mark a function as static (*)
  35a56ba... Add API to GtkBookmarksManager for built-in bookmarks (*)
  03f220e... Don't add built-in bookmarks twice (*)
  f59a618... Apply custom names to XDG dirs if possible (*)
  f5b91b9... Update TODO (*)
  742a2f1... Remove useless style_set override (*)
  21a07a5... Add GObject properties and C getters (*)
  a8f3465... Add some missing annotations (*)
  fc9489f... Use GFile in the DnD signals instead of URIs (*)
  f3fb51e... Remove TODO items that are done (*)
  4bff4b0... Reset the treeview drag dest row if the drop is not possibl (*)
  2a35574... Whitespace cleanups (*)
  fafec94... Redo the logic for computing drop positions (*)
  46acb93... Remove the accept-uri-drops property (*)
  04dbec4... Allow dropping URIs as bookmarks between existing bookmarks (*)
  936045e... Merge branch 'master' into places-sidebar (*)
  a46976f... Merge branch 'origin/master' into places-sidebar (*)
  dbf98bc... Properly indicate when new bookmarks are being dropped betw (*)
  6d94f8a... Don't allow drops in unmounted volumes (*)
  0d95705... GtkTreeView: Add some CSS for the 'dnd' style class so draw (*)
  3363974... Remove temporary debugging code (*)
  a7213e3... Disallow drops on the recent:/// item (*)
  bc38811... Remove a couple of FIXMEs (*)
  63b9598... Don't use inout ints in the drag-action-requested signal (*)
  0ae26b9... Remove a NULL-GError that is no longer useful (*)
  2108397... Revert "GtkFileChooserDefault: Define children with a GtkBu (*)
  5b827c5... Merge branch 'places-sidebar' into master (*)
  d3985de... GtkPlacesSidebar: Hold a reference to the sidebar while a D (*)
  9a3bc21... Don't include gtkfilechooserprivate.h from the file chooser (*)
  456c318... Remove unused #define (*)
  70fce92... Move GtkFileChooserDialogPrivate into gtkfilechooserdialog. (*)
  e2c9797... Move GtkFileChooserWidgetPrivate to gtkfilechooserwidget.c (*)
  b0eed86... Move GtkFileChooserDefault to gtkfilechooserdefault.c (*)
  4d4904e... Move all of GtkFileChooserDefault's fields into a private s (*)
  c297d4d... Add .ui file for GtkFileChooserDefault
  1d94636... For now, add GtkPlacesSidebar to the Glade catalog for priv
  a6f9ef0... Load the file chooser's widgets from the .ui file
  3b3eb4b... Merge branch 'merge-places-sidebar'

(*) This commit already existed in another branch; no separate mail sent


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]