[evolution] portability: don't use too generic variable names
- From: Antoine Jacoutot <ajacoutot src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [evolution] portability: don't use too generic variable names
- Date: Thu, 4 Oct 2012 13:56:30 +0000 (UTC)
commit 1cfe0327ca436a687383412664e3a5c2869c7dda
Author: Antoine Jacoutot <ajacoutot gnome org>
Date: Thu Oct 4 15:34:23 2012 +0200
portability: don't use too generic variable names
OpenBSD (and maybe other OS) already declare stdout and stdin in <stdio.h>
which breaks evolution build, so prefix both with "pipe_" to prevent clashing.
https://bugzilla.gnome.org/show_bug.cgi?id=685471
.../e-mail-formatter-text-highlight.c | 8 ++++----
1 files changed, 4 insertions(+), 4 deletions(-)
---
diff --git a/modules/text-highlight/e-mail-formatter-text-highlight.c b/modules/text-highlight/e-mail-formatter-text-highlight.c
index d3bec38..48c6e7a 100644
--- a/modules/text-highlight/e-mail-formatter-text-highlight.c
+++ b/modules/text-highlight/e-mail-formatter-text-highlight.c
@@ -187,7 +187,7 @@ emfe_text_highlight_format (EMailFormatterExtension *extension,
return TRUE;
} else if (context->mode == E_MAIL_FORMATTER_MODE_RAW) {
- gint stdin, stdout;
+ gint pipe_stdin, pipe_stdout;
GPid pid;
CamelStream *read, *write, *utf8;
CamelDataWrapper *dw;
@@ -262,12 +262,12 @@ emfe_text_highlight_format (EMailFormatterExtension *extension,
NULL, (gchar **) argv, NULL,
G_SPAWN_SEARCH_PATH |
G_SPAWN_DO_NOT_REAP_CHILD,
- NULL, NULL, &pid, &stdin, &stdout, NULL, NULL)) {
+ NULL, NULL, &pid, &pipe_stdin, &pipe_stdout, NULL, NULL)) {
return FALSE;
}
- write = camel_stream_fs_new_with_fd (stdin);
- read = camel_stream_fs_new_with_fd (stdout);
+ write = camel_stream_fs_new_with_fd (pipe_stdin);
+ read = camel_stream_fs_new_with_fd (pipe_stdout);
/* Decode the content of mime part to the 'utf8' stream */
utf8 = camel_stream_mem_new ();
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]