[gtk+] Created tag 3.7.2



The unsigned tag '3.7.2' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Tue Nov 20 07:00:31 2012 -0500

    3.7.2

Changes since the last tag '3.7.0':

Adorilson Bezerra (1):
      Fixed Brazilian Portuguese Translation

Alexander Larsson (6):
      Add "parent widget" button to test property editor
      gdk: Add gdk_window_has_alpha helper
      Fix cnp bug in _gtk_bitmask_intersects
      Exit early in gtk_style_context_update_cache codepaths
      gtk_css_style_provider_lookup: minor loop optimiziation
      Make _gtk_css_lookup_get_missing inline

Andika Triwidada (1):
      Updated Indonesian translation

Aurimas Äernius (1):
      Updated Lithuanian translation

Benjamin Otte (97):
      cssprovider: Split out theme loading function
      cssprovider: Export gtk_css_provider_load_named) function
      cssprovider: Move fallback code into _gtk_css_provider_load_named()
      settings: Use _gtk_css_provider_load_named()
      menuitem: Draw background unconditionally
      cssimage: Add an equal vfunc
      stylecontext: Don't use bg image in gtk_style_context_set_background()
      cssvalue: Compute "background-size: 0 0" properly
      reftests: Add a reftest for recent commit
      cssimage: Add a warning for drawing empty images
      themingbackground: Restructure code
      themingbackground: Restructure code some more
      themingbackground: Move image variable
      themingbackground: Get rid of flags variable
      themingbackground: Add content_box variable
      themingbackground: Introduce gtk_theming_background_get_box()
      themingbackground: Use get_box() for background image size
      themingbackground: Remove GtkThemingBackgroundLayer
      reftests: Fix linear-gradient reftest
      themingengine: Draw fradctional border sizes
      reftests: Add reftest for fractional border sizes
      themingbackground: Remove struct members
      cssimage: Implement some equal functions
      Raleigh: Fix spinners with disabled animations
      settings: Reset all styles when the enable-animations settings changes
      sizegroup: Always at least use widget's size
      sizegroup: Don't cache the sizes anymore
      sizegroups: Restructure code
      sizegroup: Use for loops
      sizegroup: Check ignore_hidden flag when adding groups
      sizegroup: Don't keep groups around everywhere
      sizegroup: Add a function for clarity
      sizegroup: Handle hfw in size groups
      API: Add gtk_widget_is_visible()
      sizegroups: Use is_visible() instead of get_mapped() for visibility
      sizerequest: Cache sizes without size groups
      sizegroup: Move GtkSizeGroupMode to gtkenums.h
      sizerequest: Export _gtk_widget_compute_size_for_orientation()
      reftests: Make label-sizing tests use better CSS
      reftests: Improve reftest performance
      label: Fix ellipsize and wrap being set
      label: Redo get_preferred_width/height()
      sizerequest: Move optimization
      sizegroup: Use _gtk_widget_compute_size_for_orientation()
      reftests: Add a test for all the recent sizegroup hackery
      reftests: Add a test from evolution
      sizegroup: Construct the set of sizegroup peers as a hash table
      sizerequest: Move sizegroups function to different source file
      sizerequest: Restructure code
      reftests: Mark windows as popup
      reftests: Add test for recent fix
      label: Handle crazy corner cases
      reftests: Add a reftest for latest fix
      cssimage: Fix huge memleak
      Disable deprecation checks for all libraries we depend on on stable branches.
      tests: Include config.h
      gradient: Add color stops to the right gradient
      symboliccolor: Split out HSLA code
      symboliccolor: Change the print output
      cssvalue: Add GtkCssColorValue
      cssstyleproperty: Replace symbolic colors with GtkCssColorValue
      cssimage: Use GtkCssColorValue
      cssvalue: Convert shadows to GtkCssColorValue
      stylecontext: Remove unused function
      stylecontext: Fix a memleak
      label: Fix another sizing corner case causing segfaults
      reftests: Add test for recent fix
      reftests: Add a test for all the color names
      cssvalue: Make shade() work properly again
      bitmask: Fix intersection code
      tests: Add some bitmasks to the hardcoded list
      tests: Add an intersection test for the recent bug
      bin: Only handle size for the child if it is visible
      window: Remove useless functions
      container: Simplify code
      bin: Handle border width if we have to
      reftests: Add a test for border-width problems
      sizerequest: Split out size request cache code into separate header
      reftests: Update named colors reftest
      reftests: Turns out, green changed color
      sizerequestcache: Move functions
      sizerequestcache: Make clear_cache clear all the cache
      sizerequest: Cache the request mode
      widget: Get rid of unused flags
      sizerequestcache: Move commit function
      sizerequestcache: Move lookup function
      sizerequest: Use GtkOrientation
      sizegroup: Simplify comparison
      sizerequestcache: Make code an array
      sizerequestcache: Move rest of code to array
      stylecontext: Add a flag to force style_updated() emission
      sizerequest: Optimize CONSTANT_SIZE better
      Revert parts of "window: Remove useless functions"
      cssprovider: Handle non-existing section
      stylecontext: Split out a function
      cssvalue: Fix copy/paste error
      reftests: Fix linear-gradient reftest (again)

Carlos Garnacho (3):
      texthandle: Fix shape setup on non-composited environments
      texthandles: set input shape on handles' window
      texthandles: Add an extra style class to the cursor-mode handle

Cheng-Chia Tseng (1):
      Updated Traditional Chinese translation(Hong Kong and Taiwan)

Chun-wei Fan (1):
      Visual C++ property sheets: Update GtkBinaryVersion

Cosimo Cecchi (3):
      icon-theme: support loading symbolic GFileIcons from generic URIs
      css: Fix copy/paste error
      text-cell-accessible: fix a double unref

Daniel Mustieles (1):
      Updated Spanish translation

Federico Mena Quintero (6):
      Rename gtk_tree_path_new_from_node() to tree_path_new_from_node()
      Remove argument to _gtk_file_system_model_update_file() that should not be part of the internal API
      Comments on how the filtering and sorting processes work
      Make freeze_updates() and thaw_updates() static functions
      bgo#687196 - Fix model corruption during file removal
      Merge branch 'bgo687196-filesystemmodel-crash'

Fran DiÃguez (1):
      Updated Galician translations

Hib Eris (1):
      Fix compiling for win32

Jasper St. Pierre (3):
      gtkversion.h.in: Put the documentation inside the header guards
      gtkbin: Complete more of a base implementation for GtkBin subclasses
      gtkbin: Remove the silliest code on earth

John Ralls (1):
      Fix typo from f2ab3af

Jonny Lamb (1):
      filechooser: remember sidebar width

Kjartan Maraas (2):
      Updated Norwegian bokmÃl translation
      Updated Norwegian bokmÃl translation

Kristian HÃgsberg (1):
      configure.ac: Look for wayland-client 1.0.0

Matej UrbanÄiÄ (1):
      Updated Slovenian translation

Matthias Clasen (9):
      Bump version
      Add GDK_VERSION_3_8
      Bump GLib dependency to 2.35
      Nuke GtkBoxAccessible
      Update a11y test results
      Avoid infinite recursion in the ime input module
      3.7.2
      Fix parser tests for color changes
      Update expected output for the entries a11y test

Mattias PÃldaru (1):
      [l10n] Updated Estonian translation

Michael Natterer (7):
      quartz: move SPLASHSCREEN-hinted windows to NSStatusWindowLevel
      quartz: filter out button press events on the window frame
      quartz: GdkQuartzWindow -> GdkQuartzNSWindow was forgotten in one place
      quartz: move tooltips window to the topmost level
      quartz: use the real current event time for generated motion events     (cherry picked from commit b4a30877a9315ade584858f7259729dbda614bab)
      Bug 672193 - windows (including menus) shown multiple times don't...
      quartz: always send GDK_NOTIFY_NONLINEAR crossing events

Mike Gorse (2):
      Send a notification when a GtkEntry icon's tooltip text changes
      Add accessibles for GtkEntry icons

Nilamdyuti Goswami (1):
      Assamese translation updatedas.po

Paolo Borelli (2):
      gtkmenubutton: set menu to NULL in dispose.
      gtkmenubutton: remove weak pointer when needed

Piotr DrÄg (4):
      Updated POTFILES.skip
      Updated POTFILES.skip
      Updated POTFILES.skip
      Updated POTFILES.skip

Ran Benita (1):
      wayland: update to work with stable libxkbcommon

RÅdolfs Mazurs (1):
      Updated Latvian translation

Sandeep Sheshrao Shedmake (1):
      Updated Marathi Translations

Stef Walter (1):
      icon-theme: Add some preconditions for NULL arguments

Stefano Facchini (1):
      sizerequest: do not derefence NULL pointers

Sweta Kothari (1):
      Updated gujarati file

Timothy Arceri (1):
      Remove bookmark duplicate of shortcut

Tom Tryfonidis (1):
      Updated Greek translation

Wolfgang Stoeggl (1):
      Updated German translation

ÐÐÑÐÑÐÐÐ ÐÐÐÐÐÐÑ (1):
      Updated Serbian translation



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]