[gtk+] widget: silence g-i scanner warning



commit 8ff9770c7f2e93c4d56f5d33c8c6535bb60ea74c
Author: Cosimo Cecchi <cosimoc gnome org>
Date:   Wed May 30 17:31:57 2012 -0400

    widget: silence g-i scanner warning
    
    The parameter should be named the same in the definition and the
    declararion.
    
    https://bugzilla.gnome.org/show_bug.cgi?id=677127

 gtk/gtkwidget.c |    2 +-
 gtk/gtkwidget.h |    2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)
---
diff --git a/gtk/gtkwidget.c b/gtk/gtkwidget.c
index 1f93340..daee052 100644
--- a/gtk/gtkwidget.c
+++ b/gtk/gtkwidget.c
@@ -1689,7 +1689,7 @@ gtk_widget_class_init (GtkWidgetClass *klass)
   /**
    * GtkWidget::child-notify:
    * @widget: the object which received the signal
-   * @pspec: the #GParamSpec of the changed child property
+   * @child_property: the #GParamSpec of the changed child property
    *
    * The ::child-notify signal is emitted for each
    * <link linkend="child-properties">child property</link>  that has
diff --git a/gtk/gtkwidget.h b/gtk/gtkwidget.h
index 33a54d0..b153dff 100644
--- a/gtk/gtkwidget.h
+++ b/gtk/gtkwidget.h
@@ -229,7 +229,7 @@ struct _GtkWidgetClass
   void (* grab_notify)         (GtkWidget        *widget,
 				gboolean          was_grabbed);
   void (* child_notify)        (GtkWidget	 *widget,
-				GParamSpec       *pspec);
+				GParamSpec       *child_property);
   gboolean (* draw)	       (GtkWidget	 *widget,
                                 cairo_t          *cr);
 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]