[gnome-shell] altTab: Rename AltTabPopup to AppSwitcherPopup



commit aba46720c0e98888562516bff941204b8be10353
Author: Florian MÃllner <fmuellner gnome org>
Date:   Mon Dec 3 16:31:50 2012 +0100

    altTab: Rename AltTabPopup to AppSwitcherPopup
    
    We will add support for a window-based popup in addition to the
    current application-based one, so use a more descriptive name.
    
    https://bugzilla.gnome.org/show_bug.cgi?id=688913

 js/ui/altTab.js        |    4 ++--
 js/ui/windowManager.js |    2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)
---
diff --git a/js/ui/altTab.js b/js/ui/altTab.js
index 95f2bad..e605fd6 100644
--- a/js/ui/altTab.js
+++ b/js/ui/altTab.js
@@ -20,8 +20,8 @@ const THUMBNAIL_FADE_TIME = 0.1; // seconds
 
 const iconSizes = [96, 64, 48, 32, 22];
 
-const AltTabPopup = new Lang.Class({
-    Name: 'AltTabPopup',
+const AppSwitcherPopup = new Lang.Class({
+    Name: 'AppSwitcherPopup',
     Extends: SwitcherPopup.SwitcherPopup,
 
     _init : function() {
diff --git a/js/ui/windowManager.js b/js/ui/windowManager.js
index ef33fbc..b1c33e9 100644
--- a/js/ui/windowManager.js
+++ b/js/ui/windowManager.js
@@ -617,7 +617,7 @@ const WindowManager = new Lang.Class({
         if (this._workspaceSwitcherPopup != null)
             this._workspaceSwitcherPopup.destroy();
 
-        let tabPopup = new AltTab.AltTabPopup();
+        let tabPopup = new AltTab.AppSwitcherPopup();
 
         let modifiers = binding.get_modifiers();
         let backwards = modifiers & Meta.VirtualModifier.SHIFT_MASK;



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]