[gimp] Created tag soc-2012-unified-transform-after-gsoc



The signed tag 'soc-2012-unified-transform-after-gsoc' was created.

Tagger: Mikael Magnusson <mikachu src gnome org>
Date: Mon Aug 20 20:30:58 2012 +0200

    Code after this tag is outside gsoc 2012.

Changes since the last tag 'soc-2012-unified-transform-before-gsoc':

Mikael Magnusson (50):
      transformtool: remove unused function shearvector()
      transformtool: Try to straighten out modifiers
      transformtool: Remove shift-clicking to accept transform since shift is used as a modifier
      transformtool: temp hack to fiddle with drawing interface
      transformtool: Add temporary new handles
      transformtool: Enable hit detection for new handles
      transformtool: Make move op behave as spec
      transformtool: Make rotate op behave as spec
      transformtool: Make rotation axis behave as spec
      transformtool: Make perspective op behave as spec
      transformtool: remove unneeded old stuff, cleanup
      transformtool: Make shear op behave as spec, no frompivot
      transformtool: implement fromcenter constraint for shearing (old spec)
      transformtool: Make corner scale op behave as spec, no frompivot
      transformtool: nonworking naive frompivot for corner scale
      transformtool: corner scale: use full transform machinery to keep pivot constant position, missing some offset maybe
      transformtool: Make basic scale op via side handle behave as spec, no constrain or frompivot
      transformtool: implement aspect constraint for scaling via side handle
      transformtool: Add todo about pivot point
      transformtool: how to draw in screen coords
      transformtool: Show an incredibly helpful message in the statusbar when a handle is hovered over
      transformtool: Add the five options instead of just two
      transformtool: Fix frompivot for cornerscale, only problem is the handle doesn't end up at mouse cursor
      transformtool: Use better method for keepaspect side scaling
      transformtool: Copy the corner scale non-aspect frompivot code to side scale
      transformtool: Add option for locking pivot to canvas, add code to transform the pivot along with all transformations
      transformtool: Add frompivot for perspective handles too
      transformtool: Factor out getpivotdelta() function
      transformtool: Deduplicate code, use more vector representations, fix style and warnings
      transformtool: move assignment of coords to after the logic code, this somehow fixes frompivot perspective
      transformtool: Rename p to d because p is a weird name for a delta/diff
      transformtool: some more cleanup + comments
      transformtool: Add a draw_gui method to the TransformTool class and remove some hack duplication
      transformtool: Add a pick_function method to the TransformTool class and remove some more hack duplication
      transformtool: Check if new transform is convex and don't involve the pivot if it isn't
      transformtool: Update modifier keys for options, solves problem with perspective frompivot + constrain
      transformtool: Add the bunch of 8 separate options for 3 things
      transformtool: use GimpFrame + GtkBox to group the options instead of just putting GtkLabel between them
      transformtool: Add one more rotation handle, in case the point you want to pivot around is close to the first one
      transformtool: Pick move operation anywhere inside polygon
      transformtool: Add back statusbar code (but more helpful) that was deleted when I made pick_function
      transformtool: Remove some annoying duplication and draw perspective handles differently
      transformtool: We show corrective preview for selections and paths, so why not drawables
      transformtool: Be a bit more strict about the pivot being inside the transform frame to use it, to protect against it flying away to infinity
      transformtool: kill rotate and move handle, instead rotate when outside frame (move already works inside)
      transformtool: Use the same method for frompivot for shearing as everything else
      transformtool: Remove now unused variables
      transformtool: Fix indent of switch statement
      transformtool: Set the cursor and tool cursor properly on each handle by way of the new cursor_update method
      app: remove GIMP_TOOL_CURSOR_UNIFIED_TRANSFORM from GimpToolCursorType



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]