[gtk+] Created tag 3.3.2



The unsigned tag '3.3.2' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Tue Oct 25 10:21:48 2011 -0400

    3.3.2

Changes since the last tag '3.2.0':

Adel Gadllah (1):
      gdk: Plug leak in gdk_display_pointer_is_grabbed

Alex Corrado (1):
      Quartz, Bug 655057: Eliminate Compiler Warning

Andrà Gondim (1):
      Fixed some strings in Brazilian Portuguese translation

Antoine Jacoutot (2):
      __SIZEOF_INT__ and __SIZEOF_POINTER__ may not be defined.
      GMountOperation on OpenBSD: remove the need for kvm(3)

Benjamin Otte (60):
      styleproperty: Use the long form to register background-color
      styleproperty: Default to transparent background-color
      styleproperty: Allow 'transparent' keyword for background-color
      cssprovider: Remove unused enums
      reftests: Add a reftest checking background-color: transparent
      tests: Make editing window look more beautiful
      tests: Make testwindows dialog even more beautiful
      tests: Make testwindows use GtkGrid
      tests: Convert testtreeview from GtkTable to GtkBox
      tests: Convert testtoolbar to use a box instead of a table
      container: Warn if an invalid widget path is created
      toolbar: Fix widget path creation code
      tests: Use a box instead of a table in testselection
      tests: Use a grid in testorientable instead of a table
      tests: Use a grid in testnotebookdnd instead of a table
      tests: Convert testmerge from GtkTable to GtkGrid
      tests: Convert testimage example from GtkTable to GtkGrid
      tests: Convert print-editor from GtkTable to GtkBox
      tests: Make prop-editor use a grid instead of a table
      tests: Convert testadjustsize example from GtkTable to box and grid
      tests: Convert testdnd from GtkTable to GtkGrid
      tests: Convert testentryicons example from GtkTable to GtkGrid
      tests: Convert testexpand from GtkTable to GtkGrid
      tests: Convert testgeometry from GtkTable to GtkGrid
      tests: Convert testframe from GtkTable to GtkGrid
      testgtk: Upgrade alpha windows test from GtkTable to GtkGrid
      testgtk: Convert big windows example from GtkTable to GtkGrid
      testgtk: Beautify buttons example
      testgtk: Convert buttons example from GtkTable to GtkGrid
      print: Convert custom paper dialog from GtkTable to GtkGrid
      testgtk: Convert radio/check button examples from GtkTable to GtkGrid
      testgtk: Switch scrolled windows example from GtkTable to GtkGrid
      testgtk: Simplify code
      testgtk: Convert focus example from GtkTable to GtkGrid
      testgtk: Remove invalid property
      testgtk: Move display example from GtkTable to GtkGrid
      testgtk: Move paned example from GtkTable to GtkGrid
      testgtk: Clean up code
      testgtk: Switch progress bar example from GtkTable to GtkGrid
      testgtk: Convert size groups example from GtkTable to GtkGrid
      testgtk: Convert panes example from GtkTable to GtkGrid
      testtoolbar: Fix test to use GtkGrid
      docs: Make infobar code example use GtkGrid instead of GtkTable
      table: Deprecate GtkTable for GtkGrid
      combobox: Remove unused define
      notebook: Remove unused variables
      docs: Fix typo in treeview docs
      tests: Fix a bunch of set-but-unused warnings in the filtermodel test
      a11y: Remove useless check
      a11y: Don't include gtkx when not needed
      tests: Remove handleboxes from testmerge example
      testgtk: Remove handlebox example
      handlebox: Deprecate
      gtk-demo: Don't use tearoff menus
      testgtk: Remove tearoff menus from tests
      menu: Deprecate GtkTearoffMenuItem
      uimanager: Deprecate add-tearoffs property
      filesystemmodel: Add a missing check
      iconcache: Fix gcc warning
      a11y: Hack around infinite loops in parent setting

Brian Cameron (1):
      Fix void function n gtkfontbutton.c so it does not try to return a value.      Fixes bug #661089.

Bruce Cowan (1):
      Updated British English translation

Carles Ferrando (2):
      [l10n]Updated Catalan (Valencian) translation
      [l10n]Updated Catalan (Valencian) translation

Chun-wei Fan (3):
      Bug 660730: Use GStatBuf for portability
      Bug 660730: Win32: Only use _fstat32 if available
      Update VS property sheets

Colin Walters (1):
      build: Strip out -DG_DISABLE_DEPRECATED

Cosimo Cecchi (22):
      mountoperation: fix the build
      notebook: use the current state to get the padding values
      notebook: allow using different padding values for the active tab state
      notebook: really deprecate tab_vborder and tab_hborder
      notebook: unconditionally apply padding to the tab content
      stylecontext: add style classes for top/bottom/right/left areas
      notebook: add top/bottom/left/right style classes to the tab region
      notebook: vborder/hborder deprecations are Since: 3.4, not 3.2
      toolbutton: don't force the icon widget to be a GtkMisc
      GdkWindow: fix conditional jump depends on uninitialized value error
      GtkTreeViewColumn: initialize a variable
      notebook: don't forget to prepare the tab style context before drawing
      box: add some missing includes
      appchooser: add a GCancellable to the search operation
      appchooser: make the "Find applications online" follow search state
      all: add an 'only-child' pseudo-class selector
      reftests: add a reftest for the CSS :only-child selector
      tooltip: add support for opacity and rounded corners for tooltips
      treemodel: document gtk_tree_path_free() as allow-none
      GtkRange: use the right widget for coordinate translation
      notebook: update tab area allocation when switching page
      printunixdialog: fix a GtkTable->GtkGrid typo

Dieter Verfaillie (1):
      win32: fix unterminated #ifdef error

Fran Dieguez (1):
      Updated Galician translations

Hendrik Knackstedt (1):
      Updated German translation

Javier JardÃn (5):
      Replace some references to the GtkTable, use GtkGrid instead
      gtktable: Fix gtk-doc notation
      gdkcreen-x11: Use GdkRGBA instead GdkColor
      gtkbox: Move private functions to private header
      Use G_VALUE_INIT

Jiro Matsuzawa (1):
      Updated Japanese translation

John Ralls (4):
      Bug 628936: Minimal change to pass introspection.
      Bug 658772: Directory paths for resource directories are hard coded.
      Bug 658767 - Drag and Drop NSEvent capture is racy
      Bug 658772: Directory paths for resource directories are hard coded.

Jorge GonzÃlez (1):
      Updated Spanish translation

Kjell Ahlstedt (1):
      GtkTreeViewColumn: dispose: Remove from the treeview

Kristian Rietveld (7):
      Add unit test for part 1 of bug 659022
      Fix first part of bug 659022
      Add two more unit tests for bug 659022
      Bug 659022 - gtk_tree_model_filter_clear_cache_helper: assertion failed
      Fix commit 61d6c73f186a08cd55852c0a44a1704a6fbbbc39
      quartz: also update window position on windowDidResize
      Bug 657770 - Write to released memory in gtkdnd-quartz.c

Matthias Clasen (20):
      Bump version
      Put master on the 3.3 track
      Add new api to gdk.symbols
      Add 'Since 3.4' indices to the docs
      Add G_GNUC_DEPRECATED annotations in GDK
      Add a new symbol
      Include gdk.h in gail.c
      Add deprecation annotations for deprecated functions
      Add deprecation annotations for GtkHandleBox and GtkTable
      DND: Work better with XI2
      Don't refer to --sync anymore
      Distribute tests/css/parser/selector.errors
      Add GtkSwitch to widget-factory
      Fix natural/min widht calculations for empty grids
      Fix handling of GtkCellRendererProgress::inverted
      Add a css parser test for transparent
      Fix make check
      Fix more test breakage
      Updates
      Bump version to 3.3.2

Michael Natterer (23):
      gtk: enable setting virtual modifiers in GtkCellRendererAccel
      gtk: disable mnemonics in gtkrc.key.mac, they don't exist on the Mac     (cherry picked from commit d83c86d42eda7063f7367057ad3afaf01e95c997)
      quartz: resolve the modifier confusion on the Mac
      gtk: use GTK_DEFAULT_ACCEL_MOD_MASK instead of GDK_CONTROL_MASK in gtkstock.c
      gtk: fix entering of Option-foo symbols on the Mac
      gtk: allow to specify accelerators in a platform-independent way
      gtk: use GTK_NO_TEXT_INPUT_MOD_MASK also in gtkfilechooserdefault.c     (cherry picked from commit b057a311e76a90a120ca0e9597bedeb9fc89b0b2)
      app: abstract which modifiers are used for extending and modifying selections
      Bug 659406 - Abstract what triggers a context menu
      Bug 659602 - Provide an abstraction for the platform's use of modifier keys
      gtk: remove the private GTK_NO_TEXT_INPUT_MOD_MASK
      gtk: remove the private GTK_EXTEND/MODIFY_SELECTION_MOD_MASK
      GtkSettings: fix compile warnings on != X11
      Bug 659406 - Abstract what triggers a context menu
      quartz: don't filter away directly encoded 24-bit UCS characters
      gtk: use the new modifier API instead of GTK_DEFAULT_ACCEL_MOD_MASK
      gdk: fix gdk_keyval_to_lower/upper() for Quartz, Win32 and Broadway
      gtk: remove the private GTK_DEFAULT_ACCEL_MOD_MASK define
      gdk: s/gdk_cursor_unref/g_object_unref/
      quartz: don't return FALSE from GdkDevice::query_state()
      gtkquartz: don't free the string returned by get_bundle_path()
      gtk: clean up the private horror
      gtk: move _gtk_modules_has_mixed_deps() to gtkmodlesprivate.h

Nguyán ThÃi Ngác Duy (2):
      po/vi: import from Damned Lies
      Updated Vietnamese translation

Petr Kovar (1):
      Update Czech translation

Piotr DrÄg (1):
      Updated POTFILES.skip

Rachid (1):
      Updated Dutch translation by Rachid

Rodolfo Ribeiro Gomes (1):
      Fixed some strings in Brazilian Portuguese translation

Rui Matos (3):
      docs: Delete duplicate line in gdkwindow.c
      gtkwindow: Clean up gtk_window_map()
      tooltip: only update shape if the window is realized

Sebastian PÃlsterl (1):
      Fixed referenced images for GTK_STOCK_INDENT

Sjoerd Simons (1):
      Fix document generation in out of tree builds

Stef Walter (1):
      gtk: GtkToolbar returns invalid paths when adding tool items

Tiffany Antopolski (1):
      Updated Esperanto translation

Torsten SchÃnfeld (1):
      gtk: fix syntax of an annotation

Tristan Van Berkom (2):
      Fixed gtk_cell_area_stop_editing() to properly notify when editing is not canceled
      GtkComboBox: Add the format-entry-text signal.

Wouter Bolsterlee (1):
      Updated Dutch translation by Wouter Bolsterlee

Yaron Shahrabani (1):
      Updated Hebrew translation.

YunQiang Su (1):
      update zh_CN translation

ÐÐÑÐÑÐÐÐ ÐÐÐÐÐÐÑ (1):
      Updated Serbian translation



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]