[gtk+] Created tag 3.3.4



The unsigned tag '3.3.4' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Mon Nov 21 18:14:35 2011 -0500

    3.3.4

Changes since the last tag '3.3.2':

Akira TAGOH (1):
      Allow fallback for input method modules

Alexander Larsson (63):
      Make sure we only show icons in the file selector bookmarks toolbar
      Add include to fix the build
      Fix build by adding include
      win32: Fix up initialization order of input subsystem
      win32: Update input device code to use the new property names in constructor
      win32: Handle implicit grabs
      win32: in window_at_pointer, ensure that we handle non-client areas correctly
      win32: Use right native_window for implicit grabs
      win32: Record the native event mask in use
      win32: Better crossing events and grab destination reporting
      win32: Fix up window_show
      win32: Handle all window changes in WINDOWPOSCHANGED
      win32: Fix missed resize exit message
      win32: Remove most special casing of WINPOSCHANGED during modal ops
      win32: Ignore client requested window move/size during SIZEMOVE
      win32: Send initial configure
      win32: Send window-state-changes before configure events
      win32: Make set_keep_above work also for non-mapped windows
      win32: Don't remove the window from the handle table on destroy
      win32: Use WM_NCDESTROY instead of WM_DESTROY
      win32: Fix size or style changes during fullscreen
      win32: By default, allow windows larger than the screen
      win32: Ensure we always send a configure event when changing size/pos
      win32: More robust way to ensure we get a configure event after move/resize
      win32: Add custom placements for some window types
      win32: Make flush/sync work like in X
      win32: Don't use API_CALL for SetWindowLong
      win32: Fix modal_hint handling
      win32: Add gdk_win32_window_get_impl_hwnd
      win32: Fix synaptics trackpad issues
      win32: Fix placement at initial position
      win32: Ensure newly mapped toplevels are inside the workarea
      win32: Hack to make statusbar menus show up visible:
      win32: Fix some warnings
      win32: Fix gdk_win32_window_translate
      win32: Make grab cursors work again
      ref, don't unref, requestor member when copying GdkEvents
      win32: make fixup_event correctly ref all GdkWindow members
      Save a generic boxes source in GtkImageBorder
      Add GtkStylePropertyContext and use it in when getting style properties
      Remove _gtk_style_properties_peek_property
      Actually pass in a StylePropertyContext when getting images
      make _gtk_style_property_resolve copy the result to an output value
      Add initial cut at win32 theme support for CSS
      win32-theme: Support -gtk-win32-size CSS value
      Render background image if set for checks and options
      win32-theme: Support multiple parts being combined
      Add top/left/bottom/right style classes to steppers
      Set top/bottom style classes on spinbutton buttons
      Add pulse style class and use in progress bar and entry
      Add support for win32 theme colors as symbolic colors
      win32-theme: Support mixing parts
      win32-theme: Add gtk-win32.css
      Build gtkwin32css.h from gtk-win32.css
      Build in default win32 css as gtk-win32
      win32: Default to gtk-win32 theme
      Merge branch 'win32-theme2'
      win32-theme: Fix up docs for gtk_symbolic_color_new_win32
      Add gtk_symbolic_color_new_win32 to gtk.symbols
      Convert gtk-win32.css to unix line endings
      win32: Make gdk_drag_context_new static
      win32: Don't dereference keyboard_grab if it is NULL
      win32: Don't double free stuff when finalizing drag context

Arnaud Charlet (1):
      win32: fix typo in msw_style.c

Bastien Nocera (13):
      gdk: Make gen-keyname-table.pl work again
      gdk: Translate keyboard brightness keys
      tests: Store keycode in tree for testaccel
      gtk: Fix XIGrabKeycode usage
      gtk: Add accel with keycode parsing functions
      gtk: Add test program for keycode parsing
      tests: Disable accel test until fixed
      gtk: Fix GtkCellRenderer ignoring keycodes
      gtk: Fix parsing of accelerators with keycodes
      Revert "tests: Disable accel test until fixed"
      tests: Check "without keycode" code path too
      gtk: Parse keypad numbers correctly
      tests: Add tests for keypad keys parsing

Benjamin Moody (1):
      Mark gtk_dialog_new_with_buttons as NULL-terminated

Benjamin Otte (116):
      box: Fix includes so hbox/vbox compile warning-free
      tests: Remove unused variables
      x11: Don't use deprecated function
      x11: Do fallback resize without deprecated functions
      display: Don't use deprecated functions
      gdk: Move a bunch of deprecated code to a new file
      fontsel: Define GDK_DISABLE_DEPRECATION_WARNINGS
      handlebox: Define GDK_DISABLE_DEPRECATION_WARNINGS
      table: Define GDK_DISABLE_DEPRECATION_WARNINGS
      iconview: Keep the device for dnd autoscroll
      tooltip: Remove unused variables
      tooltip: Don't use deprecated API
      tests: Disable fontselection deprecation warnings
      gtk-demo: Don't use deprecated code
      assistant: Work around deprecation warnings
      button: Don't call deprecated functions
      cellrendererspinner: Include correct header
      cellrendererspinner: Ignore deprecation warnings
      icontheme: Get rid of deprecation warnings
      treeview: Fix warnings from fixing warnings
      window: Fix cast warnings
      immodule: Fix includes
      immodule: Move private functions to a private header
      build: Don't append to an accidentally existing file
      gtk: Empty gtkimmodule.h
      immodule: Disable deprecations before including deprecated header
      layout: Work around deprecation warnings
      settings: Disable deprecaion warnings for deprecated header
      queryimmodules: Disable deprecaion warnings for deprecated header
      menuitem: WOrk around deprecation warnings
      paned: Remove MOTION_HINT_MASK
      paned: Pass x/y position to update_drag()
      treeview: Remove call to gtk_widget_get_pointer()
      widget: Deprecate gtk_widget_get_pointer ()
      widget: Don't use deprecated symbols
      treeview: Remove unused crack code
      queryimmodules: Actually fix deprecation warnings
      gtk-demo: Remove excessive pointer querying
      treeview: Do a simple replace for gdk_window_get_pointer()
      testgtk: Don't use deprecated functions in properties example
      testgtk: Remove deprecations from shapes test
      exanmples: Don't use deprecated API
      tools: Work with deprecated APIs
      demos: Remove non-working code
      a11y: It's not a bug if there's no row at some point
      a11y: Fix gcc warning
      a11y: Get rid of gtk.h includes in headers
      treeview: Only compute parity once when rendering
      treeview: Remove special cases when computing parity
      treeview: Make the parity actually store the row number
      treeview: Rename "parity" to "total_count"
      treeview: Add _gtk_rbtree_find_index()
      a11y: Re-implement gtk_tree_view_accessible_get_n_rows()
      a11y: Remove idle handler for focus notifications
      a11y: Add _gtk_cell_accessible_parent_get_child_index()
      a11y: Add a special-case for cell index querying
      a11y: Change function declaration
      a11y: Make the cache lookup function inefficient
      gtk: Fix compiler warnings from include fixes
      a11y: Implement get_child_index in treeviewaccessible
      a11y: Implement get_child_index in treeview
      a11y: Don't use the cell's index anymore
      a11y: Remove index from cellaccessible
      a11y: Store the cellinfo in the cell's qdata
      a11y: Implement find_cell_info() using qdata lookup
      a11y: Improve cell_infos table
      a11y: Don't garbage collect anymore
      a11y: Remove in_use member
      a11y: Mark object as defunct in destroy notify
      treeview: Remove unnecessary variable
      a11y: Add a cell_info_get_path() function
      a11y: Remove needless checks
      widget: Add _gtk_widget_peek_accessible()
      treeview: Redo row tracking
      tests: Ensure the treeview is expanded
      a11y: Redo indexing
      a11y: Compute index the easy way
      treeview: Add _gtk_rbtree_node_get_index()
      a11y: Compute the cell index quicker
      a11y: Add a hash function for cell infos
      a11y: Make find by index lookup use the hash table again
      a11y: Don't crete cell infos for non-children
      a11y: Remove clean_rows function
      a11y: remove useless argument
      tests: Up the ante
      treeview: Minor beautification
      treeview: Simplify a check
      a11y: remove argument from get_column_number()
      a11y: Fix get_column_index()
      API: treeview: Add gtk_tree_view_get_n_columns()
      a11y: Use gtk_tree_view_get_n_columns()
      tests: Don't dump stuff twice for tables
      tests: Add checks for row/column index to accessibility-dump
      tests: Add an invisible column to the tree test
      a11y: Unify column-by-index getting
      treeview: Call a11y functions for culmn changes directly
      a11y: Merge function into only caller
      viewport: Don't unset the adjustment on finalize
      viewport: Initialize the adjustment in the init function
      viewport: adjustments are never NULL
      viewport: Don't use deprecated functions
      viewport: Get rid of deprecation warnings
      rbtree: Make debug functions private
      rbtree: Mark all debug sections as debug
      rbtree: Add assertions to clarify usage
      rbtree: Don't set variable twice
      rbtree: Split out a common function
      rbtree: Use gtk_rbnode_adjust()
      rbtree: Use gtk_rbnode_adjust() more
      rbtree: Use gtk_rbnode_adjust() more.
      rbtree: Use gtk_rbnode_adjust()
      rbtree: Use gtk_rbnode_adjust() even more
      rbtree: Move to an approach where we don't move contents
      rbtree: Add a local variable
      rbtree: Don't write to nil node
      tests: Add a test for the rbtree code.

C. Scott Ananian (1):
      Fix uninitialized digest_len field, causing WebSocket handshake to g_assert.

Chun-wei Fan (1):
      Add G_ENABLE_DEBUG #ifdef check in gdkdisplay-win32.c

Colin Walters (1):
      introspection: Include deprecated headers for scanner too

Cosimo Cecchi (9):
      iconview: layout items immediately when setting a GtkTreeModel
      themingengine: set the cairo extend to PAD when we're stretching bg
      treeview: factor out gtk_tree_view_ensure_background()
      treeview: use gtk_tree_view_ensure_background() consistently
      notebook: make sure to allocate the CSS border width
      frame: add GTK_STYLE_CLASS_FRAME in _init()
      frame: make sure to allocate the CSS border width
      notebook: properly subtract the initial_gap width from the tab space
      notebook: use the current page allocation when computing the redraw area

Dieter Verfaillie (8):
      win32: dnd should not be registerd for offscreen windows
      win32: Fix DnD when drag icon is below the pointer
      win32: Call GetQueueStatus instead of PeekMessage PM_NOREMOVE
      win32: add TODO mentioning GtkButton::child-displacement-x & y should be 0 when XP theme is active
      win32: correctly handle difference between tab_pos and gap_side when drawing an extension (notebook tab)
      win32: fix some typos
      win32: fix pasting screenshots taken with PrintScreen or Alt+PrintScreen
      win32: get rid of GdkDragContextPrivateWin32 and related machinery.

Emmanuele Bassi (2):
      radiotoolbutton: Fix the annotation for get_group()
      radiotoolbutton: Fix the introspection annotations

Florian MÃllner (1):
      menuitem: Always treat submenus as popup

Guillaume Desmottes (2):
      gtktreeviewaccessible: factor out cell_info_free()
      gtktreeviewaccessible: use a value_destroy_func with the cell_info_by_index hash

Hans Breuer (1):
      win32: Resurrect some enter/leave notify events for native windows

Javier JardÃn (1):
      gtk/gtkapplication.c: Fix typo

John Ralls (6):
      [Quartz Bug 663182] NSImage throws an exception from _gtk_quartz_create_image_from_pixbuf()
      Fix accidental paste error in 8216324
      Revert "[Quartz Bug 663182] NSImage throws an exception from _gtk_quartz_create_image_from_pixbuf()". Utterly screwed up. Sorry.
      [Quartz Bug 663182] NSImage throws an exception from _gtk_quartz_create_image_from_pixbuf()"
      [Bug 664238] GTK apps crash when dragging something
      [icons] text-x-generic isn't a generated icon

Jorge GonzÃlez (1):
      Updated Spanish translation

Kjell Ahlstedt (1):
      Maintain map/unmap invariants in GtkRecentChooserDialog

Kristian Rietveld (12):
      quartz: remove unused variable
      quartz: Separate out screen_point conversion in function
      quartz: Factor out toplevel from NSEvent code into function
      quartz: Process motion events within windows bounds without window set
      quartz: make test_resize () conform to coding style
      quartz: make gdk_quartz_osx_version conform to coding style
      quartz: use get_toplevel_from_ns_event in one more place
      Bug 661997 - Gtk crashes when changing the TreeView model while ...
      quartz: do not call gdk_drag_begin() twice
      quartz: fix coding style in quartz-version of gtk_drag_begin_internal
      Bug 660554 - gtk_tree_view_drag_begin: assertion `path != NULL' failed
      Don't call scroll to cell if the tree view is empty

Marc-Andrà Lureau (4):
      Rename s/GtkCssRepeatStyle/GtkCssBorderRepeatStyle/g
      css: start background-repeat
      reftests: Add a reftest for background-repeat css property
      win32: resurect Windows clipboard selection notification

Martin Pitt (2):
      Fix gtk_tree_view_get_tooltip_context() transfer annotation
      Fix GDK linking for Gtk typelib and example builds

Matthias Clasen (62):
      Post-release version bump
      Fix gtk_grid_attach_next_to
      Update grid tests to match
      Print dialog: small keynav improvement
      GtkSearchEngineSimple: adapt the GLib thread api changes
      GDK: Adapt to GLib thread api changes
      Don't use deprecated Pango api
      Don't use g_value_set_char
      Don't use deprecated Pango api
      Don't use deprecated GValue api
      Don't use *_DISABLE_DEPRECATED
      Don't use *_SINGLE_INCLUDES defines
      Don't use *DISABLE_DEPRECATED guards
      Drop DISABLE_DEPRECATED guards here, too
      Move gtk_draw_insertion_cursor out of gtkstyle.[hc]
      Move wholly deprecated files to a subdirectory
      Move gtkstyle and gtkrc to deprecated/
      Don't warn about deprecations in deprecated/
      Move deprecated gtkwidget style api to gtkstyle
      Don't warn about deprecations in deprecated/
      Remove various internal uses of deprecated api
      Remove one instance of gdk_window_get_pointer
      Remove some more uses of gdk_window_get_pointer
      Revert a change to the plug/socket headers
      Fix make check
      GdkDeviceManager: some reshuffling of docs
      Add device-taking variants of begin_resize/move_drag
      win32: Adapt to GdkWindowImpl api change
      Quartz: Adapt to GdkWindowImpl api change
      Broadway: Adapt to GdkWindowImpl API change
      Wayland: Adapt to GdkWindowImpl api change
      GtkWindow: Use new begin_resize_drag api
      Pop up context menus at the right device
      Drop references to g_thread_init()
      Drop use of GDK_DISABLE_DEPRECATED guards in gdk
      Drop use of GDK_DISABLE_DEPRECATED guards in gtk
      Add a missing include
      Don't add -DGSEAL_ENABLE to CFLAGS anymore
      Update documentation around deprecations.
      Don't use G_ERRORCHECK_MUTEXES anymore
      Remove some redundant verbosity
      treeview: Work around deprecations
      uimanager: Work around deprecations
      GtkProgressbar: respect the range of 'fraction'
      Add a link to the Windows port wiki page
      Add some keybindings to the a11y entries test
      Add combobox a11y tests
      GtkComboBoxAccessible: Make keybindings work
      GtkTextViewAccessible: Respect display lines
      Avoid double inclusion of a migration chapter
      Update comment to new realities
      Drop the Beagle search engine
      Updates
      Fix the build
      Add a missing static
      Remove leftover debug spew
      Improve AtkText implementations
      Adapt iconview a11y test output
      Prevent local filesystem influence in the a11y tests
      Drop uses of @returns syntax
      More updates
      3.3.4

Michael Meeks (1):
      broadway: Initial support fro V7+ websockets

Michael Natterer (13):
      gtkrc.key.mac: remove half the file, it was an accidential double paste     (cherry picked from commit 79a92f99a9dbdc7b1a651b0e8665807bd89c6632)
      gtkrc.key.mac: add Command-cursor text navigation
      quartz: handle recursive CFRunLoops
      gdk: exclude MOD1 from the virtual modifier mapping
      Bug 663605 - Fix event->state of many event types on quartz
      quartz: include all buttons' states in GdkEventButton.state     (cherry picked from commit a381e8ea62441b6715ba9bcb0e04332fd914f8b1)
      quartz: include all buttons' state in GdkEventMotion.state     (cherry picked from commit 3b5c5710daa337b61c9e2135e3e55c380e5bc991)
      quartz: fix a race condition when waking up the CGRunLoop
      notebook: don't leak the action widgets
      Bug 663856 - Make option-foo accelerators use the right symbol
      Turn the private #define for the group-shifting modifier into API
      gdk_x11_keymap_get_modifier_mask(): always return a value
      gdk: remove the GET_EFFECTIVE_KEYMAP() stuff from gdkkeys-x11.c

Michel DÃnzer (1):
      Fix gdk_cairo_region_create_from_surface on big endian

Morten Welinder (2):
      Print preview: make cancel work
      win32: Actually check for IPrintDialogCallback in configure

Murray Cumming (1):
      Fix tiny docs typo.

Neil Roberts (1):
      win32: Never pass SWP_NOSIZE or SWP_NOMOVE to SetWindowPos

Peter Clifton (2):
      Win32: Ensure native back-end for windows where the user requests their handle
      Win32: Fix _gdk_windowing_window_at_pointer to correctly return a toplevel

Piotr DrÄg (1):
      Updated POTFILES.in

Rico Tzschichholz (1):
      Fix some implicit declaration warnings

Rui Matos (5):
      x11: Fix window manager change detection
      gdk: Add GDK_WINDOW_STATE_FOCUSED to GdkWindowState
      x11: Implement GDK_WINDOW_STATE_FOCUSED on top of _NET_WM_STATE_FOCUSED
      gtk: Add a GTK_STATE_FLAG_WINDOW_UNFOCUSED widget state flag
      Bug 653676 - Expand/Collapse doesn't respond after one click

Ryan Lortie (1):
      Don't implement GApplication mainloop

Stef Walter (1):
      GtkSpinButton: Clarify clamping behavior in gtk_spin_button_set_range doc

Torsten SchÃnfeld (2):
      gtk: add annotations for some GtkSymbolicColor constructors
      gtk: add annotations for some GtkRadio* constructors

Xan Lopez (1):
      treeview: fix the build

Yuri Kozlov (1):
      Fixed Russian translation



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]