[gtk+] Created tag 3.1.4
- From: Matthias Clasen <matthiasc src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gtk+] Created tag 3.1.4
- Date: Sat, 7 May 2011 17:04:21 +0000 (UTC)
The unsigned tag '3.1.4' was created.
Tagger: Matthias Clasen <mclasen redhat com>
Date: Sat May 7 13:03:31 2011 -0400
3.1.4
Changes since the last tag '3.1.2':
Abduxukur Abdurixit (4):
Added UG translation
Added UG translation
Added UG translation
Added UG translation
Alberto Ruiz (2):
Adding introspection annotation to GtkModuleIinitFunc to specify array and length parameters
Adding allow-none introspection annotation for GtkInitFunc parameters
Alexander Larsson (14):
[broadway] Implement keyboard event better
[broadway] Emulate hardware keycodes in keyboard events
[broadway] Handle keyboard modifiers in state
[broadway] Correctly handle ungrabs in the browser side
[broadway] Ungrab if grabbed window is destroyed
[broadway] Remove window from hashtable when destroyed
[broadway] Implement gdk_window_begin_resize_drag
[broadway] Make close button text unselectable
[broadway] Report most special keys in keypressed
[broadway] Implement wm close in browser
[broadway] Remove old demo code
[broadway] Stream data over websocket
[broadway] Use cairo to generate png uris
[broadway] Remove debug spew
Arnel Borja (1):
Bypass libtool for linking with libuuid on win32
Benjamin Otte (109):
testgtk: Make it possible to stop the progressbar from updating
sizerequest: return CONSTANT_SIZE in return_if_fail()
cssprovider: Use g_type_depth() instead of computing the depth manually
label: we can't ignore sizes on ellipsized labels
window: cast value so gcc shuts up
menushell: Include a function in the private header
docs: Fix wrong description for query-tooltip
window: Only draw the resize grip if it is actually visible
entry: Add the ability to query frame size in two ways
entry: Use the new get_frame_size() argument in gtk_entry_draw_frame()
entry: Fix gtk_entry_get_icon_at_pos()
cssprovider: Move private struct definition to header
docs fix typo
paned: Generalize code
paned: Implement get_width_for_height() and get_height_for_width()
paned: Cleanup size_allocate()
paned: Use hfw queries during allocation
label: Don't care about aux info
widget: Make gtk_widget_get_aux_info() private
label: Don't try to guess a label's size
label: Remove duplicated comment
label: Set wrap on the layout unconditionally
label: Redo size computation
label: Don't use a rectangle variable if we don't use a rectangle
label: Set the height of the label when ellipsized or wrapped
label: Remove wrap width leftovers
label: Pass the desired height to measuring layout
label: Request more natural size for ellipsizing wrapping labels
label: No need to special case single-line mode
docs: Strictify the docs for gtk_cairo_should_draw_window()
entry: Remove needless check
entry: Guard clipping with a save/restore
entry: Omit useless clip
entry: Move cairo_save() call for clarity
entry: Split out style-updating things into their own function
entry: g_object_notify*( when we change the invisible char
entry: Initialize cached values
entry: Also update cached style values when the state changes
entry: No need to queue a redraw on state changes
entry: Translate progress region properly when drawing text
label: Fix an invariant leading to required > minimum
widget: Add hack to make label mnemonics work again
window: Use int instead of uint consistently
window: Split out size guessing function
window: Be smarter about computing the default size
tooltip: Use the actual size of the window we're going to show
cssprovider: #include gio
grid: Fix homogeneuous properties being flipped
label: Don't crash when a builder file contains unknown attributes
window: Make comparison be the right direction
recentchooser: Fix default size setting
notebook: Warn if builder file defines multiple tab widgets per page
widget: Warn when allocation for gtk_widget_size_allocate() is too small
paned: Remove needless check
paned: Move showing of the handle from realize() to map()
widget: Update underallocation warning
docs: Fix liststore docs
widget: Allow underallocation for scrollables
arrow: Make minimum size 5px, as opposed to the 15 it was before
window: Invert check that was wrong
notebook: Use the right padding for inactive tabs
Don't adjust for values that we have previously adjusted for
notebook: Respect padding when computing tabs for left/right
notebook: Respect left border when allocating tab widgets
notebook: Match horizontal and vertical code paths
menubar: Compute proper size even when invisible
imagemenuitem: No need to query image size by default
menubar: Remove unused variable
menubar: Remove useless function declaration
menubar: Remove unnecessary return_if_fail() in vfuncs
menubar: Change function prototype for size request function
menubar: compute in advance wether to add toggle size
menubar: Only compute the necessary size
menubar: Query only the necessary size from the child
menubar: Actually query minimum and natural size of children
menubar: Implement height-for-width / width-for-height
settings: Recompute styles when font name changes
tests: Make testmenubars make all menubar items ellipsized
menubar: Respect ipadding also in y direction
menubar: Only query ipadding when we actually need it
menubar: Rewrite size allocation to take natural sizes into account
window: Remove overeagerness with new size guessing
accellabel: Only daw accelerator after natural size has been reached
window: Make non-resizable windows use default size for geometry hints
gtk-demo: Don't right-justify menu items
testgtk: right-justify menuitem by using expand/align flags
menuitem: Deprecate gtk_menu_item_set_right_justified()
cellarea: Fix warning messages to display the right type
accellabel: Remove leftover debug code
label: Allow using more underline modes
reftests: Add
reftests: Add label-sizing test
reftests: Add a test for correct entry text clipping in progress drawing
reftests: Add grid-homogeneous test
tests: Add a test for small ellipsized labels
reftests: Test that nonresizable windows get the right size
reftests: Add test for low mnemonics
reftests: Add a --output option to the test runner
reftests: Add a test for grid expand flags
reftests: Add test for box expand handling
reftests: Plug a leak
reftests: Add a hack to make toplevels work in various WMs
reftests: Ensure we got a draw event before quitting the main loop
reftests: Add a test that ensures toplevels and popups render identical
reftests: Fix filename in makefile
label: Compute label offset properly for wrapped justified labels
reftests: Add testcase for label justify fix
reftests: Add missing css file for grid-expand test
Revert "arrow: Make minimum size 5px"
Carlos Garnacho (1):
GdkWindow: Fix gdk_window_set_[device_]cursor() issues with root/foreign windows
Chun-wei Fan (10):
Add gdk_win32_window_get_type into gdk.symbols
Update gtk/gtkmenuitem.c...
Update build/win32/vs9/README.txt
Update VS 2008 support to use ATK-2.0
Update build/win32/vs9/README.txt
VS2008 support: Process filechooser gsettings xml
Bug 643270: VS 2010 Project Files
Bug 643270: VS2010 Project Files (autotools)
VS2008/2010 support: Update README.txt
VS2010 support-update property sheet
Colin Walters (5):
updateiconcache: Don't translate g_warning/g_error
Drop the last remaining translated g_warning/g_error calls
gtkimageprivate: Drop unused theme_change_id
gtkdnd: Add API that takes GIcon
gtkicontheme: More explicitly note ownership transfers of duplicated string
Cosimo Cecchi (3):
cellrendererprogress: don't force drawing inside the border
progressbar: fetch the padding without the trough style class
testassistant: don't use deprecated functions
Daniel Mustieles (2):
Updated Spanish translation
Updated Spanish translation
David King (1):
widget: add Since tags for margin accessors
Fran Diéguez (1):
Updated galician translations
Gintautas Miliauskas (1):
Updated Lithuanian translation.
Giorgos Stephanakis (1):
l10n: Updated Greek translation for gtk+
Ignacio Casal Quinteiro (1):
[textview] remove idles when unmapping
Javier Jardón (41):
Move documentation to inline comments: GtkToggleToolButton
Move documentation to inline comments: GtkFileChooserButton
Move documentation to inline comments: GtkFileChooserDialog
Move documentation to inline comments: GtkFontSelection
Move documentation to inline comments: GtkHandleBox
Move documentation to inline comments: GtkIconFactory
Move documentation to inline comments: GtkIconTheme
Move documentation to inline comments: GtkListStore
Move documentation to inline comments: GtkLabel
Move documentation to inline comments: GtkToolButton
Move documentation to inline comments: GtkMenuToolButton
Move documentation to inline comments: GtkHSV
Move documentation to inline comments: GtkRadioToolButton
Move documentation to inline comments: GtkTextMark
Move documentation to inline comments: GtkRadioMenuItem
Move documentation to inline comments: GtkPrintContext
Move documentation to inline comments: GtkPrintSettings
Move documentation to inline comments: GtkPrintUnixDialog
Move documentation to inline comments: GtkTextBuffer
Move documentation to inline comments: GtkSizeGroup
Move documentation to inline comments: GtkToggleButton
Move documentation to inline comments: GtkTreeModelSort
Move documentation to inline comments: GtkDnd
Move documentation to inline comments: GtkWindowGroup
Move documentation to inline comments: GtkFontSelectionDialog
Move documentation to inline comments: GtkMenuItem
docs: Remove no longer needed template files
Move documentation to inline comments: GtkUIManager
Move documentation to inline comments: GtkRc
docs: Do not generate the template files anymore
tests: Use gtk_box_new() instead v/h subclasses
docs/tools/widgets.c: Use GdkRGBA instead GdkColor
docs/reference/gtk/text_widget.sgml: Use GdkRGBA instead GdkColor
gtkcalendar: Remove unused variable
docs: Remove documentation about deprecated and removed GtkText
gtkbuilder.c: gtk_builder_value_from_string() also support GdkRGBA values
tests/testgtk.c: Fix crash in cursor test
gdk/x11/gdkcursor-x11.c: Use GdkRGBA instead GdkColor
gtk/gtktrayicon-x11.c: Use GdkRGBA instead GdkColor
configure.ac: Bump glib minimum required version to 2.29.2
configure.ac: Indeed the minimum required version is 2.29.4, not 2.29.2
Kalev Lember (2):
perf: Use different marshaller prefix than in gtk
Disable gtk-update-icon-cache.exe.manifest with --enable-gtk2-dependency
Kizito Birabwa (1):
Updated Luganda translation
Kristian Rietveld (6):
Merge two if-blocks with same condition
treeview: Avoid queueing a redraw in do_validate_rows()
treeview: if we are below rows that changed height: redraw
treeview: Do not unconditionally set width_changed to TRUE, which redraws
tooltips: treat scroll events like key/button press instead of motion
GdkWindow: remove unused variable
Lapo Calamandrei (1):
[broadway] New adwaita based css for "wm"
Martin Pitt (1):
GdkWindow: Add missing (allow-none) annotations
Matthew Barnes (2):
Desensitize "Select All" when GtkEntry is empty
GtkComboBox: Improve gtk_combo_box_set_active_id
Matthias Clasen (34):
Bump version
GtkTimeline: don't look when animations are disabled
Don't leak a list when activating keybindings
Fix commit 5f55c420471db9a05d145e140b3a7cdfc5bdba9f
GtkEntry: Explicitly disconnect keymap signals
Fix the build
GtkWidget: avoid an unused variable warning
Convert the commit message into a README
Add a box-packing reftest
Expand box-packing reftest
Fix box-packing test
GtkButtonBox: add a non-homogeneous child property
More box<>grid comparison tests
Add a misc-alignment reftest
Expand GtkMisc tests to cover arrows and images
Add an alignment property test
Some additional auto-mnemonic fixes
gtk-demo: Don't leave a dangling pointer to a destroyed widget
Add gtk_container_child_notify
Silently allow child properties on grandchildren
testassistant: some more tests
GtkAssistant: an new style for assistants
gtk3-demo: assistant demo simplications
Remove outdated comments
Add a lock button widget
Update the NEWS for 3.1.4
More updates
Add a new forgotten symbol
Drop missing tests
Distcheck fixes
Fix a typo in !HAVE_XCURSOR code paths
Work around testsuite failures for distcheck
Another distcheck fix
3.1.4
Michael Natterer (1):
gdk: add precondition checks to all GdkKeymap functions
Paolo Borelli (3):
Free MenuPopulateData struct in all the cases.
Factor out a get_char_pixels method for clarity.
Small cleanup in label sizing code.
Rui Matos (1):
GtkWindow: set mnemonics visible on focus in if modifier is pressed
Stéphane Maniaci (1):
Make GtkFileChoser remember the last directory opened
Tristan Van Berkom (7):
Added GdkRGBA properties to GtkTextTag.
Fixed textview rendering regression.
Handled error_color with GdkRGBA in gtktextdisplay.c.
Fixed GtkTextTag to sync the GdkColors with the new GdkRGBA values for backwards compatability.
Added internal GdkRGBA support for GtkTextTag::paragraph-background-rgba
Added Since 3.2 annotations for new GdkRGBA properties.
Adding more traditional checkered background to testtextview.
Xavier Claessens (1):
Do not call invalidate_empty_focus() when not realized
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]