[glib] Created tag 2.29.4



The unsigned tag '2.29.4' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Wed May 4 21:24:45 2011 -0400

    2.29.4

Changes since the last tag '2.29.2':

Abduxukur Abdurixit (2):
      Added UG translation
      Added UG translation

Alexander Larsson (2):
      GFilterInputStream: close-base-stream should not be construct-only
      gdbus-codegen: Make sure we pass -Werror

Behdad Esfahbod (3):
      Bug 648966 - Update g_unichar_iswide and g_unichar_iswide_cjk
      [build] Remove stale LDADD lines from tests/Makefile.am to allow build
      Bug 648966 - Update g_unichar_iswide and g_unichar_iswide_cjk

Benjamin Otte (6):
      testutils: Return a boolean from g_test_case_run()
      testutils: Remove unused variable
      testutils: Return number of bad tests from g_test_run_suite_internal()
      testutils: Sprinkle code with newlines
      API: testutils: Add g_test_fail()
      gobject: Warn if someone uses the wrong property in g_object_get/set

Christian Persch (1):
      Use G_SIGNAL_MUST_COLLECT for VARIANT signals

Chun-wei Fan (3):
      Add VS 2010 compilation support for some utilities
      Add VS 2008 compilation support for some utilities
      Update VS2008/2010 README.txt

Colin Walters (21):
      gdbusconnection: Avoid tripping assertion if we fail to authenticate twice
      gapplication: Fix typo in property
      Fix some compiler warnings from gcc 4.6
      Squash some uninitialized variable compiler warnings
      GDesktopAppInfo: Add "filename" property for bindings
      GDesktopAppInfo: Add g_desktop_app_info_get_categories()
      GDesktopAppInfo: Add g_desktop_app_info_get_generic_name
      Update gio.symbols for previous two commits
      glib-unix: New Unix-specific API
      gmain: Prepare child watch handling for more generic signal handling
      glib-unix: New API to watch some Unix signals
      glib/Makefile.am: Remove stray tab
      Drop stray reference to gthread.la
      Use SIGTRAP (via G_BREAKPOINT()) if G_DEBUG=fatal-warnings
      Drop translated g_warning/g_error
      glib-unix.h: Unconditionally include unistd.h
      g_unix_set_fd_nonblocking: New API to control file descriptor blocking state
      GCancellable: Use g_unix_pipe_flags with FD_CLOEXEC
      Use g types in public API for consistency
      glib-unix.c: Don't leak FDs if pipe2() succeeds
      Rename g_unix_pipe_flags to g_unix_open_pipe

Dan Winship (7):
      GSocketService: clarify transfer semantics of incoming connections
      GSimpleAsyncResult: push thread context around callback
      Update .gitignores
      Fix autoconf 2.68 warnings
      Fix compiler warnings
      Add back an erroneously-removed line to tests/Makefile.am
      Fix usage of _GNU_SOURCE

Daniel Mustieles (1):
      Updated Spanish translation

David Schleef (1):
      Fix %z in g_date_time_format()

David Zeuthen (63):
      Start merging gdbus-codegen code
      GDBusProxy: Update description to match GDBusInterface
      GDBusProxy: Store GDBusObject in private struct instead of qdata
      Add docs for new high-level D-Bus types
      Add "Since: 2.30" for new D-Bus routines
      Add gdbus-codegen(1) command
      Add a generic libffi based marshaller to libgobject
      Forgot to add autofoo for libffi
      GDBus: Document GVariant/GValue conversion routines and move to them to utils
      Improve g_dbus_gvalue_to_gvariant() docs
      Clarify docs for g_dbus_gvalue_to_gvariant() and g_dbus_gvariant_to_gvalue()
      GDBus: Use thread-default GMainContext in _g_assert_property_notify + friends
      GDBus: Add test-suite for new ObjectManager and gdbus-codegen(1) code
      Dist test-codegen.xml
      GDBus: Avoid using the word interface in public C headers
      GDBusInterfaceStub: Rename stub parameter to interface
      Also use interface_ instead of interface in C files
      GDBus: Add ObjectManager example
      Update "Migrating to GDBus" chapter to take gdbus-codegen(1) into account
      Spiff up the "Migrating to GDBus" docs a bit
      gdbus-codegen: Add --c-generate-object-manager option + doc improvements
      Add support for org.gtk.GDBus.Since annotation
      gdbus-codegen: Mention that @since can be used
      GDBus: Minor renames and doc fixes
      gdbus-codegen: Use CDATA to make gtk-doc avoid expanding certain strings
      gdbus-codegen: Shorten man page title
      GDBusInterfaceStub: Use G_VARIANT_TYPE_VARDICT when referring to type a{sv}
      GDBus: Use Skeleton instead of Stub
      GDBusInterfaceStub: Clarify ::g-authorize-method docs
      GDBus: Allow tcp: and nonce-tcp: addresses without any arguments
      GDBus: Nuke debug spew from the ANONYMOUS authentication method
      GDBus: Add test case for the ANONYMOUS authentication method
      GDBus: If an authentication method fail, don't give up, just try the next one
      GInetAddress: add equal() method
      GResolver: Don't return duplicate addresses
      GDBus: Support Ugly_Case and use org.gtk.GDBus.C.Name since it's C-only
      gdbus-codegen: Add copyright / license headers
      gdbus-codegen: Use the right program name in introductory comment
      gdbus-codegen: Use the right program name in introductory comment (again)
      gdbus-codegen: Include a blurb about the license of the generated code
      gdbus-codegen: Add support for the org.freedesktop.DBus.Deprecated annotation
      gdbus-codegen: Fix obvious bug in _g_variant_equal0() implementation
      gdbus-codegen: Don't send out PropertiesChanged if value ends up not changing
      gdbus-codegen: Never emit empty PropertiesChanged signals
      gdbus-codegen: Nuke debug spew
      gdbus-codegen: Make generated code introspectable
      GDBus: Add some gobject-introspection annotations for new code
      GDBusObjectManagerClient: Add a GDestroyNotify to the user_data
      gdbus-codegen: Generate docs when generating C code
      gdbus-codegen: Add "Returns:" blurb for generated get_proxy_type()
      gdbus-codegen: Document the generated ObjectManagerClient structs
      gdbus-codegen: It's GDBusProxyTypeFunc, not GDBusProxyFunc
      gdbus-codegen: Set nick+blurb for properties to shut up gtk-doc
      gdbus-codegen: Generate gtk-doc section docs
      gdbus-codegen: Document the generated FOO_PEEK_BAR() and FOO_GET_BAR() macros
      GDBusObjectManagerServer: make export() return whether the object was removed
      gdbus-codegen: Include docs for generated code in the GIO docs
      Fix build broken by previous commit
      gdbus-codegen: Generate GDBusObject{,Proxy,Skeleton} subtypes
      gdbus-codegen: Fix typo in generated docs
      Merge branch 'master' into gdbus-codegen
      Update docs to take comments/suggestions from Matthias into account
      GDBusObjectManagerServer: Allow setting :connection property

Kean Johnston (1):
      GLocalFile: Use _fstati64 rather than stat on Win32

Kjartan Maraas (1):
      Updated Norwegian bokmål translation

Maciej Piechotka (1):
      Allow caching have_qsort_r which re-enables cross-compiling

Matthias Clasen (20):
      Bump version
      Slight docs rewording
      GSequence: Make g_sequence_iter_move behave as documented
      Fix up some harmless FALSE <> NULL confusions
      Fix mailing list link in README
      Whitespace cleanup
      GHashTable: Add a test for remove-all functionality
      GHashTable: Small optimization of remove-all
      GHash: introduce a "set" mode
      GHash: make sets with refcounted keys work correctly
      Fix make check
      Avoid an unused variable warning
      Some documentation additions
      Revert "[build] Remove stale LDADD lines from tests/Makefile.am to allow build"
      Only remove the lines that are no longer needed
      Remove extraneous decorations
      Updates
      Pre-release bump
      Try to fix distcheck
      More distcheck fixes

Michael Kuhn (1):
      Bug 637561 - Crash when using G_DBUS_SERVER_FLAGS_RUN_IN_THREAD

Michael Terry (1):
      Don't ignore SUPPORTS_STARTUP_NOTIFICATION for commandline GAppInfos

Morten Welinder (3):
      GHash: use macros to check for magic hash values.
      GHash: split nodes array into seperate arrays.
      GHash: eliminate one of the lookup_nodes functions.

Muhammet Kara (1):
      Updated Turkish translation

Murray Cumming (1):
      GDBusServer: Documentation: Improvements.

Ray Strode (2):
      glib/Makefile.am: add gmain-internal.h to sources
      gdbus-codegen: don't assert non-negativity for unsigned values

Ryan Lortie (8):
      Remove unused variable in gvdb-reader
      G_VARIANT_TYPE_VARDICT: Add 'Since:' tag
      GTimeZone: fix non-threadsafe refcounting
      builder: do not include <unistd.h> on win32
      Merge remote-tracking branch 'gvdb/master'
      GApplication: #include "gsettings.h"
      Remove duplicate GDBusInterface declaration
      GVariant: Better handling of invalid UTF-8

Shaun McCance (1):
      glib/gvariant.c: Fix variable name in example code

Simon McVittie (1):
      /gdbus/message-serialize-invalid test: be compatible with D-Bus 1.4.8

Thomas Hindoe Paaboel Andersen (1):
      docs: fix typos in networking classes



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]