[gegl] Created tag GEGL_0_1_4



The unsigned tag 'GEGL_0_1_4' was created.

Tagger: Nils Philippsen <nils redhat com>
Date: Wed Mar 16 16:23:09 2011 +0100

    version 0.1.4

Changes since the last tag 'GEGL_0_1_2':

Alexia Death (2):
      Make mirrors op mirror offset respect zoom
      operations: Clean up mirrors op code

Andy Gill (2):
      added simple grid render operation
      removed arbitrary constants and reversed offset direction

Barak Itkin (2):
      gegl: Removed repeated definitions of macros in gegl-chant.h
      workshop: Add a gegl operation for GIMP's "Whirl and Pinch" plugin

Damien de Lemeny (5):
      tests: Add tests for GeglPath
      property-types: Fix Bug #620167 and simplify path_calc[_values]
      property-types: Cache path_calc iterator stop position and restart from it
      property-types: Make gegl_path_calc return a boolean
      operations: Extract vector rendering operations from path.c

Danny Robson (28):
      Convert C++ style comments to C style
      Define XOPEN feature test macro for PATH_MAX
      Initialise threading before gegl in buffer-test
      Use generated func names directly for test output
      Ignore tests/buffer/.libs
      Use GError to report missing XML attribute values
      Destroy resources if gegl_node_new_from_xml() fails
      Allow integers for rgb(a) property values
      Created dynamic save operation using save_handlers
      Added gegl_rectangle_is_empty function
      Remove all pads when attaching operations to nodes
      operations: Add gegl:rgbe-load and gegl:rgbe-save
      configure: define AM_DEFAULT_VERBOSITY if required
      configure: remove redundant print statements
      configure: move more m4 macros into external files
      configure: update gtk-doc configure macros
      configure: use autoconf to define restrict
      authors: remove duplicate entry
      jp2: fallback to AC_CHECK on configure
      Added exposure combiner, and support tool, for HDR
      operations: reinhard05 tone mapping operator
      operations: fattal02 tone mapping operator
      operations: mantiuk06 tone mapping operator
      operations: add levin et. al soft matting
      Always make use of realpath() return value
      Cache the libopenraw pixel data in a GeglBuffer
      Use explicit rects for demosaic input and outputs
      Use explicit rects for box-max and box-min process

Debarshi Ray (1):
      gegl: Ensure that the GeglProcessor's context is removed

Kao (3):
      Fix deprecated vala syntax
      Add Path, Buffer.linear_open, Buffer.linear_close vala binding
      A port of gegl-paint to vala

Martin Nordholts (83):
      gegl: Make gegl_operation_gtype_from_name() thread safe
      examples: Don't include config.h in example programs
      gegl: Loader fallback is "gegl:magick-load", not "magick-load"
      Make extension comparisions case insensitive
      operations: Remove duplicate extension registrations
      Add gegl_extension_handler_register/get_saver()
      operations: Register png and ppm savers
      bin: Lookup ouput file type dynamically through extension
      gegl: Add GEGL_DEBUG_BUFFER_SAVE output
      gegl: Avoid some crashes when providing invalid input and output file
      gegl: Breakpoint and stacktrace sanity: gegl_nop_process()
      gegl: Improve GEGL_DEBUG_PROCESS output
      Use G_N_ELEMENTS
      gegl: Comment GeglOperationContext struct
      Make gegl_buffer_save() use roi properly
      Update .gitignore
      tests: Don't output details when generating  buffer-tests.inc
      operations: Add "gegl:gegl-buffer-save/load" ops
      tests: Make the 'compositions' test support arbitrary reference images
      gegl: Quickfix for GeglTileBackendFile on read-only files
      tests: Don't ignore status of 'buffer-test'
      tools/img_cmp.c: Typo fix, top -> to
      tests: Fix minor formating issue in buffer/Makefile.am
      tests: Update buffer/.gitignore
      bin: Cleanup gegl.c a bit
      tests: Make images.stamp shared library dependencies work
      operations: Move "gegl:jp2-load" out of the workshop
      bin: Remove unused function file_utils_get_ext_start()
      gegl: s/GEGL_HANDLER/GEGL_TILE_HANDLER/g
      buffer: Remove unused 'last_added' member from SaveInfo
      gegl: Fix valgrind warnings with gegl_buffer_save()
      buffer: Cleanup buffer/gegl-tile-handler-cache.{c,h}
      buffer: Namespace functions for breakpoint and stacktrace sanity
      buffer: Explain why we do gegl_tile_store() in gegl_tile_unref()
      buffer: Move defines in gegl-tile.h to the end
      buffer: Add gegl_tile_mark_as_stored()
      buffer: Initialize revisions inside gegl_tile_new(), not outside
      buffer: Use gegl_tile_get_data() everywhere
      buffer: Set revs to 1 allrady in gegl_tile_new_bare()
      buffer: Remove unneeded code
      buffer: Unset tile_handler_chain->chain while destroying it
      build: Add buildbot/suppressed_warnings.txt
      tests: Distribute .hdr and .jp2 from compositions/data
      Update .gitignore
      Put simple tests in 'tests/simple'
      tests/buffer: Make output dir from Makefile
      tests/buffer: Make buffer tests work during distcheck
      tests/buffer: Another try at 'Make buffer tests work during distcheck'
      build: Update buildbot/suppressed_warnings.txt
      Do not handle signals in "gegl:display"
      gegl: property-types/gegl-path.c: Fix warning
      libs/rgbe: Always reset errno before using it
      tools: Us g_printerr() for img_cmp errors
      tests/compositions: Redirect stderr to tests-report too
      tools: #define P2() at the top and call it SQR() instead in img_cmp
      tests: Rewrite compositions tests framework
      tests: Include jp2-load.xml only if HAVE_JASPER
      tests: Fix compositions/.gitignore
      Require Automake 1.10
      autogen.sh: Don't modify global var DIE in check_version()
      Fix automake version check
      operations: Fix warning in fattal02.c
      build: Rename to buildbot/suppressed-warnings.txt
      configure.ac: Disable gzip tarball
      Use AC_CONF_PROGRAM in AC_COMPILE_IFELSE to silence autoconf 2.68
      build/buildbot: Supress AM_PROG_LIBTOOL warning with autoconf 2.68
      configure.ac: Use AC_CHECK_HEADER for libspiro check
      configure.ac: Print reason for umfpack failure
      operations: include <math.h> for NAN in exp-combine.c
      Bug 631183 - failure to compile gegl-buffer due to unavailable backtrace
      Clean up previous commit
      AUTHORS: Add Fabian Groffen
      operations: Increase exp-combine.c portability
      Revert "operations: Increase exp-combine.c portability"
      tools: PKG_CHECK_MODULES sets EXIV2_CFLAGS, not _CXXFLAGS
      operations: Use png_get_valid()
      libs: Use strlen() instead of strnlen()
      build/buildbot: Supress jas_config.h warnings
      build/buildbot: Complete jas_config.h warning suppression
      gegl: Namespace gegl-config.c
      Update NEWS
      NEWS: Fix typo
      Fix newly introduced compile warning

Michael Muré (5):
      render_mapping: add an operation that sample input with an auxiliar buffer that contain source coordinates
      gegl:render_mapping: small correction
      render_mapping: fix bad call to sampler that caused aliasing
      render_mapping: fetch a pixel directly if the coordinates asked is an exact pixel,     to avoid the blur of sampling.
      buffer: expose gegl-buffer-iterator for use in gimp cage tool

Michael Natterer (3):
      process: don't leak each node set on a GeglProcessor
      Bug 609869 - Invalid position of layer content when using GEGL
      autogen.sh: fix automake check to default to checking for 1.10

Michael Schumacher (4):
      Don't discard ACLOCAL_FLAGS from environment
      Replace bcopy and bzero by memcpy and memset and include math.h
      Use #!/usr/bin/env ruby instead of #!/usr/bin/ruby
      Check for compiler flags before using them

Mikael Magnusson (1):
      Add some needed math.h includes

Mukund Sivaraman (50):
      ppm-load: Remove unnecessary whitespace
      ppm-load: Make some functions static
      ppm-load: Remove unnecessary protos
      ppm-load: Return early if there's an error loading the header
      ppm-load: Add support for 16-bit images
      ppm-load: Restructure code to do fewer computations
      ppm-save: Remove unnecessary whitespace
      ppm-load: Make bpc into a gsize
      ppm-save: Add support to save 16-bit PPM images
      ppm-save: Save in raw format by default
      ppm-load: Fix format strings
      ppm-save: Fix format strings
      jp2-load: Add support for loading JPEG-2000 images
      ppm-load: Don't initialize image data to zero
      ppm-save: Don't initialize image data to zero
      Add rules to .gitignore files
      jp2-load: Initialize variables to NULL
      jp2-load: Close the input stream early
      jp2-load: Render images to sRGB color space before passing to GEGL
      jp2-load: Handle files with .jpx extension too
      mandelbrot: Update description slightly
      ppm-load: Fix leak of file handles when input is not a PPM file
      ppm-save: Fix leak of file handles when we don't support the output type
      tests: Add test for jp2-load
      Plug a leak of GeglRectangle
      Use values instead of uninitialized variables
      Free any nodes that remain on the parent list
      Return FALSE instead of nothing
      Use silent rules even when running libtool
      Fix typo in variable name
      Make the compiler show extra warnings
      Fix a bug where MMX was not used when SSE was unavailable
      Rename variable to avoid shadowing a global function
      ppm-load: Fix compare between signed and unsigned
      ppm-save: Fix compare between signed and unsigned
      Rename variable to avoid shadowing a global function
      Fix inline declaration style
      Rename variable to avoid shadowing a global function (babl_format)
      Rename variable to avoid shadowing outer block variable
      Fix #ifdefs
      Fix check of mmap() return value
      Annotate function decl
      Use int array instead of char (for alignment)
      Check return value of system()
      Add/update .gitignore files
      Fix constness
      Change variable types to fix signedness
      Add ACLOCAL_FLAGS to ACLOCAL_AMFLAGS
      Disable warnings
      Add back some warnings (as many commits before)

Nils Philippsen (11):
      remove execution bits from source, CSS files
      remove executable bit on Makefile.am
      this is gegl, not babl
      don't make gtk-doc documentation files executable
      fix various pointer <-> integer casts
      fix typos
      fix strict aliasing of type-punned pointers
      fix use of const qualifier
      remove unused variables and static functions
      avoid buffer overflow in gegl_buffer_header_init()
      gegl: make "root" a have file, not global scope

Patrick Horgan (1):
      png-load: check for failed read

Ruben Vermeersch (1):
      Update gegl-sharp bindings for libgegl-0.1.so.

Stuart Axon (1):
      Make PyGEGL look for automake 1.11

Vincent Untz (1):
      Bug 609706 - Useless printf in mirrors.c

Ã?tienne BERSAC (4):
      Updated to vala 0.7.6
      Release 0.0.3
      Don't refer ungenerated headers
      Release 0.0.4

�yvind Kolås (65):
      post release bump to 1.2.3
      Remove unused variables/assignments.
      Refactor gegl:remap be a GeglOperationPointComposer3 subclass
      gegl-operation.h Improved GeglOperationClass documentation
      build: fix srcdir!=builddir issues
      Add tests for transform op
      If the test name contains "broken" the test is allowed to fail
      Rename down sampling tests to contain the string broken
      tests: Remove nop, that breaks chain of consecetuve affine op
      gegl:stress: remove unneeded function call/copy
      Updated reference image for composite-transform
      affine: revert functional change in commit 7320d0
      docs: Removed unused graphic element from html/css
      configure.ac: increase gtk+ version dependency to be >2.18
      Removed affine->matrix member
      tests/compositions/reference/clones.png: refreshed
      tools/img_cmp: do g_thread_init
      Default to 1 thread
      Enable multi threading by default.
      buffer: remove locking from cache trimming
      GeglColor: add priv struct to GeglColor
      dropshadow, unsharp-mask: simplify code
      buffer: refactor some redundant calls away
      buffer: simplified construction of some of the gegl-tile-handlers
      buffer: simplify tilebus command dispatch by storing vfunc in instance
      buffer: removed unneeded use of varargs
      buffer: simplified buffer construction logic
      buffer: removed properties from tile-storage
      buffer: s/gegl_tile_handler_chain_up/gegl_tile_handler_source_command/
      buffer: make gegl-tile-handler-zoom be an object again
      save: initialize save handler just before processing
      magick-load: fix image magick fallback load op
      raw-load: fix raw loading op
      examples: added gegl convert a GEGL backed format converter
      AUTHORS: update
      buffer: include gegl-buffer-iterator.h from gegl-buffer.h
      map-absolute: rename gegl:render_mapping to gegl:map-absolute
      Added gegl_node_has_pad
      Expand comment describing GeglOperationContext
      update NEWS and AUTHORS
      Remove gegl-simd.h
      buffer: add extra locks
      Update op names in splash
      gegl-paint: use pixelformats that have optimizations
      processor: remove unusued variables
      path-stroke: make it threadsafe by not having a static cache buffer
      buffer: disable 1px fast paths as they are not thread-safe
      buffer: add note about possible optimization
      buffer: cache and reuse tile-storages
      configure: remove dangling --enable-mt from configure help
      gegl:display: use a timeout instead of an idle for the SDL event pumping
      increase maximum number of threads to 16
      Referesh performance testing framework
      perf: fix header in reports
      buffer: disable more of the debug code in default builds
      ff-load: convert to utf8 from iso8859-1
      tools/gobj2dot.rb: catch encoding errors
      Fix newly introduced compile warning
      brightness-contrast: removed SIMD codepath
      update NEWS and AUTHORS
      mirrors: remove unused variables from code
      move mirrors op out of workshop
      move mirrors op out of workshop
      Simplify list of contributors in "splash" of binary.
      bump version to 0.1.4



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]