[gtkmm] 2.99.6



commit 82a2c00315073e3760c9a8ef1edd0608b5abd351
Author: Murray Cumming <murrayc murrayc com>
Date:   Wed Mar 16 12:57:47 2011 +0100

    2.99.6

 ChangeLog    |    6 +++-
 NEWS         |   82 +++++++++++++++++++++++++++++++++------------------------
 configure.ac |    2 +-
 3 files changed, 53 insertions(+), 37 deletions(-)
---
diff --git a/ChangeLog b/ChangeLog
index 073834e..ff4f8b2 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,5 @@
+2.99.6:
+
 2011-03-16  Murray Cumming  <murrayc murrayc-desktop>
 
 	TreeView: Removed unused TreeView::_get_base_model() method.
@@ -7,7 +9,7 @@
 
 2010-12-27  Luca Wehrstedt  <lerks users sourceforge net>
 
-	Make TreeModelFilter behave like TreeModelSort.
+	Make TreeModelFilter behave like TreeModelSort for editable TreeViews.
 
 	* gtk/src/treemodel.hg: Add references to TreeModelFilter.
 	* gtk/src/treemodelfilter.ccg: Make set_value_impl() convert the iter
@@ -16,6 +18,8 @@
 	_get_base_model(). Update the toggle auto-store method.
 	* gtk/src/treeview.hg: Update all auto-store methods.
 
+	Bug #582981
+
 2011-03-07  Murray Cumming  <murrayc murrayc com>
 
 	Main: Improve the documentation.
diff --git a/NEWS b/NEWS
index c2affd4..cdc422b 100644
--- a/NEWS
+++ b/NEWS
@@ -1,21 +1,33 @@
+2.99.6 (unstable):
+
+Gtk:
+* CssProvider: load_from_data(): Remove the size parameter.
+	(Fabien Parent)
+* Main: Added a constructor with no argc and argv.
+  (Murray Cumming)
+* TreeView::add_column_editable(): Make this work for TreeModelFilter models.
+  (Luca Wehrstedt) Bug #582981
+* Window: Added unset_application.
+  (Murray Cumming)
+
 2.99.5 (unstable):
 
 Gtk:
 * ButtonBox, Separator, Scale, Scrollbar: Add public constructors.
   (Murray Cumming)
-* CellArea, CellRenderer: Added get_request_mode(), 
+* CellArea, CellRenderer: Added get_request_mode(),
   get_preferred_[width|height_for_width|height|width_for_height] vfuncs.
   (Kjell Ahlstedt) Bug #639073,
 * CellView: Derive from Orientable and add set/get_draw_sensitive(),
 	set/get_fit_model() and the new properties.
-* EntryCompletion: Derive from Buildable and add the cell-area 
+* EntryCompletion: Derive from Buildable and add the cell-area
 	property.
 * IconView: Added the cell_area property.
 * Image: Added the set_fallback property.
 * Paned: Constructor: Add an optional orientation parameter.
 * Widget: Added should_draw_window() and transform_cairo_context_to_window().
   (Murray Cumming)
-  
+
 2.99.4 (unstable):
 
 Gtk:
@@ -30,12 +42,12 @@ Gtk:
 Documentation:
 * ComboBoxText: Add warning about not confusing these.
 	Bug #619656 (JimO, Kjell Ahlstedt)
-	
+
 2.99.3 (unstable):
 
 Gdk:
 * Display:
-  - selection_send_notify(): This now takes a 
+  - selection_send_notify(): This now takes a
 	Gdk::Window instead of a (now removed) GdkNativeWindow.
 	- Removed get_protocol() and add_client_message_filter().
 * Screen: Removed send_client_message().
@@ -45,7 +57,7 @@ Gdk:
   (Krzesimir Nowak)
 
 Gtk:
-* Application: Try to make this a replacement for Gtk::Main, though this 
+* Application: Try to make this a replacement for Gtk::Main, though this
  work is not finished yet.
   (Murray Cumming)
 * Button: Restore the clicked() method.
@@ -59,16 +71,16 @@ Gtk:
  - get_default() and get_named(): fixed the reference counting.
  (Kjell Ahlstedt)
 * IconSet: Use this via a RefPtr.
-* LisViewText: Rename append_text(), insert_text(), and 
-	prepend_text() to append(), insert() and prepend() because that is what 
+* LisViewText: Rename append_text(), insert_text(), and
+	prepend_text() to append(), insert() and prepend() because that is what
 	ComboBoxText now uses (because it has other append overloads).
 * Added NumerableIcon.
 * Range: Added get/set_round_digits() and property.
 * TextView: Added get_cursor_locations().
 * Widget:
   - Removed client_event signal.
-  - Added set_state_flags(), get_state_flags(), 
-	reset_state_flags(), set_device_enable(), get_device_enabled(), and 
+  - Added set_state_flags(), get_state_flags(),
+	reset_state_flags(), set_device_enable(), get_device_enabled(), and
 	reset_style().
   (Murray Cumming)
   - Added get_request_mode_vfunc(),
@@ -80,14 +92,14 @@ Gtk:
 	- set_window(), set_has_window(), and get_requisition() are now protected.
 	(Murray Cumming)
 	- set_window(): Increase the ref count of the Gdk::Window because GTK+ does
-	not, and will not, though we think we may need to do more work to fix this 
+	not, and will not, though we think we may need to do more work to fix this
 	properly.
   (Kjell Ahlstedt) Bug #606903 (Hammered)
 
 2.99.1 (unstable):
 
 Gdk:
-* Cursor: Add create() methods, making the constructors protected, 
+* Cursor: Add create() methods, making the constructors protected,
 	because this should now be used via RefPtr.
   (Murray Cumming)
 * Device:
@@ -103,9 +115,9 @@ Gdk:
   - Removed Remove get_device_state() and get_window_at_device_position()
   (Krzesimir Nowak)
   - Added has_pending() and notify_startup_complete().
-  - Removed pointer_ungrab(),  keyboard_ungrab(), pointer_is_grabbed(), 
-  device_is_grabbed(), get_pointer(), get_window_at_pointer(), warp_pointer, 
-  set_pointer_hooks(), unset_pointer_hooks(), set_device_hooks(), 
+  - Removed pointer_ungrab(),  keyboard_ungrab(), pointer_is_grabbed(),
+  device_is_grabbed(), get_pointer(), get_window_at_pointer(), warp_pointer,
+  set_pointer_hooks(), unset_pointer_hooks(), set_device_hooks(),
   unset_device_hooks().
   (Murray Cumming)
 * DisplayManager.hg: Added open_display().
@@ -113,7 +125,7 @@ Gdk:
   - Use a reference for the protocol parameter, instead of a pointer.
 	- Added get_dest_window() and get_protocol().
 * Pixbuf: Added set_option() and apply_embedded_orientation().
-* Screen: The monitors_changed() signal was wrapping the 
+* Screen: The monitors_changed() signal was wrapping the
 	size_changed signal. Fixed.
 * Window: Added get_device_cursor().
   (Murray Cumming)
@@ -128,10 +140,10 @@ Gtk:
 * TreeModel::iterator::operator--(): Use gtk_tree_model_iter_previous().
 * TreeView: Added is_blank_at_pos().
 * Widget: Removed style_attach().
-* Window: Removed set_frame_event(), get_frame_event(), 
+* Window: Removed set_frame_event(), get_frame_event(),
 	set_frame_dimensions(), get_frame_dimensions() and the frame_event signal.
   (Murray Cumming)
-	
+
 2.91.7 (unstable):
 
 Gtk:
@@ -142,20 +154,20 @@ Gtk:
 * CellLayout: Added get_area().
 * CellRenderer: Added is_activatable() and get_aligned_area().
 * IconInfo:
-  - Renamed load_icon_symbolic() to load_symbolic() 
+  - Renamed load_icon_symbolic() to load_symbolic()
   - Added load_icon_symbolic(StyleContext, bool&).
-* Switch: Fix the type registration to avoid breaking Widget's type 
+* Switch: Fix the type registration to avoid breaking Widget's type
   registration completely, which probably broke everything.
 * TreeViewColumn: Added get_button().
 * Widget:
   - Removed reset_shapes() and get_default_visual().
   - Added unset_color/font() methods.
   - Removed render_icon(), adding render_icon_pixbuf().
-* WidgetPath: Renamed get_widget_type() to get_object_type() and 
-	renamed iter_get/set_widget_type() renamed to iter_get/set_object_type(). 
+* WidgetPath: Renamed get_widget_type() to get_object_type() and
+	renamed iter_get/set_widget_type() renamed to iter_get/set_object_type().
 * Window: Added get/set_application().
   (Murray Cumming)
-  
+
 Gdk:
 * Cursor should now be used via RefPtr.
 * Display: Removed warp_device().
@@ -165,22 +177,22 @@ Gdk:
 2.91.6 (unstable):
 
 Gtk:
-* Added the StyleContext, StyleProvider, and CssProvider classes, 
+* Added the StyleContext, StyleProvider, and CssProvider classes,
   removing the Style and RC classes.
 * Added Gdk::Cairo::set_source_rgba().
 * Widget: Added get_style_context().
 * Cellrenderer, Cellrenderertext, Cellview, Colorbutton, TextTag:
-  Added RGBA versions of color properties. We expect to remove Gdk::Color 
+  Added RGBA versions of color properties. We expect to remove Gdk::Color
   in future, maybe then renaming all uses of RGBA to Color.
 * ColorSelection: Added get/set_current_rgba() and get/set_previous_rgba().
 * ComboBoxText:
-  - Renamed append_text(), prepend_text() and insert_text() to append(), 
+  - Renamed append_text(), prepend_text() and insert_text() to append(),
   prepend() and insert().
   - Added extra append()/prepend()/insert() overloads that also take an id.
   - Added get/set_id_column(), get/set_active_id() and properties.
 * Widget:
-  - Removed the style_changed signal because it used GtkStyle, though 
-  we might bring this back when the GTK+ code is completely ported to 
+  - Removed the style_changed signal because it used GtkStyle, though
+  we might bring this back when the GTK+ code is completely ported to
   GtkStyleContext.
   - Added get_path(), removing path().
   - Removed the no_expose_event signal.
@@ -189,16 +201,16 @@ Gtk:
 
 Gdk:
 * Removed Drawable.
-* RGBA: Rename set_rgb_p(double) to set_rgba(dobule) and rename the old 
-  set_rgb(gushort) to set_rgb_u(gushort). Likewise for other methods. 
-  This makes it more like GdkRGBA, which uses double instead of the gushort 
+* RGBA: Rename set_rgb_p(double) to set_rgba(dobule) and rename the old
+  set_rgb(gushort) to set_rgb_u(gushort). Likewise for other methods.
+  This makes it more like GdkRGBA, which uses double instead of the gushort
   that GdkColor used.
 * Window:
-  - Added set_background(RGBA) and renamed  set_background_pattern() to 
+  - Added set_background(RGBA) and renamed  set_background_pattern() to
   set_background(Pattern).
 	- Added set_clip_region() and get_visible_region() and create_cairo_context(),
 	which were previously in the (now removed) base Drawable class.
-	
+
 2.91.5.1 (unstable):
 
 Fix the build with GTK+ 2.91.5 by removing some newer GtkComboBox methods.
@@ -209,11 +221,11 @@ Gdk:
 * Device: get_n_axes() now returns an int instead of a guint.
 
 Gtk:
-* ComboBox: Added get/set_id_column(), get/set_active_id() and 
+* ComboBox: Added get/set_id_column(), get/set_active_id() and
 	properties.
 * Scrollable, ScrolledWindow: Fix Adjustment reference counting.
 * Added Switch widget.
-* Removed Ruler, with no replacement in gtkmm itself, because it 
+* Removed Ruler, with no replacement in gtkmm itself, because it
   was not used generally enough.
   (Murray Cumming)
 
diff --git a/configure.ac b/configure.ac
index 084c0d9..f8560a7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -15,7 +15,7 @@
 ## You should have received a copy of the GNU Lesser General Public License
 ## along with this library.  If not, see <http://www.gnu.org/licenses/>.
 
-AC_INIT([gtkmm], [2.99.5],
+AC_INIT([gtkmm], [2.99.6],
         [http://bugzilla.gnome.org/enter_bug.cgi?product=gtkmm],
         [gtkmm], [http://www.gtkmm.org/])
 AC_PREREQ([2.59])



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]