[gtk+/gdk-backend-wayland] (105 commits) ...wayland: Add modifier masks for meta, hyper and super keys



Summary of changes:

  69e4a3f... Updated Galician translations (*)
  c1bc521... gtk: get rid of two cases of invalidating the spinbutton wh (*)
  858ba35... gtk: remove function gtk_entry_queue_draw() and call gtk_wi (*)
  f23585b... gtk: bail out in render_background_internal() if the extent (*)
  217d3fd... GtkStyleContext is meant to have a GdkScreen (*)
  baa6343... Handle insensitive cell renderer flags in gtk_cell_renderer (*)
  4277889... s/state_changed/state_flags_changed/ in GtkComboBox (*)
  3301589... gtk: make the .trough background-color darker() as it was i (*)
  1aaed01... Updated Polish translation (*)
  1c0f85a... gtk: gtk_cell_renderer_get_state(): a row can be both selec (*)
  e39e8ac... gtk: gtk_cell_renderer_get_state(): check the widget's effe (*)
  f55ccce... win32: msvc build update (*)
  b41ee31... win32: no more GdkNativeWindow and related changes (*)
  733731e... No more gtk_plug_*/gtk_socket_* symbols on win32 (*)
  24c37e9... Updated Norwegian bokmål translation. (*)
  9bd1755... Add a testcase for state propagation problems (*)
  899019d... configure.ac: Remove some obsolescent macros (*)
  c734bb8... configure.ac: Use AS_HELP_STRING instead deprecated AC_HELP (*)
  8a965b9... configure.ac: Use AC_COMPILE_IFELSE instead deprecated AC_T (*)
  14eb348... configure.ac: Remove some more obsolete macros (*)
  beb8c29... Always chain up in ::style-updated (*)
  db97f86... Use faster new G_VALUE_COLLECT_INIT variant instead G_VALUE (*)
  1c20c93... Optimize queue_resize_on_widget() (*)
  23f9bdd... Fix problems with state propagation (*)
  2be6926... Fix color style properties lookup when the color resolution (*)
  2089746... Set the correct initial value for the direction property (*)
  3a50b46... Update the context direction when emitting ::direction-chan (*)
  15fdf90... doc: Add a note about prioritization of GtkStyleProviders (*)
  c1f8330... gdk: Fix typo in documentation string (*)
  1483145... API: image: Move private struct definitions into private he (*)
  7711f9f... introspection: Remove redundant include (*)
  60e0acf... Remove tab as it confused g-ir-scanner (*)
  358a2b8... Rename time to time_ to avoid a scanner warning (*)
  6a40c0f... introspection: Remove redundant include (*)
  99b5af1... Add warnings about environment variables (*)
  d2bdd50... Extend the mixed-dependency check to modules as well (*)
  a189d1e... Updated Spanish translation (*)
  e56de51... Update NEWS (*)
  83478ae... Define the required introspection version in configure.ac (*)
  57d5328... Add links to the migration guide (*)
  f6cc08f... Remove annotation that breaks the docs (*)
  32398f1... README.in: Fix link to the migration guide (*)
  394ae46... Add some missing symbols to the docs (*)
  861ba00... Don't export gtk_cell_area_box_init_groups (*)
  4943367... Don't export GtkModifierStyle symbols (*)
  5ada6ac... Remove no-longer exported symbols from the symbol list (*)
  7e7eaf3... Documentation tweaks (*)
  1f4bb70... Give the GDK docs some love (*)
  adef256... Fix annotation that broke the docs (*)
  8291530... More GDK documentation tweaks (*)
  6974504... Add some more info for desktop app info (*)
  f0fabcd... Quell another warning (*)
  95446c3... configure.ac: Depend on stable versions of other libraries (*)
  f2ff213... Added padding to GtkTextLineDisplay struct for an addition  (*)
  d1632f8... Avoid the need for cairo_push_group() in gtk_render_backgro (*)
  e1dbc87... Change required glib version from "2.28" to "2.28.0" (*)
  13d249a... Change the title of the GDK docs to mention '3' (*)
  981cadb... Make online references point to the right place (*)
  3f1c95d... Don't try to modify readonly strings (*)
  b91549a... Add "extern C" declarations around AppChooser headers. (*)
  9455ce9... Remove a long-unsupported script that does nothing (*)
  c7d41ac... Minor formatting tweak (*)
  524ce69... Bump the version to 3.0.0 (*)
  10b7f70... Mention library soname change (*)
  edf5920... Correct sonames appearing in the docs (*)
  d4ac3c8... Bump version to 3.0.1 (*)
  bba7a98... Visual C++ support: Fix the gdk-win32 Project (*)
  1865011... gtk: don't send BUTTON_RELEASE to unrealized widgets (*)
  7cb41b6... gdk/gdkconfig.h.win32: Make it more up-to-date (*)
  d847f48... Win32 Visual C++ Support: Some more clean-ups (*)
  63b415d... docs: Link to all versions of both GTK3 and GTK2 (*)
  b1f2e5b... x11: Fix build without Xinput (*)
  0bd0854... icontheme: constify arguments to gtk_icon_theme_load_symbol (*)
  ccc3679... stylecontext: Use the common approach for priate pointers (*)
  e9ff457... x11: Make the device manager struct actually subclass the c (*)
  ac6c6b0... gtk: Fix warnings for dnd code without XInput (*)
  30abd4d... x11: Fix struct definition for GdkDeviceManagaerXI2 (*)
  de9a082... x11: Make headers identical no matter if we run with or wit (*)
  728a45f... Remove confusion over XI2 defines (*)
  10ebea8... Use standard icon names (*)
  5a86445... Added UG translation (*)
  c526c1b... Updated Hebrew translation (*)
  086f266... Updated Norwegian bokmål translation. (*)
  bfd66fe... Quell compiler warnings (*)
  d05d924... Silence more compiler warnings (*)
  799c3e4... gail: Fixing little bug, gail_misc_add_attribute returns th (*)
  3138c3d... No GTK_ENABLE_BROKEN anymore (*)
  9f12cc3... Protect x11-specific functions in gtktypefuncs.c (*)
  81229e7... Update Korean translation (*)
  a1d96af... colorsel: Remove WINDOWING ifdef (*)
  9f5c734... doc: Document the GDK_BACKEND environment variable (*)
  33a46dd... gdk: Select the X11 backend a the last possible backend (*)
  48819b4... po/vi.po: import from Damned Lies (*)
  8c4d8c1... Updated Vietnamese translation (*)
  d587252... configure.ac: Use AC_LINK_IFELSE instead deprecated AC_TRY_ (*)
  efeade2... configure.ac: Use AC_RUN_IFELSE instead deprecated AC_TRY_R (*)
  dffc96a... configure.ac: Use AC_PREPROC_IFELSE instead deprecated AC_T (*)
  932ab55... configure.ac: Use AC_CONFIG_COMMANDS instead deprecated AC_ (*)
  a3f5294... Bug 633291 - Handle Shift-keys in X11 gdk_test_simulate_key (*)
  3842399... configure.ac: Remove fd_set checks (*)
  b1a0a08... testgtk: Fix compilation warning (*)
  f04504a... Allow custom icon size in gtk_render_icon_pixbuf() (*)
  287d91e... Merge remote-tracking branch 'origin/master' into gdk-backe
  0e1041a... wayland: Add another cursor (left-ptr)
  fcd58b0... wayland: Add modifier masks for meta, hyper and super keys

(*) This commit already existed in another branch; no separate mail sent



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]