[libgdata] Release version 0.9.0



commit 827305957733db51124d90873949f45f7ba7a45d
Author: Philip Withnall <philip tecnocode co uk>
Date:   Sun Jun 12 12:45:49 2011 +0100

    Release version 0.9.0

 NEWS         |  103 ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
 configure.ac |    2 +-
 2 files changed, 104 insertions(+), 1 deletions(-)
---
diff --git a/NEWS b/NEWS
index c8f7bc8..8dbfbd5 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,106 @@
+Overview of changes from libgdata 0.8.0 to libgdata 0.9.0
+=========================================================
+
+Major changes:
+* Switched to evenâ??odd/stableâ??unstable versioning (so 0.9.0 is an *unstable* release)
+* Use HTTPS for all requests
+* Some minor parsing fixes
+* Fixed some nasty threading/cancellation problems
+* Removed the old authentication API in favour of a more extensible, flexible one based on a GDataAuthorizer interface:
+  - ClientLogin is now handled by GDataClientLoginAuthorizer
+  - OAuth 1.0 support has been added with GDataOAuth1Authorizer
+* Added a dependency on liboauth â?¥ 0.9.4
+* Introspection annotation improvements by Philip Chimento <philip chimento gmail com>
+* Removed some outdated contact photo API
+
+API changes:
+* Added GDATA_AUTHENTICATION_ERROR_INVALID_SECOND_FACTOR (later renamed to GDATA_CLIENT_LOGIN_AUTHORIZER_ERROR_INVALID_SECOND_FACTOR as below).
+* Rename GDataAuthenticationError to GDataClientLoginAuthorizerError
+* Rename GDATA_AUTHENTICATION_ERROR and gdata_authentication_error_quark() similarly.
+* Remove gdata_service_authenticate() in favour of using GDataClientLoginAuthorizer with GDataService::authorizer:
+  - Remove gdata_service_authenticate(), gdata_service_authenticate_async() and gdata_service_authenticate_finish().
+  - Replace gdata_service_is_authenticated() by gdata_service_is_authorized() with much the same functionality.
+  - Add GDataService::authorizer, gdata_service_get_authorizer(), gdata_service_set_authorizer() and gdata_service_get_authorization_domains().
+  - Remove gdata_service_get_client_id() in favour of GDataClientLoginAuthorizer::client-id.
+  - Remove gdata_service_get_username() in favour of GDataClientLoginAuthorizer::username.
+  - Remove gdata_service_get_password() in favour of GDataClientLoginAuthorizer::password.
+  - Remove GDataServiceClass->service_name in favour of GDataAuthorizationDomain::service-name.
+  - Remove GDataServiceClass->authentication_uri and GDataServiceClass->parse_authentication_response in favour of different GDataAuthorizer
+    implementations.
+  - Add GDataAuthorizer parameters to and remove client_id parameters from: gdata_calendar_service_new(), gdata_contacts_service_new(),
+    gdata_documents_service_new(), gdata_picasaweb_service_new() and gdata_youtube_service_new().
+* Add GDataAuthorizationDomain.
+  - Add GDataServiceClass->get_authorization_domains and gdata_service_get_authorization_domains().
+  - Add auth. domain getters to various GDataService subclasses: gdata_youtube_service_get_primary_authorization_domain(),
+    gdata_contacts_service_get_primary_authorization_domain(), gdata_calendar_service_get_primary_authorization_domain(),
+    gdata_picasaweb_service_get_primary_authorization_domain(), gdata_documents_service_get_primary_authorization_domain() and
+    gdata_documents_service_get_spreadsheet_authorization_domain().
+  - Add auth. domain properties to various standalone request objects: GDataDownloadStream::authorization-domain with
+    gdata_download_stream_get_authorization_domain(), GDataUploadStream::authorization-domain with gdata_upload_stream_get_authorization_domain() and
+    GDataBatchOperation::authorization-domain with gdata_batch_operation_get_authorization_domain().
+  - Add GDataAccessHandlerIface->get_authorization_domain. This doesn't have to be implemented by existing GDataAccessHandlers, but it's
+    highly recommended.
+  - Add a GDataAuthorizationDomain parameter to GDataServiceClass->append_query_headers, gdata_service_query(), gdata_service_query_async(),
+    gdata_service_query_single_entry(), gdata_service_query_single_entry_async(), gdata_service_insert_entry(), gdata_service_insert_entry_async(),
+    gdata_service_update_entry(), gdata_service_update_entry_async(), gdata_service_delete_entry(), gdata_service_delete_entry_async(),
+    gdata_batchable_create_operation(), gdata_download_stream_new() and gdata_upload_stream_new().
+* Add GDataAuthorizer as described above, implemented by GDataClientLoginAuthorizer.
+* Add GDataOAuth1Authorizer and all its properties and methods.
+* Remove gdata_contacts_contact_has_photo() and GDataContactsContact:has-photo (use gdata_contacts_contact_get_photo_etag() instead).
+
+Bugs fixed:
+* Bug 642983 â?? libgdata-0.8.0: test fail with --enable-gtk-doc
+* Bug 644940 â?? Use HTTPS only
+* Bug 644946 â?? Support two-factor authentication
+* Bug 639610 â?? Allow access to a contact's photo ETag
+* Bug 648058 â?? Doesn't allow empty names for user defined fields
+* Bug 650835 â?? [abrt] evolution-data-server-3.0.1-1.fc15: Process /usr/libexec/e-addressbook-factory was killed by signal 6 (SIGABRT)
+
+Updated translations:
+* as (Nilamdyuti Goswami)
+* da (Kris Thomsen)
+* de (Wolfgang Stöggl)
+* bg (Ivaylo Valkov)
+* bn_IN (Runa Bhattacharjee)
+* ca (Joan Duran)
+* cs (Marek Ä?ernocký)
+* de (Mario Blättermann)
+* el (Î?ιÏ?Ï?γοÏ? ΣÏ?εÏ?ανάκηÏ?, Michael Kotsarinis)
+* en_GB (Bruce Cowan)
+* eo (Kristjan SCHMIDT)
+* es (Daniel Mustieles, Jorge González)
+* eu (Iñaki Larrañaga Murgoitio)
+* fr (Bruno Brouard)
+* gl (Leandro Regueiro, Fran Diéguez)
+* gu (Sweta Kothari)
+* he (Yaron Shahrabani)
+* hi (Rajesh Ranjan)
+* hu (Gabor Kelemen)
+* id (Andika Triwidada)
+* it (Claudio Arseni)
+* kn (Shankar Prasad)
+* ko (Changwoo Ryu)
+* lv (Rudolfs)
+* mr (Sandeep Shedmake)
+* nb (Kjartan Maraas)
+* or (Manoj Kumar Giri)
+* pa (A S Alam)
+* pl (Piotr DrÄ?g)
+* pt (António Lima)
+* pt_BR (Rodrigo Padula de Oliveira)
+* ro (Lucian Adrian Grijincu)
+* ru (Yuri Kozlov)
+* sl (Matej UrbanÄ?iÄ?)
+* sr, sr latin (Ð?иÑ?оÑ?лав Ð?иколиÑ?)
+* sv (Daniel Nylander)
+* th (Akom Chotiphantawanon)
+* tr (Senol Korkmaz)
+* ug (Gheyret Kenji)
+* uk (Korostil Daniel)
+* zh_CN (ben)
+* zh_HK (Chao-Hsiung Liao)
+* zh_TW (Chao-Hsiung Liao)
+
 Overview of changes from libgdata 0.7.0 to libgdata 0.8.0
 =========================================================
 
diff --git a/configure.ac b/configure.ac
index 747bf62..3b9fcd8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -43,7 +43,7 @@ OAUTH_REQS=0.9.4
 #  4. If any interfaces have been removed or changed since the last public release, then set age to 0.
 #
 # Note that versioning started at 2:0:0 to ensure no conflicts with e-d-s' libgdata library, whose maximum version was 1:0:0
-GDATA_LT_VERSION=11:0:0
+GDATA_LT_VERSION=12:0:0
 AC_SUBST(GDATA_LT_VERSION)
 
 GDATA_VERSION_MAJOR=gdata_version_major



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]