[gthumb] Created tag 2.13.2



The unsigned tag '2.13.2' was created.

Tagger: Paolo Bacchilega <paobac src gnome org>
Date: Mon Jun 6 22:44:06 2011 +0200

    version 2.13.2

Changes since the last tag 'GTHUMB_2_13_1':

Abner Silva (1):
      Save the user preference changes when the pref window is about to be destroyed

Christian Kirbach (1):
      [l10n] Updated German help screenshots

Daniel Mustieles (4):
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation
      Updated Spanish translation

Lincoln de Sousa (11):
      Replacing an include for <gdkconfig.h> by a <gdk/gdk.h>
      Updating the gdk_drag_* stuff in gth-browser.c
      There's no depth param in the gdk_window_get_geometry function anymore
      Replace GDK_<keyname> with GDK_KEY_<keyname> through the code
      Stripping unused code from gedit-message-area
      Removing all references of the `gtk_dialog_set_has_separator()' function
      Project wide replace GtkComboBox by GtkComboBoxText when needed
      Replacing gtk_combo_box text API by gtk_combo_box_text one
      Replacing the deprecated gdk_set_sm_client_id call by a gdk_x11_set_sm_client_id
      Replacing references for members being accessed directly by their getters and setters
      Fixing an indirect linking problem against libICE

Michael J. Chudobiak (1):
      do not unref files returned by g_file_icon_get_file

Paolo Bacchilega (242):
      Fixed crash when closing a window while the video viewer is active
      add the entry points to the bookmark menu
      center the extra_widget vertically, fix location chooser spacing
      added the description to the .doap file
      webalbums: for generic ranges add the tag to the list, instead of the loop
      fixed compiler warning
      webalbums: fixed progress dialog not showing again after exporting the first time
      align the current folder to the top if it's an entry point
      rename_series: speed-up dialog appearance
      rename_series: automatically resize the columns of the preview list
      rename_series: added a dialog to edit the template
      changed the name of a variable
      rename_files: update the list after a timeout
      rename_series: remove the spaces from the attribute id
      template-selector: organize attributes in sub-categories
      template-selector: fixed setting of the active attribute
      rename_series: do not keep loading if an attribute is not recognized
      rename_series: use an embedded progress widget instead of a dialog
      rename_series: keep the cancel button sensitive during file loading
      force slow mime type detection in the temp dir as well
      check if the string is null before adding to the statusbar text
      rename_series: fixed crash when closing the dialog while loading the files metadata
      template-selector: changed the default date formats
      rename_series: if an error occurs show the error and close the dialog
      gth-load-file-data-task: show the remaining number of fails instead of the current filename
      gth-load-file-data-task: changed the progress text again
      updated POTFILES.in
      find duplicates: make the help button open the help window
      image-selector: removed unsed parameters from update_mouse_selection()
      image-selector: changed the grow direction
      image-selector: maximize the selection size when the pointer is out of the image bounds
      image-selector: do not paint the darker background when dragging
      image-selector: use a larger and proportional border for the resize grips
      image-selector: show the active resize grip
      crop: added ability to maximize and center the selection
      crop: set an initial selection of 2/3 the size of the image and centered
      after deleting a file in browser mode select the next file
      image-viewer: hide the frame when using a black background
      moved gimp_scale_entry_new() to gtk-utils.c
      added a sharpen tool
      added VIDEO and DESKTOP to the entry point list
      changed adjust color icon
      added an icon for the sharpen tool
      sharpen tool: move the "amount" option to the top
      sharpen tool: use "enhance focus" instead of "sharpen"
      blur and sharpen: modify the pixbuf in-place
      sharpen: added a preview
      resize images: added ability to select the file format
      find duplicates: do not allow to select more than a file
      extensions dialog: use a combo_box as category selector
      extensions dialog: put the category selector on the left
      extensions dialog: use a smaller font for the extension description
      sharpen tool: allow to enable/disable the preview
      extensions dialog: removed calls to the extensions_label
      added a tool to rotate images of any degree
      red eye removal: exit from the tool only when the ok button is clicked
      install the sharpen options ui file
      rotate tool: return the rotated image as a pixbuf
      rotate tool: added ability to set the background color
      rotate tool: added ability to change the rotation center
      image viewer: store the image in a cairo_surface instead of a GdkPixbuf
      image viewer: let the viewer tool paint the background
      image viewer: invalidate only the viewer window
      image viewer: renamed gth_image_viewer_set_surface as gth_image_viewer_set_image
      image viewer: fixed visualization of animations
      image viewer: implemented the black and white background for transparency
      image rotator: no need to create a pixbuf here
      image navigator: use the cairo_surface instead of the GdkPixbuf
      fixed memory leak when calling gth_image_viewer_get_current_pixbuf
      added CAIRO_SET_RGB[A] public macros
      implemented _cairo_image_surface_has_alpha
      image history: store images using cairo_surface_t instead of GdkPixbuf
      gth-image-histogram: calculate the histogram directly from the cairo_surface
      reorganized some code
      added _cairo_image_surface_scale_to to scale an image with cairo
      rotate tool: use the cairo_surface direclty without converting to/from a GdkPixbuf
      image viewer page: renamed pixbuf_changes as image_changed, as to to FALSE when loading a new image
      rotate tool: remove unused variable tmp_pixbuf
      rotate tool: save and restore the grid size
      rotate tool: added a label to the small angle adjustment; renamed a variable
      rotator: round the image position to the smaller integer
      rotator: reset the device offset to 0 after painting the image
      Merge branch 'cairo-surface' into rotate
      Merge branch 'rotate'
      red eye removal: fixed variable name and don't save the image in the history
      use the right function to destroy a cairo surface
      rotator: flush the surface before using it
      flip, mirror, rotate left and right: use the cairo_surface instead of a GdkPixbuf
      crop: use the cairo_surface instead of a GdkPixbuf
      resize tool: use the cairo_surface_t directly instead of converting to/from a GdkPixbuf
      added CAIRO_SET_RGBA_FAST macro that uses shift and add to divide by 255
      gth-async-task: added an optional user data to the functions
      removed CAIRO_SET_RGBA_FAST, which was broken
      fixed function name and signature
      negative image: use cairo_surface instead of GdkPixbuf
      CAIRO_SET_RGBA: no need to multiply if alpha is 255
      desaturate tool: use the cairo_surface directly instead of converting to/from a GdkPixbuf
      adjust colors: use the cairo_surface directly instead of converting to/from a GdkPixbuf
      adjust colors: use a samller font for the labels to give more space to the hscale
      enhance tool: operate on the cairo_surface directly instead of converting to/from a GdkPixbuf
      enhance tool: move data initialization in the thread
      equalize tool: operate on the image_surface directly instead of converting to/from a GdkPixbuf
      sharpen tool: operate on a cairo_surface directly instead of converting to/from a GdkPixbuf
      image navigator: fixed display of the image preview
      removed unused varibles
      rotate tool: disable the zoom commands
      removed unused callback
      rotate tool: enable zoom in destroy_options()
      rotate options: fixed spacing in label
      image navigator: create a small version of the image instead of scaling in the expose event handler
      Added GthImage as a generic container of image data
      added the convenience function gth_image_new_for_pixbuf
      fixed visualization of animated gifs
      fixed crash when an error occurs while loading an image
      started work on a cairo jpeg loader
      revert wrong change
      added a cancellable to the g_load_file_in_buffer function
      image loader: fixed the io scheduler code
      cairo-io-jpeg: added color space convertion
      cairo-io-jpeg: added YCCK color space conversion, added look-up tables
      added the _cairo_image_surface_transform_get_steps() function
      jpeg utils: added _jpeg_exif_orientation()
      cairo-io-jpeg: rotate the image without creating a new surface and scale to the requested size
      Revert "removed unused callback"
      set the TWO_STEPS policy for the image preloader
      g_load_file_in_buffer: use a 64K buffer
      use 10 preloaders
      use 10 preloaders
      added "copy image to clipboard" and "paste image to clipboard" commands
      Merge branch '10-preloaders'
      don't compile jpeg loader if libjpeg is not available
      check is actions is null before using it
      jpeg_utils: added function to read image width and height from the jpeg header
      fixed memory leak
      image metadata provider: return the corrent image dimesions when the exif orientation swaps width and height
      make jpeg_utils optional instead of mandatory.
      removed unnecessary include
      jpeg info: fixed loading of image dimensions
      add support for png dimensions
      fixed a comment
      removed unused code
      added an empty space
      use the GIO scheduler
      fixed bug when enabling/disabling thumbnails very fast
      update the title when the file list changes
      use the best filter for high quality zoom
      compile the image viewer after jpeg_tools
      preloader: load the non-requested image at original size
      fixed crash when the image is smaller than the preview area
      fixed surface drawing with cairo 1.9 and greater
      Merge branch 'rotate-tool'
      set the alpha channel to 255 if present
      fixed ref/unref of pixbufs
      removed double gth-file-tool-rotate.c in SOURCES
      rotate tool: removed the Crop and Undo buttons
      don't try to create cairo surfaces bigger then 32767
      cairo-io-jpeg: use the shift to create the cairo pixel
      cairo utils: added _cairo_multiply and CAIRO_RGBA_TO_UINT32
      cairo-io-jpeg: use the new cairo utils
      renamed _cairo_multiply to _cairo_multiply_alpha
      added a cairo png loader
      image preloader: cancel the current loader before starting the new one
      Fixed renaming of files when the new name is entered quickly.
      image metadata provider: set the mime type as well
      correctly display images with wrong extension name
      slideshow: use the progress instead of the msecs to make the code more generic
      slideshow: use a sinusoidal increment and decrement on the animations
      slideshow: set the transition duration to 650ms
      set the flash thumbnail queue timeout to 100ms
      check whether surface is null before using it
      added a map view to view the geographical position where the picture was taken
      updated POTFILES.in
      map view: added a space after minutes and seconds for better readability
      histogram view: added the thousands separator to the pixel total
      reverted wrong change to the property view
      rotate tool: reorganized the options to make things less cluttered
      use gtk_widget_reparent to move the file_properties widget in another container
      hide the embed after unrealizing the widget to try to fix a crash with libchamplain
      cairo-io-png: fixed crash and memory leak when cancelling the operation
      make the libunique dependency optional
      Revert "There's no depth param in the gdk_window_get_geometry function anymore"
      check for libbrasero 2 instead of 3
      removed use of gdk_drawable_get_size
      removed use of deprecated gtk_combo_box API
      do not access suggested_action directly
      removed calls to gtk_about_dialog_set_url_hook and gtk_about_dialog_set_email_hook
      do not acces the evet_window attribute directly
      fixed some errors when linunque is not used
      Merge branch 'gtk-2-24'
      updated the required gtk+ and glib versions
      removed the deprecated has-separator property from the ui files
      cairio-io: set the has_alpha flag when loading a jpeg or png image
      moved the grid painting function in cairo-utils.c
      image rotator: added crop_region and grid_type
      image rotator: removed unused code
      added the crop option for consinstency
      rotate image: added ability to choose the original image size as well
      rotate image: use always high quality, no need for an option
      rotate image: batch of changes
      rotate image: pass a cairo_surface to the rotate function, instead of a GdkPixbuf
      rotate image: misc changes
      rotate image: load and save the tool options
      image selector: fixed display of the image selection
      image rotator: make sure the crop area is inside the original image
      image selector: reduce the selection size by 0.5
      image-viewer-tool: added [set|unset]_viewer functions
      rotate image: simplified the align horizonal/vertical function
      updated POTFILES.in
      disable the map view by default as it crashes frequently for unknown reasons
      rotate image: use a crosshair cursor when drawing the alignment
      rotate image: added ability to rotate dragging the image
      fixed rotation when dragging the image from the first quarter
      fixed histogram computation and visualization
      moved the extensions activation in the preferences dialog
      no need to set the font description
      set the hscroll policy to automatic
      preferences dialog: show the number of extensions for each category
      gth-file-source: added the remove virtual function
      moved the delete files and trash files functions to gth-file-source-vfs
      pressing the delete key in a catalog removes the file from the catalog instead of deleting the file from disk
      fixed function arguments
      moved the timeout removal from finalize to close
      check whether the viewer is null before using it
      fixed display of the tag list in the search dialog
      fixed the desktop background setting with GNOME 3.0 or higher
      Fixed automatic creation of comments from embedded data
      emit an update signal after synchronizing with the embedded metadata
      change 'make dist' to create tar.xz files
      fixed progress-bar jumps when copying or moving files
      Fixed adjust-time tool not changing minutes and seconds
      added a exiv2_clear_metadata function
      added the delete metadata command in the tool list
      added the delete metadata task
      fixed crash when the pixbuf is null
      implemeted the "delete-metadata" function for embedded metadata and comments
      notify the file change after deleting the metadata
      delete metadata: added a confirmation dialog
      ignore the embedded thumbnail if it's less the 90% of the requested size
      disable the screensaver when playing videos or slideshows
      updated POTFILES.in
      use the new thumbnail system if the --enable-gnome-3 flag is used
      updated for version 2.13.2

Stefano Pettini (33):
      rotate tool: initial empty implementation
      rotate tool: updated tooltips
      rotate tool: placeholder for future image rotation algorithm
      rotate tool: updated UI
      rotate tool: UI working
      rotate tool: improved UI and fixed memory leak
      rotate tool: Added center of rotation
      rotate tool: added icons
      rotate tool: fixed order of parameters
      rotate tool: implemented skew algorithm, with linear interpolation
      rotate tool: removed skew algorithm, ready for affine transformation
      rotate tool: algorithm implemented, interpolation not yet
      rotate tool: removed center of rotation, has no meaning here
      rotate tool: removed cropping from the rotation algorithm
      rotate tool: bilinear interpolation, enabled by default
      rotate tool: improving UI
      rotate tool: minor improvements to the algorithm
      rotate tool: improved crop UI
      rotate tool: fixed display of cropping region
      rotate tool: crop completed, algorithm fixed and UI improved
      rotate tool: minor improvements
      image selector: new grid type, performance and cosmetic improvements
      rotate tool: improved UI with the new grid
      rotate tool: improved crop/undo UI and performances
      rotate tool: automatic alignment completed
      rotate tool: fixed dest_pixbuf management
      rotate tool: further improved crop UI
      gtk utils: setting the GtkSpinButton climb rate correcly
      rotate tool: added reset button
      rotate tool: minor fixes and adjustments
      rotate tool: locking the cropping region inside the rotated image
      rotate tool: added proper support for alpha channel
      rotate tool: option to select the background color



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]