[libchamplain] Rename stage to view_box to avoid confusion
- From: Jiří Techet <jiritechet src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [libchamplain] Rename stage to view_box to avoid confusion
- Date: Sat, 12 Feb 2011 19:07:54 +0000 (UTC)
commit 0e32fff8875554a9e5f001e6da523332244e19e5
Author: JiÅ?Ã Techet <techet gmail com>
Date: Sat Feb 12 13:22:05 2011 +0100
Rename stage to view_box to avoid confusion
champlain/champlain-view.c | 14 +++++++-------
1 files changed, 7 insertions(+), 7 deletions(-)
---
diff --git a/champlain/champlain-view.c b/champlain/champlain-view.c
index e40cbce..ea06509 100644
--- a/champlain/champlain-view.c
+++ b/champlain/champlain-view.c
@@ -134,7 +134,7 @@ typedef struct
struct _ChamplainViewPrivate
{
- ClutterActor *stage;
+ ClutterActor *view_box;
ChamplainMapSource *map_source; /* Current map tile source */
gboolean kinetic_mode;
@@ -510,10 +510,10 @@ champlain_view_dispose (GObject *object)
priv->map_source = NULL;
}
- if (priv->stage != NULL)
+ if (priv->view_box != NULL)
{
- g_object_unref (priv->stage);
- priv->stage = NULL;
+ g_object_unref (priv->view_box);
+ priv->view_box = NULL;
}
if (priv->license_actor != NULL)
@@ -923,7 +923,7 @@ champlain_view_init (ChamplainView *view)
priv->keep_center_on_resize = TRUE;
priv->zoom_on_double_click = TRUE;
priv->license_actor = NULL;
- priv->stage = NULL;
+ priv->view_box = NULL;
priv->kinetic_mode = FALSE;
priv->viewport_x = 0;
priv->viewport_y = 0;
@@ -990,13 +990,13 @@ champlain_view_init (ChamplainView *view)
/* Setup stage */
priv->layout_manager = clutter_bin_layout_new (CLUTTER_BIN_ALIGNMENT_CENTER,
CLUTTER_BIN_ALIGNMENT_CENTER);
- priv->stage = g_object_ref (clutter_box_new (priv->layout_manager));
+ priv->view_box = g_object_ref (clutter_box_new (priv->layout_manager));
clutter_bin_layout_add (CLUTTER_BIN_LAYOUT (priv->layout_manager), priv->kinetic_scroll,
CLUTTER_BIN_ALIGNMENT_FILL,
CLUTTER_BIN_ALIGNMENT_FILL);
- clutter_container_add_actor (CLUTTER_CONTAINER (view), priv->stage);
+ clutter_container_add_actor (CLUTTER_CONTAINER (view), priv->view_box);
resize_viewport (view);
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]