[gtk+] Created tag 3.0.0



The unsigned tag '3.0.0' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Thu Feb 10 15:27:17 2011 -0500

    3.0.0

Changes since the last tag '2.99.3':

Bastien Nocera (1):
      gtk-demo: Use symbolic icon that exists

Benjamin Otte (2):
      gdk: Fix typo in documentation string
      API: image: Move private struct definitions into private header

Carlos Garnacho (9):
      Use cairo_push_group() to mix backgrounds during transitions
      Ensure gtk_render_background()/frame() yield the same shape
      GtkStyleContext is meant to have a GdkScreen
      Handle insensitive cell renderer flags in gtk_cell_renderer_get_state()
      s/state_changed/state_flags_changed/ in GtkComboBox
      Fix color style properties lookup when the color resolution fails
      doc: Add a note about prioritization of GtkStyleProviders
      Avoid the need for cairo_push_group() in gtk_render_background()
      Change required glib version from "2.28" to "2.28.0"

Changwoo Ryu (1):
      Updated Korean translation

Colin Walters (1):
      introspection: Remove redundant include

Daniel Mustieles (1):
      Updated Spanish translation

Fran Diéguez (1):
      Updated Galician translations

Garrett Regier (1):
      Fix annotation that broke the docs

Hans Breuer (3):
      win32: msvc build update
      win32: no more GdkNativeWindow and related changes
      No more gtk_plug_*/gtk_socket_* symbols on win32

Javier Jardón (8):
      Remove latest bits of GtkItemFactory
      configure.ac: Remove some obsolescent macros
      configure.ac: Use AS_HELP_STRING instead deprecated AC_HELP_STRING
      configure.ac: Use AC_COMPILE_IFELSE instead deprecated AC_TRY_COMPILE
      configure.ac: Remove some more obsolete macros
      Use faster new G_VALUE_COLLECT_INIT variant instead G_VALUE_COLLECT
      README.in: Fix link to the migration guide
      configure.ac: Depend on stable versions of other libraries

Johan Dahlin (3):
      Remove tab as it confused g-ir-scanner
      Rename time to time_ to avoid a scanner warning
      introspection: Remove redundant include

John Ralls (1):
      Update quartz to reflect deletion of GdkNativeWindow and client_message functions.

Khaled Hosny (1):
      Updated Arabic translation

Kjartan Maraas (1):
      Updated Norwegian bokmål translation.

Laszlo Pandy (2):
      [GI] Add method annotations to remaining gtk_drag_* functions.
      [GI] Add method annotation for gtk_grab_add and gtk_grab_remove.

Martin Pitt (2):
      [GI] Mark mis-detected constructors as such
      [GI] Annotate gtk_drag_{dest,source}* as methods

Matthias Clasen (52):
      Bump version
      Fix another GtkFixed regression, in gtk_fixed_forall()
      Don't build pixbuf engine, still
      Fix the build with --enable-gtk2-dependency
      Don't g_object_unref cairo surfaces
      Protect against tree_view being NULL
      XI2: don't translate button releases as scroll events
      Remove debug spew
      Add translation entries for more common keysyms
      Strip XF86 prefix from untranslated keysyms
      Add an English translation
      Add an empty English translation for properties
      Share code to fill GdkEventKey.string
      Pass group state to _gdk_x11_device_xi2_translate_state
      XI2: translate group state back into core state
      Fix a memory leak in GtkCSSProvider
      Improve GtkApplication migration guide
      Don't assume a screen exists before realize()
      Simple test for display-less widget creation
      Add a testcase for cell positions
      Migration guide additions
      Don't leak a cell area context
      Demonstrate the problem with a workaround
      Avoid tons of warnings from stylecontext initialization without screen
      Add a testcase for state propagation problems
      Always chain up in ::style-updated
      Fix problems with state propagation
      Set the correct initial value for the direction property
      Update the context direction when emitting ::direction-changed
      Add warnings about environment variables
      Extend the mixed-dependency check to modules as well
      Update NEWS
      Define the required introspection version in configure.ac
      Add links to the migration guide
      Remove annotation that breaks the docs
      Add some missing symbols to the docs
      Don't export gtk_cell_area_box_init_groups
      Don't export GtkModifierStyle symbols
      Remove no-longer exported symbols from the symbol list
      Documentation tweaks
      Give the GDK docs some love
      More GDK documentation tweaks
      Add some more info for desktop app info
      Quell another warning
      Change the title of the GDK docs to mention '3'
      Make online references point to the right place
      Don't try to modify readonly strings
      Remove a long-unsupported script that does nothing
      Minor formatting tweak
      Bump the version to 3.0.0
      Mention library soname change
      Correct sonames appearing in the docs

Michael Natterer (7):
      gtk: don't style GtkLabel:selected's color separately
      gtk: get rid of two cases of invalidating the spinbutton when not needed
      gtk: remove function gtk_entry_queue_draw() and call gtk_widget_queue_draw()
      gtk: bail out in render_background_internal() if the extents are <= 0
      gtk: make the .trough background-color darker() as it was in GTK+ 2.x
      gtk: gtk_cell_renderer_get_state(): a row can be both selected and insensitive
      gtk: gtk_cell_renderer_get_state(): check the widget's effective sensitivity

Murray Cumming (1):
      Add "extern C" declarations around AppChooser headers.

Piotr DrÄ?g (3):
      Updated Polish translation
      Updated Polish translation
      Updated Polish translation

Tristan Van Berkom (9):
      Fixed GtkContainer buildable implementation to set packing properties explicitly set to "" (i.e. explicitly set to nothing).
      Fixed GtkCellLayout buildable implementation to set cell properties explicitly set to "" (i.e. explicitly set to nothing).
      Added default implementation of GtkCellRendererClass.get_request_mode()
      Added default implementations of various GtkCellArea vfuncs.
      Fixing GtkColorButton to redraw itself when gtk_color_button_set_rgba() is called.
      Added set_transient_for() implementation for GdkOffscreenWindow
      Fixed gtk_recent_chooser_menu_set_current_filter to update the local pointer.
      Optimize queue_resize_on_widget()
      Added padding to GtkTextLineDisplay struct for an addition of GdkRGBA pointer comming soon.

Yaron Shahrabani (1):
      Updated Hebrew translation.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]