[gtk+] Created tag 3.1.12



The unsigned tag '3.1.12' was created.

Tagger: Matthias Clasen <mclasen redhat com>
Date: Mon Aug 15 21:57:28 2011 -0400

    3.1.12

Changes since the last tag '3.1.10':

Alberto Ruiz (109):
      GtkFontChooser: Remove all cruft from the current GtkFontSelection implementation and start a new widget
      GtkFontChooser: Add private members to GtkFontSelectionPrivate
      GtkFontChooser: Create fundamental widgets for the new GtkFontSelection
      GtkFontChooser: Avoid using show_all explicitely
      GtkFontChooser: Added main treeview
      GtkFontChooser: Create alignment for the preview entry
      GtkFontChooser: Adding the alignment to the selection
      GtkFontChooser: Adding the preview
      GtkFontChooser: Added slider and spin button
      GtkFontChooser: Setting the height of the preview and have a define for the top padding
      GtkFontChooser: Set vbox to no homogeneus
      GtkFontChooser: Create functions to bootstrap the treeview column and settings and update the font list
      GtkFontChooser: Add column and cell renderer
      GtkFontChooser: Populated font list model
      GtkFontChooser: Set rules hint to TRUE in the main tree view
      GtkFontChooser: Improvements in the font face listing
      GtkFontChooser: Iterate over faces as well as families to list them
      GtkFontChooser: Compilation warning cleanups
      GtkFontChooser: Setting the default preview text and the default font size
      GtkFontChooser: Adding a tree model filter for the search functionality
      GtkFontChooser: Inserted and deleted text callbacks
      GtkFontChooser: Live search implemented
      GtkFontChooser: Set the initial size to the slider, initial callbacks for size change
      GtkFontChooser: Search entry icon is now dynamic depending on the content
      GtkFontChooser: Getting the refiltering right for the clear icon. Filter function speedups.
      GtkFontChooser: The spinner now updates the slider size if it is within the range
      GtkFontChooser: Improvements on the spin/slider interaction
      GtkFontChooser: Fixed size updating in the  preview
      GtkFontChooser: Layout enhancements, using a scrolled window for the preview entry.
      GtkFontChooser: Setting a default vertical size
      GtkFontChooser: Enable font selection
      GtkFontChooser: Added a test program
      GtkFontChooser: Better cursor selection and model leak fixes
      GtkFontChooser: Keep reference to the face and the family objects
      GtkFontChooser: Ellipsize cell renderer and set a better size list
      GtkFontChooser: Setting a minimum width andfix the markup for the rows
      GtkFontChooser: Fixing mouse scroll zooming behaviour for the preview and the size controls
      GtkFontChooser: Improvements on the size setting signals between the preview, scale and spinbutton. Adding more string fields to the model to allow for backwards compatibility.
      GtkFontChooser: Layout improvements. Adding shadow to scrolled windows. Font+Face text is now bold.
      GtkFontChooser: Layout improvements, spacing between elements and default widget size.
      GtkFontChooser: Filter also by font face
      GtkFontChooser: Initial support for deprecated functions
      GtkFontChooser: initialization and destruction of deprecated widgets and data models
      GtkFontChooser: update the size model for the deprecated size list
      GtkFontChooser: Add deprecated calls to the test
      GtkFontChooser: Fix segmentation fault in deprecated size list population
      GtkFontChooser: Add tree view columns for the deprecated widgets
      GtkFontChooser: Populate font family names in the deprecated family list
      GtkFontChooser: Populate face names in the deprecated face list
      GtkFontChooser: Use scrolled windows for the deprecated widgets
      GtkFontChooser: Unref deprecated widgets on finalize
      GtkFontChooser: Use GTK_DISABLE_DEPRECATED to encapsulate the deprecated functionality
      GtkFontChooser: Add callbacks and improve test to take deprecated widgets into account
      GtkFontChooser: Use the theme font as the default font
      GtkFontChooser: Refactoring the default font size, face and family assignment for clarity
      GtkFontChooser: Update deprecated font list on slection
      GtkFontChooser: Blocking the cursor change callbacks from happening on the deprecated widgets when selecting the font from the fontselector
      GtkFontChooser: Update size when selecting an item of the deprecated size list
      GtkFontChooser: Update selection on deprecated face or font list selection
      GtkFontChooser: Update selection on deprecated size list selection
      GtkFontChooser: Improve bootstrapping of the deprecated lists
      GtkFontChooser: Setting the font-name property. Test updates. Remove warnings.
      GtkFontChooser: gtk_font_selection_set_font_name implementation
      GtkFontChooser: check if font name is NULL in gtk_font_selection_set_font_name
      GtkFontChooser: implement gtk_font_selection_set/get_preview_text
      GtkFontChooser: Added test for GtkFontSelectionDialog
      GtkFontChooser: Changed dialog label from OK to Select, deprecated get_ok_button and internal apply button.
      GtkFontChooser: Add gtk_font_selection_dialog_get_select_button and use GTK_DISABLE_DEPRECATED in gtkfontsel.h
      GtkFontChooser: Use GTK_DISABLE_DEPRECATED on the test code
      GtkFontChooser: Better test preview text
      GtkFontChooser: Add a property to control whether the preview entry is shown or not
      GtkFontChooser: Update fontlist on style change
      GtkFontChooser: Check if the deprecated widgets are present before updating the size list
      GtkFontChooser: Remove wrong usage of GTK_DISABLE_DEPRECATED
      GtkFontChooser: Renaming the class names and fixing the tests
      GtkFontChooser: Expose the new widget in gtk.h and add test cases
      GtkFontChooser: Removed support for deprecated functionality from GtkFontSelector
      GtkFontChooser: Restore automatic alignment on scroll to selection
      GtkFontChooser: Now shearch filters each individual term rather than the whole string at once
      GtkFontChooser: Use symbolic icons in the filter entry
      GtkFontChooserDialog: Split the dialog out of gtkfontchooser.[ch] to gtkfontchooserdialog.[ch]
      GtkFontChooser: GtkFontChooserDialog: Update documenation to reflect Since: 3.2
      GtkFontChooser: Initial work to use GtkGrid
      GtkFontChooser: Add preview entry to the grid
      GtkFontChooser: Use const instead of G_CONST_RETURN
      GtkFontChooser: Use GtkBox instead of GtkVBox as base class.
      GtkFontChooser: Fix expand and fill properties for the grid layout
      GtkFontChooser: Use a nested grid to achieve the right layout in the size controls
      GtkFontChooser: Remove the themed color for the font title
      GtkFontChooser: Fix scroll callback connected to treeview instead of preview
      GtkFontChooser: Remove default geometry defines
      GtkFontChooser: Cleanup comments and fix indentation alignments
      GtkFontChooser: Fix size synchronization between slider and spin button
      GtkFontChooser: Remove outdated Copyright information
      GtkFontChooserDialog: Use g_object_new to set initial values in the dialog constructor
      GtkFontChooser: Set correct margin values between UI elements
      GtkFontChooserDialog: Fix get_font_chooser public function name
      GtkFontChooserDialog: Add parent window as a parameter in the constructor
      GtkFontChooser: Setting all ought to be static functions as static
      GtkFontChooser: Added missing breaks in switch statements
      GtkFontChooser: Using explicit comparisons for g_strcmp0
      GtkFontChooser: Fixed coding style wrt spacing around operators
      GtkFontChooser: Using the widget instead of the private struct as signal data in all conects
      GtkFontChooser: Using G_N_ELEMENTS instead of a define
      GtkFontChooser: Missing G_END_DECLS in fontchooser header
      GtkFontChooser: font-name property notification wasn't properly propagated during size change from the spinbutton
      GtkFontChooser: Stub code to handle empty list by search.
      GtkFontChooser: get_font_name did not return the font size
      GtkFontChooserDialog: GtkFontButton now uses GtkFontChooserDialog instead of GtkFontSelectionDialog

Alexander Shopov (1):
      Updated Bulgarian translation

Benjamin Berg (1):
      Fix polling for new data in cups print backend (bug #599664)

Cosimo Cecchi (2):
      combobox: add a "combobox-entry" style class for comboboxes with entries
      settings: use the right RC parser for the gtk-visible-focus setting

Dan Winship (1):
      Fix cut-and-paste error in GtkEntryAccessible/GtkLabelAccessible

Daniel Mustieles (1):
      Updated Spanish translation

Daniel Nylander (2):
      Updated Swedish translation
      Updated Swedish translation

Federico Mena Quintero (16):
      Log to recent-files when confirming the file chooser
      Save selection to recent-files in the asynchronous Save cases
      Rename stop_operation() to operation_mode_stop()
      Remove duplicated code from *_switch_to_browse_mode()
      Centralize changing the operation mode in operation_mode_set()
      Make operation_mode_set() handle SEARCH and RECENT modes as well
      Move the widgets above the hpaned to their own box
      Discard the search widgets in a separate function
      Only unset the entry's contents if the entry exists
      Create the location_entry in a single function
      Remove the unused, initial-text logic from the location entry
      Switch to OPERATION_MODE_BROWSE when switching to volume or file shortcuts
      Set the location mode when changing the operation mode
      Merge branch 'bgo593793-filechooser-recent-folders-master'
      bgo#655822 - Put back the expand-folders schema in gsettings
      Merge branch 'bgo593793-filechooser-recent-folders-master'

Felix Riemann (1):
      gtkstyleproperty: fix small memory leak

Greg Hellings (1):
      Install gdk/win32 headers

Ignacio Casal Quinteiro (1):
      Fix warning

Javier JardÃn (2):
      Remove local copy of introspection.m4
      configure.ac: Bump gdk-pixbuf required version

Jesse van den Kieboom (1):
      Added gtk_text_iter_assign API

John (J5) Palmieri (1):
      [gi] annotate gdk_container_set_user_data to take a GObject

John Ralls (2):
      Bug 655122: Detect OSX version for handling version-dependent special     cases (the one at hand is window resizing, which is handled differently     on OSX 10.7 from earlier versions).
      Bug 655122: Lion Crashes during resize

Jorge GonzÃlez (1):
      Updated Spanish translation

JÃrg Billeter (1):
      widget: Add transfer annotation for gtk_widget_set_window

Kalev Lember (1):
      gtk-demo: Fix the path to demo sources for the win32 build

Kristian Rietveld (6):
      Bug 508601 - Copying from GTK+ applications causes crash
      quartz: Remove MAC_OS_X_VERSION_MIN_ALLOWED ifdef
      quartz: return modifiers instead of an event mask ...
      quartz: remove _gdk_quartz_events_get_current_event_mask
      quartz: use already existing current_button_state variable
      Bug 655545 - condition can never be true in gtk_tree_view_real_set_cursor

Laszlo Pandy (1):
      Fix incomplete &gt; entities in docs.

Matthias Clasen (37):
      post-release bump
      Ditch some long dead perl cruft
      Fix up last commit
      Update gtk_widget_get_accessible() docs
      Mention the demise of gail in 3.2 release notes
      Move GtkBuildable implementation up before accessibility
      Drop GtkIconViewAccessiblePrivate
      Use G_DEFINE_TYPE for GtkIconViewAccessible
      Drop some grandiosity from the AtkAction implementation
      Rework AtkText implementation
      Minor cleanups
      Use G_DEFINE_TYPE for GtkIconViewItemAccessible
      widget-factory: small tweaks
      GtkGrid: Add a way to insert rows or columns
      Fix entry drawing in the presence of margins
      Make focus rectangles optional
      Trivial formatting fixes
      Simplify a few things
      Fix minor issues in the tests
      Avoid extraneous signals at destroy time
      Rename some statics
      Clean up error handling
      Just use a single grid
      Make the fontchooser dialog come up in a reasonable size
      Add 'no matches' functionality
      Add filtering to the font chooser
      Add new symbols
      Add docs
      Trivial formatting fix
      Deprecate GtkFontSelection and GtkFontSelectionDialog
      Keep the currently selected font over theme changes
      Make setting fontname work, independent of a screen
      Fix a typo
      testgtk: remove dead code
      Update NEWS for 3.1.12
      Fix up symbol lists for recent api additions
      3.1.12

Michael Hutchinson (1):
      Bug 655074 - Fix crash with undecorated windows on MacOS Lion

Paolo Borelli (1):
      Do not manually create empty label

Pavel Holejsovsky (3):
      Enable introspection of X11-specific functions and methods
      Add annotations so that methods are properly paired to objects.
      Avoid introspection scanner warning on GtkPlug and GtkSocket

Rachid BM (1):
      Language improvements

Sergio Cipolla (1):
      Fixed a string in Brazilian Portuguese translation

Will Thompson (1):
      GtkAppChooser: improve grammar in short_description

Yuri Kozlov (1):
      Updated Russian translation

plesry (1):
      Updated Traditional Chinese translation(Hong Kong and Taiwan)



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]