[gjs] Created tag GJS_0_6



The signed tag 'GJS_0_6' was created.

Tagger: Owen W. Taylor <otaylor fishsoup net>
Date: Thu Mar 18 17:38:38 2010 -0400

    Tag for Release 0.6

Changes since the last tag 'GJS_0_5':

Colin Walters (3):
      Add VALGRIND_ARGS variable to Makefile
      Optimize function invocation, fix allocation cleanup
      Run "torture" test functions from everything

Dan Winship (1):
      gjs_throw: convert error string from UTF-8

Florian Müllner (1):
      Remove user_data arguments for callbacks

James Willcox (1):
      Add gjs_context_get_native_context which allows access to the JSContext

Johan Bilien (2):
      test: Add a (failing) test with an "out" argument followed by another
      gi: Do not increment argument counter for OUT arguments

Johan Dahlin (50):
      [gjs-console] Add -rpath for libmozjs.so
      [importer] Add datadir/share/gjs-1.0 to searchpath
      [examples] Add a http-server example using libsoup
      [examples] Add a cat example using gio
      [gjs-console] Add a --command/-c argument
      [jsapi-utils] Add support for doubles
      [jsapi-util] Add a few convenience macros
      Merge remote branch 'origin'
      [cairo] Add a module skeleton and build system
      [cairo] Add context prototype
      [cairo] Add an abstract Surface prototype
      [cairo] Add an ImageSurface prototype
      [cairo] Add a PostScript surface
      [cairo] Add PDFSurface prototype
      [cairo] Add a SVGSurface prototype
      [cairo] Add cairo enums
      [cairo] Add Context constructor
      [cairo] Add Context methods
      [cairo] Add an abstract Pattern prototype
      [cairo] Add an abstract Gradient prototype
      [cairo] Add a LinearGradient prototype
      [cairo] Add a RadialGradient prototype
      [cairo] Add a SurfacePattern prototype
      [cairo] Add surface/pattern method to Context
      [cairo] Add documentation
      [cairo] Update indentation of private header
      [build] Fix up makefile indentation
      [cairo] ImageSurface is not optional
      [cairo] Plug a few string leaks
      [cairo] Rename cr to context in public API
      [cairo] Make macros more readable
      [cairo] update todo
      [cairo] Check status after all cairo calls
      [cairo] Fix leaks in showText/selectFontFace
      [cairo] Take reference when attaching cairo structs
      [cairo] Improve reference counting
      [cairo] Make internal structures private
      [cairo] Wrap a few new methods for context
      [cairo] disable getDash, which is incorrectly bound
      [cairo] Return the correct surface type
      [cairo] Return the correct pattern type
      [cairo] Add a SolidPattern
      [cairo] Update doc
      [cairo] Improve error messages
      [cairo] Check status for surface methods
      [cairo] Fix two typos
      [cairo] Rename set/getAntiAlias->set/getAntialias
      [cairo] Add tests
      Merge remote branch 'origin' into cairo
      Merge branch 'cairo'

Maxim Ermilov (2):
      support build with mozilla-js that compiled with --disable-threadsafe --enable-debug
      remove incorrect asserts in function.c

Owen W. Taylor (1):
      Bump version to 0.6

Tommi Komulainen (9):
      gi: make sure to release correct arguments
      gi: assert gjs_callback_from_arguments doesn't access argv out of bounds
      gi: do not collect user_data argument(s) for callbacks when not passed
      gi: assert we don't access argument arrays out of bounds
      gi: calculate out_arg_cvalues length correctly
      gi: make it more clear only processed_in_args are being released
      gi: assert we don't access argv out of bounds
      gi: assert all arguments are processed prior to invoking the function
      gi: assert all arguments were released after invoking the function



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]