[perl-Champlain] Created tag 0.12



The signed tag '0.12' was created.

Tagger: Emmanuel Rodriguez <emmanuel rodriguez gmail com>
Date: Sun May 23 20:46:58 2010 +0200

    Version 0.12

Changes since the last tag 'LIBCHAMPLAIN_0_5_1':

Brian Cameron (1):
      Fix void functions to not try and return a value.  Fixes bug #612758.

Emmanuel Rodriguez (77):
      Reset the update prepared statement before each execution
      Merge branch 'master' of git://git.gnome.org/libchamplain
      Require libchamplain 0.5
      champlain_marker_get_highlight_color returns a const pointer
      C file no longer exists
      ChamplainCache no longer exists
      Bindings for ChamplainErrorTileSource
      Fixe a typo in the class name
      Bindings for ChamplainFileCache
      Bindings for ChamplainMapSourceChain
      Bindings for ChamplainNetworkTileSource
      The corresponding C objects no longer exist
      Bindings for ChamplainTileCache
      Don't require a size for champlain_tile_cache_store_tile since a SV knows it's size
      ChamplainZoomLevel and ChamplainNetworkMapSource no longer exist
      Tests for Champlain::TileCache
      New version Champlain::Tile
      Fix the name or a test
      Bindings for ChamplainTileSource
      Sort the types by name
      Bindings for champlain_tile_set_fade_in and champlain_tile_get_fade_in
      Bindings for champlain_base_marker_get_latitude and champlain_base_marker_get_longitude
      Don't check for libchamplain's version with CHECK_VERSION
      Fix the test
      Bindings for champlain_map_source_get_next_source and champlain_map_source_set_next_source
      Bindings for champlain_map_source_factory_create_cached_source
      Tests don't require Test::Exception to be installed
      Remove the binding for functions that no longer exist
      Use a temp folder for the file cache unit tests
      Show the stage if args are passed (debug mode)
      List the champlain modules in a xs file
      Champlain/Memphis bindings
      Add Champlain::HAS_MEMPHIS
      Tests for Champlain::BoundingBox
      Formatting
      Test for Champlain::BoundingBox::get_center
      Unit tests for Champlain::LocalMapDataSource
      Fix the PREFIX for Champlain::NetworkMapDataSource
      XS files for the memphis related API
      Unit tests for Champlain::NetworkMapDataSource
      Version change to 0.12
      Update the copyright
      Memphis maps
      Bindings for Champlain::MemphisTileSource
      Bindings for Champlain::MapDataSource
      Bindings for Champlain::MemphisTileSource
      *** Add mappings for the Memphis types
      Fix the test for create_cached_source()
      Fix the test for $view->stop_go_to()
      Fix the test for $view->ensure_markers_visible
      Fix test_event() for ChamplainView
      Fix the test count
      Remove previous objects from the stage
      Set the stage globally
      Add more debug when is_view_near fails
      Show the stage when calling the animation test.
      Hide the stage after showing it in test_ensure_markers_visible()
      Bindings for the 2 extra memphis maps in the factory
      Remove Champlain::Tile::get_modified_time_string
      Unit test fix: Champlain::MapSourceFactory->OAM is now named 'OpenAerialMap'
      Add 2010 to the Copyright
      Use the mephis types provided by Memphis
      Remove files that no longer exist
      Add ChamplainTile::get_modified_time_string()
      Updated the manifest
      Remove all files but the perl bindings
      The perl bindings are now at the top level
      Remove the file Makefile.am which is no longer needed
      Add perl-Champlain.doap which is required by the gnome git server
      Remove the bindings for Champlain::Tile::get_modified_time_stirng
      Adjust the ignore files
      Fix Champlain::HAS_MEMPHIS
      Better handling of the detection of libmemphis
      Skip tests needing Memphis support
      More debug in the test messages for test_event()
      Don't include coverage.sh
      Ignore the .git and test-cache folders

Fridrich Å trba (2):
      Build fixes for windows
      Make the windows mkdtemp be robust with non-ascii characters too

Jason Woofenden (1):
      Load tiles near the middle first

JiÅ?í Techet (62):
      Documentation of the new loading chain.
      Use cached source when switching map sources.
      Fix view destruction upon shutdown.
      Use default cache path when not specified.
      Make it possible to manually chain chains.
      Fix asynchronous tile loading
      Fix cache initialization
      Fix deletion of the wrong directory when temporary cache is used
      New tile unref logic and various leak fixes
      Test using memphis_renderer_tile_has_data()
      Remove CHAMPLAIN_STATE_INIT
      Cancel download of tiles that get out of the viewport
      Disable use of memphis_renderer_tile_has_data until it works correctly
      Fix blocked panning bug
      Insert tile content into parent only when state set to DONE
      Set tile size during its creation
      Put the tiles immediately to the right position
      Make view_load_visible_tiles() less brain-damaging
      Add test that simulates the use of GPS with libchamplain
      Fix bug where champlain_view_center_on() didn't work properly
      Make champlain_view_ensure_visible() easier to read
      Remove extra function calls in champlain_view_set_map_source()
      Fix TODO in view_reload_tiles_cb()
      Remove view_tiles_reposition ()
      Set zoom level only if champlain_zoom_level_zoom_to() is successful
      Remove the workaround related to resize_viewport()
      Fix scroll_to() for CHAMPLAIN_SCROLL_MODE_PUSH
      Remove extra condition
      When removing tiles from container, iterate using clutter_container_get_children()
      Iterate through container using clutter_group_get_nth_child() when the container is not modified
      Completely remove ChamplainZoomLevel
      Replace pow() with bit shift to be sure we are fast
      Base viewport update on time as well
      Simplify and optimize time-based redrawing
      Fix zoom-out at low zoom level
      Fix zoom level 0 not displayed
      Some cleanups in view_load_visible_tiles()
      Use tile-presence map instead of going through tile list over and over
      Remove all invalid tiles within view_load_visible_tiles()
      Code cleanup
      Revert buggy commit
      Move fill_tile() call from view_load_visible_tiles() to an idle callback
      Load tiles in true spiral pattern
      Position tiles even when they don't need to be loaded
      Remove update of tile map
      Proper fix of bug 575133
      Remove my last question/comment
      Call viewport_pos_changed_cb() only when we want to
      Fix changing map source doesn't update the display
      Make fade-in a property of a tile
      Lie a bit about not fading in
      Coding style fixes
      Fix violations against my own coding style
      Access private members through priv member of the class. Everywhere.
      Get rid of public privates for good
      Display polygons again
      Fix freeing const string
      Move variable declarations to the top of view_load_visible_tiles()
      Optimize ChamplainView state update
      Remove tile ref/unref in ChamplainTile
      Unref GdkPixbufLoader
      Many changes in build process

Lorenzo Masini (2):
      Fix Python demos to use ChamplainEmbed
      Ship all the python .defs files in tar balls

Pierre-Luc Beaudoin (24):
      580372: Get rid of champlain_view_set_size
      Update gitignore for demos
      center on ealier in the demo
      Make the licence code work as the scale code
      Rethink the init process
      Remove the loading of the ETAG from the file system
      Remove deprecated function call in urlmarker demo
      Don't redraw the scale so often
      Don't do everything everytime the user moves
      Update python bindings not to use deprecated code
      Make sure the licence and scale actors are on top
      Update scale and license on realize (once the map is available)
      Load tiles async from hard drive
      Add special paths for Maemo
      Also change path of cache db
      Update NEWS and bump libtool version
      Adjust path name on Maemo to match Maep
      do not emit a notify for lat and lon if the change is too small
      Merge branch 'libchamplain-0-4'
      Remove the code from champlain_file_cache_new
      Unref the info only if it was valid
      Properly get rid of previous image
      Merge branch 'libchamplain-0-4'
      Update maintainer information

Rob Bradford (3):
      build: Remove spurious entry from libchamplain_include_HEADERS
      build: Add memphis-1.0 to .pc file requirements
      view: Remove the need to explicitly set the size on the actor

Simon Wenner (7):
      Migrate to libmemphis version 0.2
      Fix a typo in a comment
      update m4/gtk-doc.m4
      Bugfix: GtkChamplain-0.5.gir has to depend on Champlain-0.5 and not 0.4
      launcher: remove redundant semicolon
      Add launcher.js: A champlain javascript demo
      Require Memphis 0.2.1

Victor Godoy Poluceno (9):
      Ship pychamplaingtk-base.defs
      Use memphis .defs in codegen
      Update required memphis version to 0.2
      Just include pychamplaingtk-base.defs
      Update .defs
      Add new boxed type ChamplainBoundingBox
      Use memphis.h include and add ChamplainBoundingBox sets
      Add support to virtual methods by using defsgen.py.
      Add new file pychamplain-gtk-base.defs



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]