[banshee] Created tag 1.5.5
- From: Gabriel Burt <gburt src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [banshee] Created tag 1.5.5
- Date: Thu, 11 Mar 2010 06:14:59 +0000 (UTC)
The unsigned tag '1.5.5' was created.
Tagger: Gabriel Burt <gabriel burt gmail com>
Date: Wed Mar 10 22:15:00 2010 -0800
1.5.5 stable release
Changes since the last tag '1.5.4':
Aaron Bockover (63):
[Grid] Added DataViewLayoutStyle.cs to build
Merge branch 'master' into grid
[Grid] First import of the new grid code
Fixed some grid rendering math bugs
Fixed vadjustment upper calculation for grid mode
Implemented interaction for grid mode
Restored GetRowAtY but marked obsolete
Merge branch 'master' into grid
Started a new namespace containing simple glyph renderers
[ArtworkRenderer] make up artwork if no image specified
[BansheeLineLogo] Simplified math and path nodes
Polished the line logo and artwork background rendering
Merged master into grid
Merge branch 'master' into grid
Mostly done with new unknown artwork rendering
Merge branch 'master' into grid
Merge branch 'master' into grid
[ListView] New implementation of child measuring
[ListView] Start to support text in grid layout
[ColumnCellAlbum] First phase of big refactoring
Merge branch 'master' into grid
[ColumnCellAlbum] begin implementing interaction
[grid] Started refactoring grid into proper layout
Merge branch 'master' into grid
[grid] Utility methods for finding layout children
[grid] set the child virtual allocation on grid
[grid] implemented most of the interaction code
[grid] have cairo fun and render mouse overlay
[grid] fix small comparison bug on ColumnCellAlbum
[csproj] project update from monodevelop
[grid] invalidate last icell on adjustment change
Merge branch 'master' into grid
[grid] fix virtual size calculation when no rows/cols
[DllMapVerifier] allow ignoring unmapped P/Invokes
[DllMapVerifier] willfully unmapped flexibility
[DllMapVerifier] fixed rogue newline output
[CairoDamageDebugger] extension method to show damage
[grid] massively improve rendering performance
[build] add missing CairoDamageDebugger to build
[grid] Added QueueDirtyRegion methods to wrap QueueDraw
[DataView] inching closer to world domination
[DataView] Support child-level invalidation
[GtkBaseClient] support enabling update debugging
[Actor] add StepDelta and StepDeltaPercent properties
[DataViewChildAlbum] fade in/out on mouse in/out
[DataViewChild] Allow relative invalidations
[DataView] implement geo primitives, more canvas logic
[bundle] fix ige-mac-integration detection
[bundle] fix typo in fontconfig package
[darwin] add first-run magic file to bundle skel
[darwin] obsolete --enable-osx, auto-detect darwin
[darwin] package Monobjc as an experiment
[bockbuild] add pushd/popd support
[darwin] add the missing Monobjc Makefile
Merged master branch into grid
[grid] don't render unbound allocated children
[grid] call InvalidateVirtualSize on Allocate
[grid] fix VirtualSize computation
Fix up csproj files from master
[build] enable podcast on bootstrap configure
[grid] Keep the old ColumnCellAlbum around
[grid] allow BANSHEE_DISABLE_GRID on AlbumListView
Merge branch 'grid'
Alan McGovern (1):
[Hyena] Make CryptoUtil.Md5Encode thread-safe
Alex Launi (1):
[PlayQueue] Fix items count, size and duration
Alexander Kojevnikov (24):
Undo the metadata version bump in commit e7969e5
[BansheeQuery] Fix an exception (bgo#611128)
[Halie] Relative values for --set-volume (bgo#610981)
[EqualizerSetting] Use InvariantCulture for float values (bgo#611393)
[configure.ac] 1.5.5 is 1.6 RC1
Update translators.xml
[YouTube] Add project to the solution
[YouTube] Fix project references
[YouTube] Thread-safe UI update
[Dap.MassStorage] Add Google Nexus One image (lp#532182)
[PlaybackControllerService] Clear the redo stack on shuffle mode change
[Audiobook] Custom source icons (bgo#611857)
[build] Add run-muinshee target
[Muinshee] Disable Auto-DJ (bgo#595749)
[Muinshee] Hide previous songs
[Muinshee] Allow to reorder the queue (bgo#601615)
Update translators.xml
Update translators.xml
[YouTube] Disable extension by default
Merge branch 'youtube'
[build] Build YouTube extension by default
[LibraryWatcher] Fix an exception (bgo#612361)
[LibraryWatcher] Clear the queue when disposing
Update NEWS with gdata-sharp* dependencies
Andrej ŽnidarÅ¡iÄ? (2):
Updated Slovenian translation
Updated Slovenian translation
Andrés G. Aragoneses (3):
[Dap] Warn the user if sync deletes more than 10 files (bgo#504492)
[Hyena.Query] Fix file location queries (bgo#612152)
[TrackActions] Reserve a string for bgo#611923
Benjamin Valero Espinosa (1):
Updated Spanish translation
Bertrand Lorentz (8):
Fix .gitattributes for Windows
[RssParser] Accept feeds with empty title
Update POTFILES.in
[build] Fix make distcheck
[PlayerEngine] Fix a few typos in log messages
Update contributors for 1.5.5
Improve some wording in NEWS
[YouTubePane] Make the pane a ScrolledWindow
Bruno Brouard (2):
Updated French translation
Updated French translation
Christian Hergert (1):
[X11NotificationAreaBox] Make the area transparent (bgo#588255)
Christopher James Halse Rogers (69):
[Banshee.MediaEngine] Add PlayerEvent.RequestNextTrack
[Banshee.GStreamer] Fire a RequestNextTrack event on EOS
[Banshee.PlaybackControllerService] Factor a CalcNextTrack function out of Next() and Previous()
[Banshee.PlaybackControllerService] Listen for RequestNextTrack messages, and treat them like EoS.
Add userRequested boolean parameter to IBasicPlaybackController.Next, and update all implementors
[Banshee.PlayerEngineService] Split out SwitchToEngine from FindSupportingEngine. This will be needed for gapless & crossfading, because FindSupportingEngine will be called while the engine is playing
[Banshee.PlayerEngine,PlayerEngineService] Implement SetNextTrack
[Banshee.PlaybackControllerService] Use player_engine.SetNextTrack when userRequested is false
Move responsibility for calling IncrementLastPlayed at end of track from PlayerEngineService.OpenCheck to PlaybackControllerService.
[Banshee.GStreamer] Fire EoS before RequestNextTrack. This is important because EoS triggers IncrementLastPlayed(), and the shuffle-by modes require last-played to be set. Without this, shuffle-by modes play each track twice
[libbanshee] Explicitly set audiosink's buffer-length This is useful for gapless - it gives more time to handle the about-to-finish callback
[libbanshee,Banshee.GStreamer] Implement gapless playback with playbin2
[Banshee.PlayQueue] Only RemovePlayingTrack() on Next when this was triggered by the user. We handle the 'remove when track finishes' case in the EndOfStream handler
[Banshee.PlayQueue] Handle userRequested=False in Next(). This makes gapless playback from the play queue work
[Banshee.Lastfm] Correctly handle userRequested=False in Next ()
[Banshee.InternetRadio] (Badly) Handle userRequested=False in Next(). It should be possible to handle this properly, but requires crawling a fairly deep callstack.
[Banshee.GStreamer] Update CurrentTrack.LastPlayed before firing RequestNextTrack. This is needed to make Shuffle-by-* modes work with gapless, where we need to request the next track before the current track has finished (and had its playcount, lastplayed, etc updated).
Merge in gapless work. Required small updates for changes in Banshee.PlayQueue
[Banshee.PlayQueue] PlayQueue.Next (): Always call SetNextTrack if called with userRequested == false, as this means Next() has been called in response to a RequestNextTrack signal
[libbanshee] Fix some comments
[Banshee.PlayQueue] Fix build. PlaybackController doesn't have SetNextTrack; PlayerEngine does
[libbanshee] Remove unused 'audiosink' variable in pipeline setup
[Gapless] Fix typo: PlayerEvent.RequestNexttrack -> RequestNextTrack
[Banshee.GStreamer] Convert /* comments to // comments
[Banshee.GStreamer] Fix DllImport: libbanshee->libbanshee.dll (for Windows compatibility)
[Banshee.GStreamer] Rename GaplessEnabled to gapless_enabled, as it's a field
[libbanshee]Fix video playback with playbin2
Merge in changes from trunk
[Banshee.GStreamer] Fix toggling of gapless preferences.
[Banshee.GStreamer] Make translators happier with gapless preference string.
Fix player_engine.SetNextTrack(null). Use this to disable the next-track-starting callback, because there won't be a next track
[Banshee.GStreamer] Fix 'player acts as if repeat all' is on problem. Do this by not raising RequestNextTrack in OnEos, and assume that if the PlaybackController didn't have a next track when about-to-finish was called it still doesn't have a next track
[libbanshee] Rename player->timeout_id to player->next_track_starting_timer_id to make it more obvious what it does
[Banshee.GStreamer] Remove 'EXPERIMENTAL' tag from gapless preference, & enable by default
[Banshee.MediaEngine] Factor common code out of PlayerEngineService.SetNextTrack({SafeUri, TrackInfo})
Merge gapless work to trunk.
Strip trailing whitespace again
[libbanshee] Only pass playbin's state-changed messages to managed code
Merge remote branch 'gitorious/master' into gapless-ng
Revert "[libbanshee]Fix video playback with playbin2"
[libbanshee] No longer explicitly set audiosink buffer length.
[libbanshee] Use playbin2's stream-changed message.
[Banshee.GStreamer] Don't send null uris to bp_set_next_track
Make gapless playback a build-time option.
[Banshee.MediaEngine] Handle SetNextTrack (null) correctly.
[libbanshee] Fix ReplayGain support.
[libbanshee] Move _bp_pipeline_rebuild to banshe-player-replaygain.c
[libbanshee] Make ReplayGain more error-resilient.
[libbanshee] Fix coding style issues
[libbanshee] Print scaled volume when ReplayGain values change
[libbanshee] Re-add ReplayGain history fallback
[libbanshee] Simplify conditional
[libbanshee] Fix enable/disable of ReplayGain while playing.
[libbanshee] Fix warning about disposing rgvolume.
[libbanshee] Coding style fixes
[libbanshee] Handle missing rgvolume element for ReplayGain.
[Banshee.GStreamer] Handle slow RequestNextTrack responses better.
[libbanshee] Add debug message for about-to-finish handler
[Banshee.NowPlaying] Add missing null check.
[Banshee.Metadata] Delay writing metadata for 2 seconds.
Merge branch 'master' into gapless-ng
[Banshee.PlaybackController] Update for gapless interface changes.
[Gapless] Work around BGO #602437
[libbanshee] Use playbin2 in all builds
Consolidate multi-line debug messages
[libbanshee] Whitespace fixes
[libbanshee, Banshee.GStreamer] Remove #ifdef's from managed code.
[Banshee.GStreamer] Drop EXPERIMENTAL from gapless option description
Merge branch 'gapless-ng'
Fernando Casanova (1):
[SafeUri] Fix g_filename_to_uri usage on Windows
Gabriel Burt (55):
[grid] Fix keyboard scrolling/interaction
Merge branch 'master' into grid
[extras/metrics] Tweaks
[extras/metrics] Add Makefile.am
[Dap.MassStorage] Add MaemoDevice to csproj
[extras/metrics] Better analysis
[PreferencesDialog] Fix jumping to a source's prefs
[Banshee.Configuration] Wrap Get in try/catch
[Banshee.Metrics] Post data only every 48 hours
[extras/metrics] Better analysis
Update MAINTAINERS and banshee.doap
Update .gitattributes
Update taglib-sharp refs in .csproj files
Add ref to Gio# in Banshee.Gio.csproj
More .csproj references fixing
Improve search responsiveness on large libraries
Allow choosing non-local library locations supported
Change slow-query thresholds to 6k/12k items
Update to build on Windows with MonoDevelop 2.2.1
MonoDevelop on Linux's take on the .csproj refs
Remove Banshee.Gio from Windows build
[Banshee.NotificationArea] Reconcile build setups
[Banshee.GStreamer] Define WIN32 in .csproj
[Shuffler] Add table/method to record discards
[Shuffler] Add bulk RecordShuffles/Discards methods
[PlayQueue] Record manually added/discarded songs
Disable keybindings for IDisableKeybindings widgets
[configure.ac] Bump to 1.5.5 for upcoming release
[YouTube] Dispose HttpWebResponse and some streams
[YouTube] Set videos' album as YouTube
Update Aaron's e-mail in MAINTAINERS
Revert "Update Aaron's e-mail in MAINTAINERS"
Revert "[X11NotificationAreaBox] Make the area transparent (bgo#588255)"
[Banshee.Metrics] Do as little as possible on startup
[PlayQueue] Fix bug with initializing Actions state
HIGify ConfirmShutdownDialog (bgo#611985)
Disable CheckForOverflowUnderflow in many .csproj
[Hyena.Data.Sqlite] Make some error msgs more useful
[Shuffler] record selects in addition to discards
Don't show manual-sort hint if drop not in ListView
[build] Tweak how YouTube is built/status is displayed
[YouTube] Add year to addin copyright assertion
[Migo] Log the offending URL in RssParser
Update NEWS for 1.5.5
[MediaEngine] Fix up the error handling
[Banshee.GStreamer] Workaround sticky playback
[Hyena.Gui] Fix infinite recursion bug in ScrollTo
[Banshee.GStreamer] Fix initial volume setting
[Hyena.Gui] Fix ListView grid interactions
[PlaybackController] Fix repeating same song
Update NEWS
[Hyena.Gui] Add ItemsInView property to ListView
Update AUTHORS
[Podcasts] Fix issue with PodcastFeedView rendering
Update NEWS and banshee.doap
Ján Sokoly (1):
[build] *.csproj fixes for building on windows
Kevin Duffus (1):
Add YouTube extension (bgo#576666)
Laurent Coudeur (1):
Updated French translation
Marek Ä?ernocký (3):
Update Czech translation
Update Czech translation
Update Czech translation
Mario Blättermann (2):
Updated German translation
Updated German translation
MiloÅ¡ PopoviÄ? (1):
Updated Serbian translations
Petr Kovar (1):
Update Czech translation by Marek Cernocky
Ruben Vermeersch (1):
Remove unused file.
Sandy Armstrong (1):
Merge branch 'master' into grid
Travis Reitter (1):
[TrackInfo] Don't include Duration in MetadataHash
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]