[gnumeric] change misleading function name



commit b41e20ed594cac0c8f67930d10c9d4db7bf598a4
Author: Andreas J Guelzow <aguelzow pyrshep ca>
Date:   Thu Jul 29 12:15:58 2010 -0600

    change misleading function name
    
    2010-07-29  Andreas J. Guelzow <aguelzow pyrshep ca>
    
    	* src/commands.c (cmd_reorganize_sheets_delete_cmp_f): rename
    	  to cmd_tabulate_cmp_f and change caller (which is cmd_tabulate_undo)

 ChangeLog      |    5 +++++
 src/commands.c |    4 ++--
 2 files changed, 7 insertions(+), 2 deletions(-)
---
diff --git a/ChangeLog b/ChangeLog
index e6272e2..3cc6bf4 100644
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,8 @@
+2010-07-29  Andreas J. Guelzow <aguelzow pyrshep ca>
+
+	* src/commands.c (cmd_reorganize_sheets_delete_cmp_f): rename
+	  to cmd_tabulate_cmp_f and change caller (which is cmd_tabulate_undo)
+
 2010-07-28  Morten Welinder  <terra gnome org>
 
 	* src/preview-grid-impl.h (_PreviewGrid): Get rid of unused GdkGC
diff --git a/src/commands.c b/src/commands.c
index 2e2b935..b776b39 100644
--- a/src/commands.c
+++ b/src/commands.c
@@ -6618,7 +6618,7 @@ typedef struct {
 MAKE_GNM_COMMAND (CmdTabulate, cmd_tabulate, NULL)
 
 static gint
-cmd_reorganize_sheets_delete_cmp_f (gconstpointer a,
+cmd_tabulate_cmp_f (gconstpointer a,
 				    gconstpointer b)
 {
 	guint const a_val = GPOINTER_TO_INT (a);
@@ -6639,7 +6639,7 @@ cmd_tabulate_undo (GnmCommand *cmd, WorkbookControl *wbc)
 	gboolean res = TRUE;
 
 	me->sheet_idx  = g_slist_sort (me->sheet_idx,
-				       cmd_reorganize_sheets_delete_cmp_f);
+				       cmd_tabulate_cmp_f);
 
 	for (l = me->sheet_idx; l != NULL; l = l->next) {
 		int i = GPOINTER_TO_INT (l->data);



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]