[rygel] Created tag RYGEL_0_5_0



The signed tag 'RYGEL_0_5_0' was created.

Tagger: Zeeshan Ali (Khattak) <zeeshanak gnome org>
Date: Tue Feb 23 18:33:15 2010 +0200

    Release 0.5.0

Changes since the last tag 'RYGEL_0_4_6':

Andreas Henriksson (1):
      core: Fix desktop file

Jens Georg (20):
      core: Modify URI generation scheme
      core: Move uri generating and parsing to own class
      core: Minor formatting fix
      core: Fix uri creation and parsing
      core: encode itemID base64
      core: Limit search slice to result size
      core: Rewrite SearchCriteriaParser
      media-db: Implement search on MediaDBContainer
      media-db: No need to reparent
      media-db: Return empty result on unknown criteria
      media-db: Rename get_children_with_filter
      media-db: Refactor search translator
      media-db: Use correct SQL function for "!="
      media-db: Leverage SQL to update meta-data
      media-export: add curstom object factory
      media-export: Implement MediaContainer.add_item()
      media-export: Make harvester cancellable
      media-export: Message & signal if harvesting not needed
      media-export: Don't modify DB if harvester was cancelled
      media-export: Cancel harvester before starting new one

Philip Withnall (1):
      core: A few fixes to satisfy latest valac (0.7.10)

Yakup Akbay (1):
      Fix typo in GetCurrentConnectionInfo action response.

Zeeshan Ali (Khattak) (165):
      tracker: Initial port to 0.7 APIs
      tracker: Separate class for list of triplets
      tracker: Cloneable TrackerQueryTriplet*
      tracker: TrackerQuery.from_template -> clone
      tracker: Pass triplets' clone to child container
      tracker: Avoid copying of triplets when possible
      tracker: Set title in base TrackerItem class
      tracker: Implement factories rather than items
      tracker: Item factory should know it's category
      tracker: Container classes deal with item factories
      tracker: 'upnp_class' now an item factory field
      tracker: Get rid of two redundant methods
      tracker: Only ask for relavent metadata
      tracker: Privatize ItemFactory.seconds_to_iso8601()
      tracker: Tracker now deals in URIs not paths
      tracker: No need to convert dates to ISO8601 anymore
      tracker: Sort query results by "fileLastModified"
      tracker: Rename TrackerKeywords to TrackerTags
      tracker: Move TrackerQueryTriplet* to separate files
      tracker: Get rid of SearchContainer().filter
      tracker: Query executes itself
      tracker: Special hierarchy for Music
      tracker: Correct search (for @id) logic
      tracker: Use term "picture" rather than "image"
      tracker: Move 'Tags' container into Pictures
      tracker: Special container class for Videos
      tracker: Add 'Tags' hierarchy under Music
      tracker: Tags is not specific to Photos any more
      Revert "tracker: Get rid of SearchContainer().filter"
      tracker: Correct filter syntax
      tracker: Means to create title from value
      tracker: Use filters to make search query specific
      tracker: Means to create filter from variable & value
      tracker: Means to create ID from value
      tracker: Make sure ID's of children are unique
      tracker: Provide 'Years' hierarchy
      tracker: Provide "All" container for each category
      core: Rename an HTTPSeek method
      core: More power to HTTPSeek
      core: Micro coding style fix
      core: HTTPSeek sets all related headers
      core: HTTPRequest keeps only 1 instance of HTTPSeek
      core: Always seek in case of byte seekable media
      core: Special seek classes for each format
      core: Move seeking decision to Seek classes
      core: HTTPRequest.request_handler now public
      core: Correct logic for decision to seek or not
      core: Rename HTTPRequest.request_handler to handler
      core: Rename a local variable for clarity
      core: No need for HTTPSeek.format anymore
      core: Remove some uneeded checks
      core: Duration needs conversion to nano-seconds
      core: Always time-seek if not byte-seeking
      core: Use printf for creating TimeSeekRange string
      tracker: Correct a typo
      tracker: Prefer ArrayList over vala arrays
      tracker: Remove unneeded 'using' statements
      tracker: Item factory provides key chains, not keys
      tracker: Correct keychain for album and artist
      tracker: Avoid duplicate triplets
      tracker: Allow triplets to be chainable
      tracker: Simplified handling of nested properties
      tracker: No need to create keychains on demand
      core: Add SimpleContainer.clear()
      tracker: Bind Resources.Class D-Bus interface
      tracker: Update containers on changes to subjects
      tracker: Minor refactoring of SearchContainer
      tracker: Act on new config options
      build: Require latest vala release (0.7.10)
      core,ui,plugins: Vala debugging symbols
      core: Rename ItemUri to HTTPItemURI
      core: Clean-up & indent recently added code
      core: Throw error on invalid URI
      core: Fix a spelling mistake in error message
      core,ui,plugins: Work-around for automake bug
      build: Correct linker argument order
      core: Fix condition for partial content transfer
      Enable check for Vala if any stamp file is absent
      core: HTTPServer keeps a list of active requests
      core: HTTPRequest now uses it's own Cancellable
      core: Handle message abortion in HTTPServer
      core: Indicate support for connection stalling
      core: Live response is always sender-paced
      core: Explicitly set DLNAv1.5 flag
      test: Coding style fixes
      test: Remove redundant 'using' statements
      test: Micro simplification of code
      core: Push data directly from gst thread
      core: Better name for continuation field
      core: Synchronous streaming of LiveResponse
      core: Move some code from LiveResponse to GstUtils
      core: Adapt to new Base64.decode() VAPI
      Revert "core: Synchronous streaming of LiveResponse"
      Revert "core: Push data directly from gst thread"
      core: Correctly handle boolean commandline options
      core: Correct condition for byte-seeking
      core: No need for 'construct'
      core: SearchCriteriaSymbol should be private
      core: Major refactoring of SearchCriteriaParser
      core: Rename SearchCriteriaParser parsing methods
      core: Add string property to get current parser context
      core: Better error message from SearchCriteriaParser
      core: Remove unneeded newline
      core: Clean-up MediaDBContainer code
      core: Fix cancellation of SeekableResponse
      core: Micro coding-style fix
      core: Simplify HTTPRequest.handle_item_request()
      core: Restart application on SIGHUP
      core: A bunch of coding-style fixes
      core,mediathek: Adapt to new libxml VAPI
      tracker: Category containers provide URIs
      core: Containers without URIs are 'restricted'
      core: No need to pass around the protocol string
      core: Micro indentation fix
      core: HTTPItemURI gets HTTPServer reference
      core: HTTItemURI creates the whole URI
      core: Use 'this' keyword for more readable code
      core: Provide 'importUri' for all items
      core: Support for 'place holder' items
      core: Add MediaContainer.get_writable()
      core: Implement 'CreateObject' action of CDS
      core: Micro coding-style fix
      core: Move get_writable method to MediaObject
      core: Separate class for HTTP GET request
      core: Handle HTTP Post requests
      core: Handle case of no ID during item URI parsing
      core: Minor refactor
      core: Modify error message to avoid potential crash
      core: Don't forget to put URI into new MediaItem
      tracker: Base class for category containers
      tracker: Refined class hierarchy for Tracker queries
      tracker: ItemFactory provides 'upload_dir'
      tracker: CategoryContainer keeps relavent ItemFactory
      tracker: Result of query is kept in the instance
      tracker: Implement MediaContainer.add_item()
      media-export: Initialize fields in constructor only
      media-export: Remove redundant null check
      media-export: Console message when harvesting is done
      tracker: Adapt to Tracker API changes
      tracker: Use correct Sparql query for insertion
      tracker: Chain-up of async methods now possible
      tracker: Support for search by URI
      tracker: Bind Tracker1.Miner.IgnoreNextUpdate method
      tracker: Keep "All" container as the first one in the list
      tracker: Follow recommended way for item creation
      tracker: Refactor ItemCreation.run()
      core: Implement ImportResource action of CDS
      core: ContentDirectory keeps a list of active imports
      core: Provide "TransferIDs" state variable
      core: Minor refactoring of ContentDirectory class
      core: Use enum to represent transfer status
      core: Make transfer statistics public
      core: Implement GetTransferProgress action of CDS
      core: Don't forget to signal completion in case of error
      core: ImportResource keeps its own Cancellable object
      core: Implement StopTransferResource action of CDS
      core: Refactor two new methods of ContentDirectory
      tracker: CategoryContainer creates "All" container
      tracker: Seperate class of "All" container
      tracker: Move add_item() to CategoryAllContainer
      tracker: Add method for child ID creation from URN
      tracker: No need to search for newly created item
      tracker: Tags & Years create their own IDs
      tracker: Descriptive IDs for containers
      core: Release announcement for 0.5.0



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]