[gtk+] API: Rename GdkWindowClass to GdkWindowWindowClass
- From: Benjamin Otte <otte src gnome org>
- To: commits-list gnome org
- Cc:
- Subject: [gtk+] API: Rename GdkWindowClass to GdkWindowWindowClass
- Date: Fri, 3 Dec 2010 18:19:42 +0000 (UTC)
commit d916398dd2bc05bbdf50939b2583ea2e3a3cec97
Author: Benjamin Otte <otte redhat com>
Date: Fri Dec 3 16:10:46 2010 +0100
API: Rename GdkWindowClass to GdkWindowWindowClass
We argued replacing GdkWindowClass with a input_only boolean, but this
is not doable in an API-stable way, so I decided against it.
docs/reference/gdk/gdk3-sections.txt | 2 +-
gdk/gdkwindow.h | 6 +++---
2 files changed, 4 insertions(+), 4 deletions(-)
---
diff --git a/docs/reference/gdk/gdk3-sections.txt b/docs/reference/gdk/gdk3-sections.txt
index 7b58029..e1c5bc5 100644
--- a/docs/reference/gdk/gdk3-sections.txt
+++ b/docs/reference/gdk/gdk3-sections.txt
@@ -326,7 +326,7 @@ gdk_visual_get_type
<FILE>windows</FILE>
GdkWindow
GdkWindowType
-GdkWindowClass
+GdkWindowWindowClass
GdkWindowHints
GdkGeometry
GdkGravity
diff --git a/gdk/gdkwindow.h b/gdk/gdkwindow.h
index 55726ff..b25b5f9 100644
--- a/gdk/gdkwindow.h
+++ b/gdk/gdkwindow.h
@@ -42,7 +42,7 @@ typedef struct _GdkPointerHooks GdkPointerHooks;
typedef struct _GdkWindowRedirect GdkWindowRedirect;
/**
- * GdkWindowClass:
+ * GdkWindowWindowClass:
* @GDK_INPUT_OUTPUT: window for graphics and events
* @GDK_INPUT_ONLY: window for events only
*
@@ -56,7 +56,7 @@ typedef enum
{
GDK_INPUT_OUTPUT,
GDK_INPUT_ONLY
-} GdkWindowClass;
+} GdkWindowWindowClass;
/**
* GdkWindowType:
@@ -345,7 +345,7 @@ struct _GdkWindowAttr
gint x, y;
gint width;
gint height;
- GdkWindowClass wclass;
+ GdkWindowWindowClass wclass;
GdkVisual *visual;
GdkWindowType window_type;
GdkCursor *cursor;
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]