[gtk+] (65 commits) Created branch rendering-cleanup



The branch 'rendering-cleanup' was created.

Summary of new commits:

  48ed881... API: x11: gdk_drawable_get_xid => gdk_window_get_xid
  2d402c2... API: x11: Change GDK_WINDOW_XDISPLAY() macro
  92f7759... API: x11: Remove gdk_x11_window_get_drawable_impl()
  3a05742... im-xim: Use window macros instead of drawable macros
  0df6b94... x11: Use window macros in test code
  cc4e112... API: Remove gdk_x11_drawable_get_xdisplay()
  ca10932... x11: Use window macros instead of drawable macros
  ab63ece... API: x11: Remove GDK_DRAWABLE_XID and GDK_DRAWABLE_XDISPLAY
  6814829... x11: Change GDK_WINDOW_SCREEN macro
  9620ee8... x11: Get display from window, not from impl-drawable's scre
  7065a50... x11: Get display from window, not from impl-drawable's scre
  3d051ab... x11: Remove screen member from GdkDrawableImplX11
  0a3b5f0... x11: Use GDK_WINDOW_XID() instead of writing it out
  f882fac... x11: Move xid member from GdkDrawableImplX11 to GdkWindowIm
  d462ada... x11: Move cairo_surface and wrapper members to GdkWindowImp
  964024e... x11: _gdk_x11_drawable_update_size() => _gdk_x11_window_upd
  56135a7... x11: Remove GdkDrawableImplX11
  98edead... win32: Remove some unused defines
  537e77d... API: Remove gdk_cairo_reset_clip()
  f8ad5d8... API: Make gdk_cairo_create() take a GdkWindow
  a10aab2... API: gdk_drawable_get_clip_region() => gdk_window_get_clip_
  8a4dc6c... API: gdk_drawable_get_visible_region => gdk_window_get_visi
  e121c99... x11: Make wrapper member a GdkDrawable
  c3d38fc... API: gdk: Don't track outstanding surfaces
  aa3c495... API: Remove GDK_WINDOW_XWINDOW() macro
  484a177... gdk: Make _gdk_window_ref_cairo_surface() protected and use
  3fa293f... gdk: Pass Drawable as argument
  b851ca4... gail: Avoid needless calls to GdkDrawable
  ab114f8... gtk: Avoid GdkDrawable usage, including needless casts
  8226bbb... gdk: Use GdkDrawable for impl pointers
  1cd6da1... API: Decouple GdkWindow from GdkDrawable
  3796109... textbuffer: Remove check for GdkDrawable
  754b273... API: Remove gdkdrawable.h from public headers
  36f9011... gdk: Remove unused medialib code
  bd8a18c... gdk: Make GdkWindowImpl a class, not an interface
  bfb9c40... gdk: Rename GdkWindowObject to GdkWindow
  4a21322... x11: Fix in_rectangle computation
  dfd482b... gdk: Remove _gdk_window_impl_get_type() function
  12c0893... gdk: Remove GdkDrawable->create_cairo_surface vfunc
  714c7fb... x11: Remove outdated variable definition
  39feaf3... gdk: Remove _gdk_drawable_ref_cairo_surface()
  cde19a2... gdk: Move ref_cairo_surface from GdkDrawable to GdkWindowIm
  13aff43... x11: Remove duplicate definition of GDK_WINDOW_XID
  6274b73... x11: Remove unused GDK_DRAWABLE_XROOTWIN macro
  aa8c138... API: GdkWindow no longer is a GdkDrawable
  0126df7... gdk: Pass the GdkWindow to resize_cairo_surface vfunc
  29faad6... cellrenderer: Fix docs to say cairo_t instead of GdkDrawabl
  6a089fd... tests: Remove disabled testtext example
  48ac4a4... docs: Remove overrides for types that don't exist anymore
  3174eaa... docs: Replace mentions of drawable with window in migration
  e84ad65... gdk: Make GdkWindow->impl a GdkWindowImpl
  9bbeb89... API: Remove GdkNoExposeEvent
  75d2b2c... gdk: Make GdkWindowImpl inherit from GObject
  da0a11e... gdk: Remove remaining includes of gdkdrawable.h
  aa418e2... gdk: Remove GdkDrawable
  a79d41e... gdk: Make get_shape and get_input_shape vfuncs
  5e39013... gdk: Move window beeps into GdkWindowImpl
  e789a9f... gdk: Remove GDK_PANGO_UNITS_OVERFLOWS() from internal heade
  da460c5... gtk: Don't include private GDK headers
  11bc59c... gdk: Remove useless macros from gdkprivate.h
  abdd992... gtk: Fix typos in comment
  7f57fdc... x11: Don't include gdkprivate.h in gdkx.h
  f4fdcd4... gdk: Replace direct calls of _gdk_event_func with _gdk_even
  ecfc3dc... label: Clarify docs for gtk_label_get_layout()
  7fe1ee5... gdk: Clean up Cairo code



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]