[glom: 6/6] Merge branch 'feature_choices_show_all'



commit 353a8fd50bd51517a13bdf874ec2f4573f584335
Merge: 1baf532 c9e654f
Author: Murray Cumming <murrayc murrayc com>
Date:   Fri Aug 6 17:23:43 2010 +0200

    Merge branch 'feature_choices_show_all'

 ChangeLog                                          |   70 +++++-
 glom/application.cc                                |    3 +
 glom/base_db.cc                                    |    2 +-
 .../data_structure/layout/fieldformatting.cc       |   36 +++-
 .../data_structure/layout/fieldformatting.h        |   13 +-
 glom/libglom/utils.cc                              |  164 +++----------
 glom/libglom/utils.h                               |   11 +-
 glom/mode_data/datawidget/combo.cc                 |   14 +-
 glom/mode_data/datawidget/combo.h                  |    9 +-
 glom/mode_data/datawidget/combochoices.cc          |   79 +++---
 glom/mode_data/datawidget/combochoices.h           |   16 +-
 glom/mode_data/datawidget/comboentry.cc            |   24 +-
 glom/mode_data/datawidget/comboentry.h             |   15 +-
 glom/mode_data/datawidget/datawidget.cc            |   30 ++--
 glom/mode_data/flowtablewithfields.cc              |    2 +-
 glom/utility_widgets/db_adddel/db_adddel.cc        |  261 ++++++++++----------
 glom/utility_widgets/db_adddel/db_adddel.h         |   71 +++---
 17 files changed, 414 insertions(+), 406 deletions(-)
---
diff --cc ChangeLog
index d04f20d,a3142eb..857587c
--- a/ChangeLog
+++ b/ChangeLog
@@@ -1,13 -1,59 +1,69 @@@
+ 2010-08-06  Murray Cumming  <murrayc murrayc-desktop>
+ 
+ 	Formatting: Add get_choices_related() overload to reduce copy/pasted code.
+ 
+ 	* glom/libglom/data_structure/layout/fieldformatting.[h|cc]:
+   Added a get_choices_related() overload that returns the LayoutItem_Fields
+   instead of just the field names. This reduces the copy/pasted code in the
+   callers, and makes it easier to support related fields in future.
+ 	* glom/libglom/utils.[h|cc]:
+ 	* glom/mode_data/datawidget/combochoices.[h|cc]:
+ 	* glom/utility_widgets/db_adddel/db_adddel.cc: Adapted and made necessary
+   const corrections.
+ 
+ 2010-08-06  Murray Cumming  <murrayc murrayc com>
+ 
+ 	Choices: Fix !show-all lists.
+ 
+ 	* glom/mode_data/datawidget/combochoices.[h|cc]:
+   refresh_data_from_database_with_foreign_key(): Add a document parameter,
+   used to update the cached choices information if necessary.
+ 	* glom/mode_data/flowtablewithfields.cc: set_field_value(): Adapted.
+ 
+ 2010-08-06  Murray Cumming  <murrayc murrayc com>
+ 
+ 	Document loading: Show an error dialog even for unexpected errors.
+ 
+ 	* glom/application.cc: on_document_load(): Don't just fail silently when
+   there is an unexpected error, for instance if the postgres data directory
+   is missing.
+ 
+ 2010-08-06  Murray Cumming  <murrayc murrayc com>
+ 
+ 	Utils::get_choice_values(): Reduce copy/pasted code.
+ 
+ 	* glom/libglom/utils.[h|cc]: build_sql_select_with_key(): Add a sort_clause
+   parameter.
+   get_choice_values(field): Rename this to get_choice_values_all() and change
+   the implementation to just call the other get_choice_values(). Add
+   a Document* parameter so we can do that.
+   get_choice_values(document, field, ...): Sort the list by the first field.
+   This should probably be an option in the developer-mode UI.
+ 	* glom/mode_data/datawidget/combo.h:
+ 	* glom/mode_data/datawidget/combochoices.[h|cc]:
+ 	* glom/mode_data/datawidget/comboentry.h:
+ 	* glom/utility_widgets/db_adddel/db_adddel.cc:
+   get_choice_values(): Adapt to the change, by adding a Document* parameter.
+ 	* glom/base_db.cc: Adapt.
+ 
+ 2010-08-06  Murray Cumming  <murrayc murrayc com>
+ 
+ 	DbAddDel: Avoid some copy/pasting of code to append items to choices cells.
+ 
+ 	* glom/utility_widgets/db_adddel/db_adddel.[h|cc]: Added set_cell_choices(),
+   using it in refresh_cell_choices_data_from_database_with_foreign_key() and
+   construct_specified_columns_cellrenderer().
+ 
 +2010-08-06  David King  <davidk openismus com>
 +
 +	Minor build system cleanup
 +
 +	* configure.ac: Drop unnecessary AC_DISABLE_STATIC. Use AS_IF rather
 +	than shell if...fi. Add a TODO.
 +	* Makefile.am:
 +	* Makefile_tests.am: Take advantage of dependencies to reduce
 +	duplication of linker flags.
 +
  2010-08-06  Murray Cumming  <murrayc murrayc com>
  
  	List: Choices with !show_all: Update the list when the from_field changes.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]