[sysprof] Created tag 1.1.2



The signed tag '1.1.2' was created.

Tagger: Søren Sandmann Pedersen <ssp redhat com>
Date: Sat Sep 26 10:05:52 2009 -0400

    1.1.2 release

Changes since the last tag 'sysprof-1-0-branchpoint':

Bastien Nocera (2):
      more ifdef's to make it work with Red Hat Enterprise Linux 4's 2.6.9-based
      we need at least glib 2.6.0 for the gstdio.h functions

Behdad Esfahbod (1):
      Correct $PWD usage, so make install works from inside module/.

Geoffrey Keating (1):
      Apply patch from binutils to demangle local-source names. Binutils

Kristian Høgsberg (3):
      Dist and install udev rule.
      Remove left over debug print out.
      Remove left over debug print out and add support for multiple clients

M Joonas Pihlaja (1):
      In sysprof-cli.c, stop the collector before trying to create a profile

Matthias Clasen (1):
      Make configure work

Owen Taylor (2):
      Constrain the samples label to only grow wider instead of bouncing around.
      Reorder the tests for CONFIG_X86 and CONFIG_X86_64 since post 2.6.26, they

Paolo Borelli (1):
      small cleanup

Robert Love (1):
      Don't use INTERVAL or SAMPLES_PER_SECOND now that we use

Soeren Sandmann (40):
      If the glade file doesn't exists pop up an alert suggesting running 'make
      New non-GUI version, written by Lorenzo Colitti, with some changes by me.
      Bump version number to 1.1.0
      If the address is 0x01, treat as kernel, regardless of whether we have a
      Update
      Update
      Delete lots of commented-out code.
      Add back these constants, but this time make sure we won't divide by 0 or
      Use APPLICATION_NAME macro
      Add "total" field.
      Update GUI after showing error message.
      Don't compute the total field.
      Use callbacks from stackstash.
      Turn this function into a StackFunction.
      Make these function call back with GLists rather than GSLists.
      Test for !prev instead of !next.
      Add beginning of a screenshot window.
      Add new tree_view_foreach_visible() function.
      Put the vertical splitter at 3/8 * screen_width.
      Add some experimental (and unused) code to look up kernel symbols.
      Remove unused pages_present() function
      Various cleanups
      Update the screenshot window.
      New function. Update screenshot window when rows are expanded and
      Updates
      update
      Resurrect this function.
      Use gulong for addresses. Bug reported by Martin Reddy.
      Remove START_OF_STACK check.
      Initialize retval.
      Only build GUI when the necessary dependencies are found.
      Updates
      Print out sysprof version at module load time.
      Clear screenshot window when start is toggled.
      Handle NULL models.
      Check that the inodes match.
      Do proper error-handling.
      New files containing a simplified and sanitized version of the state
      Updates.
      updates Various formatting fixes.

Soren Sandman (2):
      Switch to a simpler conceptual model. Update to binparser API changes.
      Free the undefined symbol

Soren Sandmann (89):
      Merge stackstash-reorg branch into HEAD
      Don't link sysprof-text to gtk+.
      Add copyright statement.
      updates
      Updates
      Simplify this file a bit, and make it not rely on atomic pointer writes.
      Add a destroy notifier to StackStash
      Make the load_file() idle low priority to avoid weird toolbar flash.
      Add beginning of an ELF parser.
      Really add this file.
      Many cleanups.
      New file, made out of files from libiberty in binutils.
      Read the name out of the file instead of out of the struct.
      New function
      New function
      Make process_lookup_symbol() return a string. Delete
      Comment out debug spew. (elf_parser_lookup_symbol): Add check that address
      Initialize crc to 0xffffffff and invert it before returning.
      Update
      Pass map->bin_file to bin_symbol_get_name.
      Add ref_count and filename (bin_files): Add map from filenames to BinFiles
      Rename elf_sym_get_* to elf_parser_get_sym_* and make these functions take
      Demangle instead of strdup.
      Add new bin_record() functions Implement them.
      Add new struct BinRecord. Comment out functions related to formats. Add
      Update to new API
      Remove old commented out code
      Remove old commented out code Add commented out code accessing entire
      Deal with address offsets. Address lookup is now:
      Support _debuglink recursions.
      Use "SHT_DYNSYM" for ".dynsym".
      Remove now unused load-address heuristic
      Add a cache of the text section.
      New function to support --version option
      Don't include bfd.h
      New function.
      Make this function return a list of immediate callers again.
      Skip nodes that don't have a parent.
      Communicate traces to userspace through shared memory instead of copying.
      Use PAGE_SIZE - 1 instead of 4096.
      Use an array instead of list of maps.
      replace PAGE_SIZE macro with this function.
      Make the pointer array static to improve cache behavior and reduce calls
      Combine processes with identical commandlines here.
      Increase the max number of addresses to 1021, reorganise SysprofMmapArea
      Valgrind:
      New function
      Declare bin_parser_free();
      Use stack_node_new() o (profile_load): Use set_root() instead of
      Use stack allocated variables to avoid taking addresses of bitfields.
      reset the collector after generating the profile.
      Move match to front (add_trace_to_tree): Break as soon as a recursive call
      Use GMappedFile instead g_file_get_contents(). (build_instructions): Pass
      Set inode for vdso to 0.
      Add forgotten put_cpu_var(). Parse in chunks of 65536 to improve locality.
      Updates
      Fix two leaks, both pointed out by Kjartan Maraas
      Make a copy of the vdso bytes to make valgrind a little quieter.
      Remove FIXME.
      Make this function static
      Update screenshot window in an idle handler to deal with the case where
      + * elfparser.c (elf_parser_get_crc32): madvise()
      Update to use new tree view API.
      Work around GTK+ bug 405625.
      Reformat and fix various minor issues.
      Compute the size by simply summing the size of the siblings. They are
      Add support for looking up kernel symbols from /proc/kallsyms
      Call callback with an extra boolean indicating whether the sample read was
      Remove CFLAGS reminiscence of 2.4 support.
      Don't discard weak symbols.
      Fix some spelling errors
      Make this a two-pass algorithm, one pass to add the trace, and one to do
      Use an array instead of a list. Look for vmlinux in the source directory.
      Updates
      updates
      Formatting
      Make heuristic stack scanning more accurate
      Use hash table instead of list.
      Add a memcpy() that uses nontemporal writes. (copy_kernel_stack): Add
      Add commented out code to reject callback.
      Initialize offset to 1. Don't do kernel lookup for unmapped addresses.
      Support for 2.6.24 and newer
      Use kernel builtin tracer instead of copying everything ourselves.
      Call back after collecting all traces.
      Work around GTK+ ABI break.
      Add various constants
      Remove all calls to g_signal_connect() Instead connect all signals here
      Get rid of all calls to glade_xml_get_widget(). (gather_widgets): Instead
      Don't leak kallsyms

Soren Sandmann Pedersen (1):
      Fix bug where the build id name was generated incorrectly.

S�¸ren Sandmann (1):
      Pass the correct pointer.

Søren Sandmann (42):
      Add my name to the copyright statement
      Add --disable-kernel-module option. Patch from Pascal Terjan.
      Add a warning about known bugs in the kernel module in this branch.
      updates
      Fix crash pointed reported by Rudi Chiarito.
      free the profile objects.
      great-sage-equal-to-heaven:~/vertigo/sysprof% head -13 ChangeLog
      A few formatting fixes. Hopefully make it work with x86-64.
      Make the tree tree-shapeed.
      Add backslashes, pointed out by Ralph Siemsen.
      small updates cosmetic updates cosmetic updates
      Remove debug spew.
      Also make offset a gulong (Samuel Mimram)
      updates
      Updates
      Updates
      Remove ancestors pane in favor of radiobuttons in the right pane.
      updates
      updates
      Updates
      Make n_samples per-cpu. Add an atomic variable in_timer_notify and use it
      Some formatting fixes.
      Die immediately if the output file is a directory.
      Add debug spew.
      Look in the correct directory for debug info files. (Tim Rowley)
      Start with "/usr", not "usr". Pointed out by Tim Rowley.
      udpate
      sysprof-icon-32.png Add a 32x32 version (also from Diana) of the icon.
      Don't store the size of the symbol. (elf_parser_lookup_symbol): Look it up
      Update copyright notices
      New function. Only warn once about bad CRC's.
      Return ssize_t instead of int.
      Crude heuristic stack scanning on x86-64.
      x86 merge happened in 2.6.25
      Beginning of a dwarf unwinder.
      Do not fold recursions for symbols starting with "In file".
      Keep a list of elf files for each binary file. In some cases, notably
      Plug leak
      Actually recurse on the debuglink.
      Simplify loop.
      Remove weird comment.
      Update to work with new vm_operations interface from 2.6.23. Patch from

Søren Sandmann Pedersen (118):
      Update TODO
      Update TODO
      Revert accidental commit of stackstash reorganisation
      file helper.h was initially added on branch stackstash-reorg.
      file helper.c was initially added on branch stackstash-reorg.
      file profiler.h was initially added on branch stackstash-reorg.
      file profiler.c was initially added on branch stackstash-reorg.
      tweak configure.ac message
      TODO
      Update TODO
      +2005-11-03  Soren Sandmann  <sandmann redhat com>
      Sun Nov 6 Soeren Sandmann <sandmann redhat com>
      *** empty log message ***
      *** empty log message ***
      file announce-1.0.1 was initially added on branch sysprof-1-0.
      Update TODO
      file announce-1.0.2 was initially added on branch sysprof-1-0.
      Update TODO
      file announce-1.0.3 was initially added on branch sysprof-1-0.
      Update TODO
      Incomplete ChangeLog entry
      Formatting fixes in header files
      Revert accidental commit
      Delete debug spew
      +2006-10-09  Soren Sandmann <sandmann redhat com>
      +2006-10-25 Soren Sandmann <sandmann daimi au dk> + + * process.c
      Incomplete changelog
      file announce-1.0.4 was initially added on branch sysprof-1-0.
      file announce-1.0.5 was initially added on branch sysprof-1-0.
      file announce-1.0.7 was initially added on branch sysprof-1-0.
      file announce-1.0.8 was initially added on branch sysprof-1-0.
      Add new icons
      svn path=/trunk/; revision=351
      include correct header file
      svn path=/trunk/; revision=355
      Add MAINTAINERS
      Update TODO
      Update TODO
      TODO updates
      Add notes about releasing
      Add ChangeLog
      Update TODO
      +2007-11-17  Soren Sandmann <sandmann daimi au dk>
      Update TODO
      Update a comment
      +2008-03-23  Soren Sandmann <sandmann daimi au dk>
      Remove unnecessary show_samples
      Split decode_entry
      Initial build id support
      More build-id work
      Update TODO
      +Mon Jun  2 01:14:17 2008  Søren Sandmann  <sandmann redhat com>
      Update configure banner to the latest version control system.
      Add percent signs; update TODO
      Disregard symbols that are not defined with respect to the text section
      Select the first row in the object view when making the profile
      Don't delete profile when toggling on_profile
      new enter_display_mode() function
      Delete ChangeLog
      Add empty ChangeLog to appease automake
      Give the samples label a minium width of "Samples: 888888"
      Get rid of hack to not fold recursions for "In file" symbols
      TODO
      TODO
      Add percent signs in screenshot window
      Tweak percent sign format
      Merge branch 'master' of git+ssh://git.gnome.org/git/sysprof
      TODO
      Free the sfile formats after freeing the input/output files.
      Reserve space in the samples label for large numbers.
      Delete trailing whitespace
      Rename sysprof-text to sysprof-cli
      Remove unused profile_from_file variable
      Initial port to perf counters
      Use two consecutive mappings of the ring buffer.
      Add forked copies of gtktreestore.[ch] and gtktreedatalist.[ch]
      Lots of gtk->foo renames
      Some more renamings
      Eliminate as many signal emissions as we can from footreestore.c
      Add a cache for TreeDataList allocation
      Use a buffer of 32 pages.
      Add tracker.[ch]
      Create data types
      Add array resizing code
      Add code to append map and process events
      Make StackStash store uint64_ts instead of pointers
      Make stack_stash_add_trace() return a pointer to the trace
      Implement tracker_add_sample()
      Hook up dead period, and only call back after a complete batch of samples
      Fake new_process and new_map events when a tracker is created
      Add events to tracker instead of stash
      Add process and map tracking to tracker
      Add symbol resolution to tracker
      Various debug spew
      More informative errors when symbols can't be found
      Simpler message formatting
      Update TODO
      Don't compile process.[ch] anymore
      Remove last bits of process.[ch]
      Simplify vdso reading in binfile.c
      Move bin file cache to state object
      Destroy state object after use, don't keep bin files in map objects
      TODO
      Make sure parser->symbols is non-NULL after read_table()
      Initial support for fork/exit events
      Remove stash from collector
      Better handling of events without stacktraces
      Avoid mallocs in process_sample()
      TODO, plus a number of other fixes
      TODO
      Read data before stopping collector.
      Update TODO
      Eliminate 'partial' string
      Comment out some debugging spam; update copyright
      Make it distcheck
      Really make it compile on older kernels
      Remove GSEAL macros
      Pre-release version bump



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]