[rygel] Created tag RYGEL_0_3



The signed tag 'RYGEL_0_3' was created.

Tagger: Zeeshan Ali (Khattak) <zeeshanak gnome org>
Date: Sat May 30 21:02:43 2009 +0300

    Release 0.3

Changes since the last tag 'RYGEL_0_2_2':

Jens Georg (39):
      import plugins into branch
      add copyright header
      update copyright
      Add simple gconf configuration
      Fix segfault on folder plugin
      once again, add mms straming protocol
      load children on demand only
      move directorysearch into own file
      add folder media object
      Make folder plugin recursive
      make it work with gvfs (non-local directories)
      Make it work with arbitrary gio sources
      Fix crash if no gconf key; Use XDG dirs then
      fix handling of nonexistant gconf key
      DirectorySearchResult adheres the style guide
      Make FolderContainer adhere style guide
      Make MediaItem adhere style guide
      Make FolderContentDir adhere Styleguide
      Finish style guide cleanup
      add missing file to BUILD_SOURCES
      Fix ASX class for style
      RootContainer -> fix style
      RssContainer -> style
      VideoItem -> style
      Plugin->style
      Move class guessing to factory method
      More style fixes
      Fix more stlye issues
      Update schemafile for Folder and Mediathek
      Add Readme for Mediathek plugin configuration
      Rename gconf key from folder to folders
      Fix schema file
      Use configuration class
      Add get_int_list method to Configuration class
      Fix exception handling
      Fix missing return value
      Simply use basename everywhere
      Remove MediaItem subclass
      Use Configuration class instead of raw gconf

Marc-André Lureau (3):
      Use git-version-gen to generate package version.
      Add a summary after configure
      git-version-gen: generate versions with . instead of -

Rob Taylor (2):
      Change Mediathek plugin headers to LGPL
      Correct license header for cstuff.vapi

Zeeshan Ali (Khattak) (333):
      Post release version bump.
      It's root container if it's parent is 'null'.
      Tell why Search.Query is used instead of Search.GetHitCount.
      Minor indentation fix.
      Use "this" to make it things more explicit and therefore readable.
      Create and report transcode URIs as well.
      MediaItem creates res for itself for a given URI.
      Move get_transcoded_resources() to HTTPServer.
      Separator for HTML query components is '&' rather than '?'.
      HTTPServer.create_http_uri_for_item is now private.
      Put transcoding target mime to http uri rather than a boolean.
      Use vala syntax for concatenating strings.
      Correct creation of transcode resource.
      Don't create transcoding resource for images.
      Add TranscodeSrc.
      Fix build rule for rygel-transcode-src.vala file.
      Mark TranscodeSrc class as internal.
      HTTPServer creates transcoder given the actual src.
      Move get_transoding_src from HTTPServer to HTTPRequest.
      Use TranscodeSrc when request is for transcode uri.
      Correct logic to decide wether to handle as interactive.
      Make source pad of muxer a ghost pad of TranscodeSrc.
      No need to pass caps to Element.get_compatible_pad.
      Link the pads after their parents are in the same bin.
      No need to get encoder from it's pad.
      Use alternative encoders rather than ffmpeg.
      Indentation fix.
      Print request id and if transcoding.
      Place an 'audioconvert' in front of audio encoder.
      Ghost audio encoder's src pad as well.
      Add the pads to the audio bin rather than TransodeSrc.
      Print URI and method for each request on debug console.
      Another indentation fix.
      Set the correct mimetype on transcode URI request.
      Minor optimization.
      Mark transcoded resource as one in DLNA fields.
      Only HTTP proxy res don't get exported if HTTP uri already exist.
      Add HTTP resources to the existing list.
      Rename *resouce_list* to *resources*.
      Rename create_http_uri_for_item to create_uri_for_item.
      Add TranscodeManager.
      TranscodeManager.create_uri_for_item() tells the protocol.
      HTTPRequest keeps a unowned ref to HTTPServer.
      TranscodeManager creates the transcode source for us.
      Don't create transcode resource if not needed.
      Rename TranscodeSrc to MP2TSTranscoder.
      Add MP2Transcoder.
      Provide "audio/mpeg" transcode uri for music items.
      Use MP2Transcoder for "audio/mpeg" transcoding requests.
      Give src pad of audio encoder bin a name.
      Audio encoder can be added to the bin earlier.
      Escape the transcode target string before putting it in the URI.
      Use an mp3 parser.
      Convert MP2Transcoder into a more generic mpeg audio transcoder.
      Clever use of arrays to create appropriate encoder.
      Use enum to identify mpeg audio layers, rather than integer.
      Turn MP3Transcoder.create_audio_encoder 'internal static'.
      Rename MP3Transcoder.create_audio_encoder to create_encoder.
      MP2TSTranscoder uses MP3Transcoder.create_encoder.
      Correct a typo.
      MP3Transcoder.create_encoder can be dictated names for pads.
      Remove now unneeded contsants.
      Don't trust Gst.Element.get_compatible_pad().
      Don't trust get_compatible_pad() in MP3Transcoder either.
      Intersect the caps of the pads to check their compatibility.
      Add colorspace and parser elements to video encoding part of pipeline.
      Prepend a videorate to the video encoder bin.
      No need for mpegvideoparse.
      No need to keep check_pad_compatible static.
      A base class for Transcoder elements.
      Transcoder classes dictate the mimetype and DLNA profile.
      LiveResponse should use EOF encoding rather than CHUNKED.
      Explicitly require and link to libsoup-2.4 >= 2.26.0.
      Put the audioresample before audio encoder, just in case.
      Correct indention of Transcoder classes.
      Generalize gst element creation in base transcoder.
      Use g_content_type_is_a to compare mimetypes.
      Refactor TranscodeManager.add_resources().
      Add transcoder for "audio/L16" (LPCM in DLNA terms).
      Refactor TranscodeManager.add_resources a bit more.
      Replace add_resource with create_resource.
      Add more metadata to "audio/L16" transcoding resource.
      Just use Pad.can_link to check pad compatibility.
      Put the encoders in the bin at startup.
      No need for encoders to sync state with parent anymore.
      List the L16 resource before the MP3 one.
      Transcoder classes themselves add their resource.
      Rename add_resource to add_resources.
      More information hiding by Transcoder classes.
      Scale the video to High Definition.
      Report the (hopefully) correct DLNA profile for mpeg 2 ts.
      Fix the typo and actually require libsoup >= 2.26.0.
      Fix a typo that messed-up the Music titles.
      Export duration for music and video items from Tracker.
      Bump gstreamer requirement to latest git mainline (0.10.22.1).
      Separate Transcoder and TranscoderBin classes.
      'mime_type' and 'dlna_profile' are now props of base Transcoder.
      can_handle() can now also move to base Transcoder class.
      TranscodeManager provides Transcoder rather than transcoding source.
      HTTServer and TranscodeManager are now 'internal'.
      No need to lie about DLNA profile anymore.
      Require mainline gupnp-av.
      Use dlna profile as transcoding target.
      Rename MP3Profile to MP3Layer.
      MP2TSTranscoder supports both HD and SD.
      No need to mark TranscodeManager's methods 'internal'.
      Move create_resource() from TranscodeManager to Transcoder.
      Implementations override Transcoder.create_resource.
      Remove unneeded args of Transcoder.create_resource().
      Move add_resources to base Transcoder class.
      Re-use const defined already to construct mime_type.
      MP3Transcoder doesn't need to proxy it's Bin's methods.
      MP3TrancoderBin doesn't need to keep layer info.
      Put gst transcoder bins into separate files.
      create_transcoder is now part of relevant Transcoder.
      TranscoderBin.post_error is now static.
      Turn TranscoderBin into GstUtils.
      L16Transcoder supports both endianness'es.
      Correct a copy&paste mistake.
      More specific naming for L16Transcoder's encoder bin.
      MP3Transcoder (re-)uses L16Transcoder's encoder.
      Refactor TranscodeManager.add_resources().
      Provide audio transcoding for videos as well.
      Provide video transcoding for audio/music items as well.
      Transcoder tells the primary UPnP class it is meant for.
      TranscodeManager keeps list of transcoders.
      TranscodeManager keeps a single list of transcoders.
      mpeg2enc wants us to tell it the aspect ratio.
      MP3Trancoder specifies the bitrate in Resource.
      Some basic documentation for recently added classes.
      mp3 and l16 transcoder support audio upnp class rather than music.
      mpeg ts transcoder provides NTSC (30 fps).
      Make sure mpeg ts transcoder outputs 30 fps.
      Use ffenc_mpeg2video instead of mpeg2video.
      The aspect-ratio needs to be 1:1 once video has been scaled.
      Just set all the desired caps at the end of the pipeline.
      Remove the FIXME comment from MediaItem.
      Put the videorate element after videoscale.
      Add audiorate element to audio transcoding pipeline.
      Update build system for latest vala.
      Require vala trunk (0.7.1).
      No need to require gstreamer trunk.
      Provide a DOAP file.
      Put user configuration access into a separate object.
      Configuration should be part of public API.
      GConf path prefix shouldn't be a public prop.
      Depend on Gtk+ if UI build is not disabled.
      Put Configuration into a separate static library.
      Beginning of a preferences UI.
      Add an "Apply" button.
      Our dialog implements it's own run method.
      Dialog should be all visible from the beginning.
      Skeleton for handling of dialog response.
      Put the cstuff in the config library.
      Add widgets to set 'host-ip' and 'port' configuration.
      Add "Enable Xbox support" option.
      A bit of refactoring.
      Don't put label as part of CheckButton.
      Refactor more: HBox and Label now handled by add_pref_widget.
      Don't put anything in gconf.
      Rename Configuration to ConfigReader.
      Make GConf client and path accessible to subclasses.
      All plugins need to link to gconf now.
      Allow get_string() params/return to be null.
      Convenient methods to read boolean and integer.
      Use the convenience methods to read values from gconf.
      Make convenience methods public.
      New class for editing of user configuration.
      Don't capitalize the gconf keys unless it's an abbrev.
      Add convenience methods to set IP, port and xbox support.
      Define constants for known keys.
      Differentiate between name and title of config options.
      Keep the config_editor in the object scope.
      Actually save the configuration.
      Save the boolean options as well.
      Also save the integers.
      Rename Preferences to PreferencesDialog.
      Introducing PreferencesVBox.
      PreferencesDialog doesn't need to keep config_editor.
      PreferencesVBox should provide a title for itself.
      Put the PreferencesVBox in Notebook.
      Keep section name in a object field.
      Make some fields/methods of PreferencesVBox, protected.
      Introducing GeneralPrefVBox.
      Minor indentation fix.
      Treat empty strings from gconf as nulls.
      Pass the title and section args in correct order
      Don't expose 'enable-xbox' prop to user
      Provide consts for title and UDN keys
      Put code to add a pref page in a separate method
      Introducing PluginPrefVBox.
      Add pref vbox for all existing plugins.
      Merg 'section' and 'title' props of PluginPrefVBox
      More use of consts defined for gconf keys
      Add option to enable/disable plugins
      Don't use GConf.Client.get_bool ()
      Don't load disabled plugins
      Remove the unused convenience methods
      ConfigReader + ConfigEditor = Configuration
      UDN is supposted to be a constant
      HIG: Put the OK button in the end
      Exit on delete event on PreferencesDialog
      Rename PreferencesVBox to PreferencesPage
      Moving towards Glade + GtkBuilder approach.
      Convert UI file to Gtk+ 2.16.
      Better names for widgets.
      Assign response IDs to buttons.
      Better names for some widgets.
      Port the code to use dynamic UI
      Use the correct response IDs.
      Put a nice title on the dialog
      Dialog should be at least 400 pixels by default
      Put the table inside an alignment
      Random size/alignment improvements
      Remove the unneeded VBox
      Add transcoding options
      Add transcoding options to Configuration
      Better names for transcoding check buttons
      Config UI loads/saves the transcoding options
      General options are loaded/saved on demand
      Bring back the tooltips
      Glade3 wants to re-arrange some widgets, let it!
      Disable widgets when they don't make sense
      Add a button to enable/disable media server.
      Remove all xbox-related stuff
      Install the rygel header(s)
      Distribute the deps file
      Install the vapi and dep files
      List all required packages in deps file
      Provide a pkg-config file
      Dialog should not be resizable.
      New better layout for general tab.
      Don't expose UDN in the config UI
      Configuration is grouped sections
      Put all plugins options on the same page
      Use basename as container's title
      More style consistency fixes for Folder plugin
      Merge commit 'origin/git-version'
      Use "owned" keyword instead of "#"
      Mediathek plugin should be disabled by default
      Protocol to uknown URI is same as it's scheme
      Minor indentation fix
      enumerate children asynchronously
      Fetch files from enumerator, asynchronously
      PluginLoader is now in public API
      Passive loading of plugins
      Remove an unneeded constant
      First implementation of External plugin
      Remove an extra arg from a method
      Rename 'service_path' to 'service_name'
      Use the ObjectPath type instead of 'string'
      Load the external services dynamically
      Plugin can provide title as well as name
      A workaround for unknown array length
      Automatic substitution of user info in title
      Configuration.get_title takes default value arg
      Honor the default title provided by plugins
      Add "available" prop to Plugin
      Attach the availability of MediaServer and Plugin
      Update docs for PluginLoader
      Differentiate between modules and plugins
      Use the new keywords
      Allow the old (shorter) keywords in config ui
      Add magic keyword for hostname substitution
      Shorter alias of @HOSTNAME@ for config UI: %h
      ExternalItem constructor gets ExternalContainer
      Substitute "://@HOSTNAME@" with hostname
      No need to pass service_name to ExternalItem
      Keyword substitution for ExternalItem title
      Keyword substitution goes to ExternalContainer
      Keyword substitution for ExternalContainer title
      Plugin is made (un)available when it's backend goes down/up
      Add the forgotten Makefile.am
      Can't use 'foreach' on strv from dynamic dbus calls
      Substitute the correct keyword in URIs
      New class: ExternalPluginFactory
      Call Dbus.ListNames asynchronously
      PluginLoader keeps a hashtable of plugins
      Add API to get/list plugins
      Provide hashing and equality check functions
      Let PluginFactory handle the NameOwnerChange signal
      ExternalPlugin doesn't need DBus object proxy anymore
      Use of 'this' to make things explicit
      Watch for and use new external plugins
      Add a debug statement
      Put PluginFactory in a separate file
      Move the constants into class definitions
      Take care of activatable services as well
      Use GetAll to get all item props at once
      Act on org.Rygel.MediaContainer1.Updated() signal
      Update the API usage according to latest spec.
      Fix a small typo
      Catch error from ExternalContainer.fetch_media_objects
      Re-use existing description
      Generate UDN when creating description first time
      Don't keep the UDN in user config anymore
      Remove test plugin from config UI
      Add Folder plugin to user preferences UI
      Provide GConf schemas
      Only load Tracker plugin if service is available
      Only load DVB plugin if service is available
      Add Jens Georg to AUTHORS
      Require vala 0.7.3
      Fix a typo in mediathek plugin Mafefile.am
      Distribute built sources as well
      Don't check for vala unless instructed to do so
      Value of VAPIDIR defaults to ${datadir}/vala/vapi
      Distribute .version file
      Bump-up gupnp-av requiment to latest: 0.4
      No need to disable UI tools
      More verbose output on module loading failure
      Proper use of 'top_srcdir' and 'abs_top_builddir'
      Module load failure message should be a warning
      Show exact error on module load failure
      Better handling of Module.symbol() failure
      DBus MediaServer spec update
      Add widgets to UI for specifying folders to export
      Methods to get/set list of strings configuration
      Handle 'Folders' textview
      Equally align the text labels
      Provide mnemonics
      Put plugins pref table in an alignment
      OK button is the default button
      Align the label to corresponding textview
      Minor indentation fix
      Mediathek plugin should be enabled in the config
      Use GLib.warning() for displaying warnings
      Rygel.Configuration should inherit GLib.Object
      Rygel.Configuration is now a singleton
      Take user transcoding configuration into account
      Clear the existing service list first
      Don't put empty string to 'folders' config
      Prepare release notes for 0.3.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]