[rygel/shave] (233 commits) ...Don't put empty string to 'folders' config



Summary of changes:

  9bb186e... Put user configuration access into a separate object. (*)
  5ff76f4... Configuration should be part of public API. (*)
  a7f6fd4... GConf path prefix shouldn't be a public prop. (*)
  19b29a5... Depend on Gtk+ if UI build is not disabled. (*)
  9801ff1... Put Configuration into a separate static library. (*)
  ec5cd68... Beginning of a preferences UI. (*)
  bbfcca1... Add an "Apply" button. (*)
  9010c09... Our dialog implements it's own run method. (*)
  9181c45... Dialog should be all visible from the beginning. (*)
  17ff1f4... Skeleton for handling of dialog response. (*)
  6cb4659... Put the cstuff in the config library. (*)
  ac6e162... Add widgets to set 'host-ip' and 'port' configuration. (*)
  85b01ac... Add "Enable Xbox support" option. (*)
  7033873... A bit of refactoring. (*)
  013b7b3... Don't put label as part of CheckButton. (*)
  5a5e2e8... Refactor more: HBox and Label now handled by add_pref_widge (*)
  d6660bf... Don't put anything in gconf. (*)
  3a4546d... Rename Configuration to ConfigReader. (*)
  110ce3a... Make GConf client and path accessible to subclasses. (*)
  adf9ad6... All plugins need to link to gconf now. (*)
  e23ce89... Allow get_string() params/return to be null. (*)
  ed7552b... Convenient methods to read boolean and integer. (*)
  e9b1389... Use the convenience methods to read values from gconf. (*)
  1a01d64... Make convenience methods public. (*)
  1146b26... New class for editing of user configuration. (*)
  de493a4... Don't capitalize the gconf keys unless it's an abbrev. (*)
  4ef780b... Add convenience methods to set IP, port and xbox support. (*)
  6285f4e... Define constants for known keys. (*)
  6b58c3d... Differentiate between name and title of config options. (*)
  47cc318... Keep the config_editor in the object scope. (*)
  8529cb2... Actually save the configuration. (*)
  99fb8b0... Save the boolean options as well. (*)
  b012d0d... Also save the integers. (*)
  568cb6d... Rename Preferences to PreferencesDialog. (*)
  019daaa... Introducing PreferencesVBox. (*)
  39f2f54... PreferencesDialog doesn't need to keep config_editor. (*)
  0557d8c... PreferencesVBox should provide a title for itself. (*)
  1c4d633... Put the PreferencesVBox in Notebook. (*)
  15a7a11... Keep section name in a object field. (*)
  76c48a1... Make some fields/methods of PreferencesVBox, protected. (*)
  8bd2443... Introducing GeneralPrefVBox. (*)
  cd69a1e... Minor indentation fix. (*)
  95ef7c6... Treat empty strings from gconf as nulls. (*)
  29ff775... Pass the title and section args in correct order (*)
  65cacec... Don't expose 'enable-xbox' prop to user (*)
  3c523dd... Provide consts for title and UDN keys (*)
  73b773f... Put code to add a pref page in a separate method (*)
  089ceb5... Introducing PluginPrefVBox. (*)
  acb10bb... Add pref vbox for all existing plugins. (*)
  779fcd9... Merg 'section' and 'title' props of PluginPrefVBox (*)
  adc453a... More use of consts defined for gconf keys (*)
  772b91c... Add option to enable/disable plugins (*)
  50c201f... Don't use GConf.Client.get_bool () (*)
  0449734... Don't load disabled plugins (*)
  b7adf47... Remove the unused convenience methods (*)
  3ca65b8... ConfigReader + ConfigEditor = Configuration (*)
  bae7463... UDN is supposted to be a constant (*)
  7373e5e... Use git-version-gen to generate package version. (*)
  6de63b7... Add a summary after configure (*)
  c8f3edc... HIG: Put the OK button in the end (*)
  ea9687b... Exit on delete event on PreferencesDialog (*)
  616f0af... Rename PreferencesVBox to PreferencesPage (*)
  1f32c84... Moving towards Glade + GtkBuilder approach. (*)
  5b198ca... Convert UI file to Gtk+ 2.16. (*)
  7402b87... Better names for widgets. (*)
  3b4c7f0... Assign response IDs to buttons. (*)
  cd58b02... Better names for some widgets. (*)
  0ec058c... Port the code to use dynamic UI (*)
  f995cae... Use the correct response IDs. (*)
  836ea9b... Put a nice title on the dialog (*)
  b9506a9... Dialog should be at least 400 pixels by default (*)
  ef2ed6d... Put the table inside an alignment (*)
  26bfc36... Random size/alignment improvements (*)
  24f6c86... Remove the unneeded VBox (*)
  8dc59e6... Add transcoding options (*)
  4e5b664... Add transcoding options to Configuration (*)
  ae5b2e7... Better names for transcoding check buttons (*)
  1c82936... Config UI loads/saves the transcoding options (*)
  9dbba34... General options are loaded/saved on demand (*)
  f9bbc5b... Bring back the tooltips (*)
  6ea6f83... Glade3 wants to re-arrange some widgets, let it! (*)
  14792d0... Disable widgets when they don't make sense (*)
  0661eb9... Add a button to enable/disable media server. (*)
  328dfcd... Remove all xbox-related stuff (*)
  5c81374... Install the rygel header(s) (*)
  4a40458... Distribute the deps file (*)
  1e25646... Install the vapi and dep files (*)
  3fd4e9d... List all required packages in deps file (*)
  cdddb36... Provide a pkg-config file (*)
  bdecc68... Dialog should not be resizable. (*)
  8f3c99a... New better layout for general tab. (*)
  a67ce90... Don't expose UDN in the config UI (*)
  e3b32b2... Configuration is grouped sections (*)
  bc95624... Put all plugins options on the same page (*)
  c8401df... import plugins into branch (*)
  37c7792... add copyright header (*)
  d23a428... update copyright (*)
  a112db8... Add simple gconf configuration (*)
  2000ae8... Fix segfault on folder plugin (*)
  eeeea6c... once again, add mms straming protocol (*)
  1524ba9... load children on demand only (*)
  542e761... move directorysearch into own file (*)
  b2ffeac... add folder media object (*)
  bffd77e... Make folder plugin recursive (*)
  6664567... make it work with gvfs (non-local directories) (*)
  75cf277... Make it work with arbitrary gio sources (*)
  7df93dd... Fix crash if no gconf key; Use XDG dirs then (*)
  ac1da35... fix handling of nonexistant gconf key (*)
  387f8cc... DirectorySearchResult adheres the style guide (*)
  49472a8... Make FolderContainer adhere style guide (*)
  7aebfe4... Make MediaItem adhere style guide (*)
  7163dd9... Make FolderContentDir adhere Styleguide (*)
  c38f0f8... Finish style guide cleanup (*)
  4b55092... add missing file to BUILD_SOURCES (*)
  b1eb780... Fix ASX class for style (*)
  9fdabb9... RootContainer -> fix style (*)
  484cea5... RssContainer -> style (*)
  3b25844... VideoItem -> style (*)
  60a100a... Plugin->style (*)
  0049f63... Move class guessing to factory method (*)
  47cfca1... More style fixes (*)
  26ea10a... Fix more stlye issues (*)
  2e28377... Use basename as container's title (*)
  c258936... More style consistency fixes for Folder plugin (*)
  8294883... Merge commit 'origin/git-version' (*)
  9a5cbe6... Use "owned" keyword instead of "#" (*)
  daa83b9... Mediathek plugin should be disabled by default (*)
  5da6e0b... Protocol to uknown URI is same as it's scheme (*)
  18817b9... Change Mediathek plugin headers to LGPL (*)
  d74e7d4... Correct license header for cstuff.vapi (*)
  b896043... Minor indentation fix (*)
  646739b... enumerate children asynchronously (*)
  54e41ee... Fetch files from enumerator, asynchronously (*)
  8721d75... PluginLoader is now in public API (*)
  43e15c1... Passive loading of plugins (*)
  d986bd0... Remove an unneeded constant (*)
  15cdac0... First implementation of External plugin (*)
  59d4519... Remove an extra arg from a method (*)
  2c2ef28... Rename 'service_path' to 'service_name' (*)
  24d2135... Use the ObjectPath type instead of 'string' (*)
  80a8d40... Load the external services dynamically (*)
  73b8a7f... Plugin can provide title as well as name (*)
  acf5030... A workaround for unknown array length (*)
  391e125... Automatic substitution of user info in title (*)
  dd9b977... Configuration.get_title takes default value arg (*)
  47fcdd1... Honor the default title provided by plugins (*)
  00290d6... Add "available" prop to Plugin (*)
  4e5a233... Attach the availability of MediaServer and Plugin (*)
  42fce5d... Update docs for PluginLoader (*)
  979f081... Differentiate between modules and plugins (*)
  9151bc6... Use the new keywords (*)
  d854471... Allow the old (shorter) keywords in config ui (*)
  09b4934... Add magic keyword for hostname substitution (*)
  adfdfce... Shorter alias of @HOSTNAME@ for config UI: %h (*)
  3d63d98... ExternalItem constructor gets ExternalContainer (*)
  c01e9d1... Substitute "://@HOSTNAME@" with hostname (*)
  422161a... No need to pass service_name to ExternalItem (*)
  e6e8be1... Keyword substitution for ExternalItem title (*)
  21d3971... Keyword substitution goes to ExternalContainer (*)
  fb39780... Keyword substitution for ExternalContainer title (*)
  55340a6... Plugin is made (un)available when it's backend goes down/up (*)
  9fedf61... Add the forgotten Makefile.am (*)
  d085cd6... Can't use 'foreach' on strv from dynamic dbus calls (*)
  5130f14... Substitute the correct keyword in URIs (*)
  26561b7... New class: ExternalPluginFactory (*)
  fecb347... Call Dbus.ListNames asynchronously (*)
  a2b7d91... PluginLoader keeps a hashtable of plugins (*)
  8b73458... Add API to get/list plugins (*)
  29bad49... Provide hashing and equality check functions (*)
  53547bb... Let PluginFactory handle the NameOwnerChange signal (*)
  a0caf55... ExternalPlugin doesn't need DBus object proxy anymore (*)
  f6758f0... Use of 'this' to make things explicit (*)
  e5edf4b... Watch for and use new external plugins (*)
  a38f2b1... Add a debug statement (*)
  97f4723... Put PluginFactory in a separate file (*)
  7c65949... Move the constants into class definitions (*)
  7121f78... Take care of activatable services as well (*)
  df82fd5... Use GetAll to get all item props at once (*)
  e99fbc3... Act on org.Rygel.MediaContainer1.Updated() signal (*)
  daed550... Update the API usage according to latest spec. (*)
  6dff7a6... Fix a small typo (*)
  7cac504... Catch error from ExternalContainer.fetch_media_objects (*)
  15d485a... Re-use existing description (*)
  a19c8c2... Generate UDN when creating description first time (*)
  0da129e... Don't keep the UDN in user config anymore (*)
  12ec11f... git-version-gen: generate versions with . instead of - (*)
  7f1339d... Remove test plugin from config UI (*)
  e818921... Add Folder plugin to user preferences UI (*)
  cbf5192... Provide GConf schemas (*)
  f16740b... Only load Tracker plugin if service is available (*)
  1abd7f2... Only load DVB plugin if service is available (*)
  618508f... Add Jens Georg to AUTHORS (*)
  94b0fa5... Require vala 0.7.3 (*)
  55f8458... Fix a typo in mediathek plugin Mafefile.am (*)
  73f2f66... Distribute built sources as well (*)
  3a1dbb2... Don't check for vala unless instructed to do so (*)
  037437b... Value of VAPIDIR defaults to ${datadir}/vala/vapi (*)
  1c00b55... Distribute .version file (*)
  883267c... Bump-up gupnp-av requiment to latest: 0.4 (*)
  ec3bd0f... No need to disable UI tools (*)
  4b272b8... More verbose output on module loading failure (*)
  38527ec... Proper use of 'top_srcdir' and 'abs_top_builddir' (*)
  47eb8c1... Module load failure message should be a warning (*)
  3267a2a... Show exact error on module load failure (*)
  1457cff... Better handling of Module.symbol() failure (*)
  8db3a60... DBus MediaServer spec update (*)
  f65e235... Add widgets to UI for specifying folders to export (*)
  1a4ebad... Methods to get/set list of strings configuration (*)
  54c98f4... Handle 'Folders' textview (*)
  584a0a1... Equally align the text labels (*)
  768db24... Provide mnemonics (*)
  d73e73d... Put plugins pref table in an alignment (*)
  35fac98... OK button is the default button (*)
  0548e60... Align the label to corresponding textview (*)
  d275725... Update schemafile for Folder and Mediathek (*)
  2ea2578... Add Readme for Mediathek plugin configuration (*)
  15d5d50... Rename gconf key from folder to folders (*)
  d934874... Fix schema file (*)
  121ad89... Use configuration class (*)
  c78d252... Add get_int_list method to Configuration class (*)
  24fda31... Fix exception handling (*)
  5e98a9f... Fix missing return value (*)
  4d651fc... Simply use basename everywhere (*)
  d15bffa... Remove MediaItem subclass (*)
  6a76963... Use Configuration class instead of raw gconf (*)
  8de8a77... Minor indentation fix (*)
  49ecefa... Mediathek plugin should be enabled in the config (*)
  248eaf0... Use GLib.warning() for displaying warnings (*)
  935e190... Rygel.Configuration should inherit GLib.Object (*)
  1d80b24... Rygel.Configuration is now a singleton (*)
  747db1c... Take user transcoding configuration into account (*)
  fbf778d... Clear the existing service list first (*)
  c023ae5... Don't put empty string to 'folders' config (*)

(*) This commit already existed in another branch; no separate mail sent



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]