[babl] Created tag BABL_0_1_0



The unsigned tag 'BABL_0_1_0' was created.

Tagger: Martin Nordholts <martinn src gnome org>
Date: Thu May 21 01:20:28 2009 +0200

    Tag that marks babl 0.1.0

Changes since the last tag 'BABL_0_0_18':

Hubert Figuiere (1):
      Add extern "C" to the header for C++ friendliness.

Jan Heller (11):
      added naive versions of respective conversions.
      fallback to floor function when rint function is not available.
      changed fallback macro to have the same return type as rint().
      Added support for CPU acceleration, RGBA float -> RGB u8 and RGBA float ->
      Fixed conditionally compiled code.
      Added babl_get_version () to the public API.
      Added.
      babl_get_version () moved into separate source file.
      Updated download link.
      Updated contact info.
      Added fallback non-SSE routine if the input buffer is not aligned to 16

Kevin Cozens (1):
      Applied patch from Matteo 'Peach' Pescarin which makes build use rsvg

Manish Singh (1):
      BABL_VARIADIC_MACROS needs to be called before the libtool stuff (which

Martin Nordholts (65):
      Added "This considerably improves BABL performance." to latest ChangeLog entry.
      typedef:ed BABL free and malloc function pointers.
      extensions/gegl-fixups.c (conv_rgbAF_sdl32) Make un-pre-multiplication
      Add #define BABL_ALPHA_THRESHOLD which is the alpha threshold used in the
      Use the default babl tolerance level if BABL_TOLERANCE is the empty string
      Don't just eek when an assertion fails, also say exactly what failed.
      Instead of an arbitrary threshold, use one hundredth of the channel
      Remove BABL_HARD_MAX_PATH_LENGTH from here, it's only for internal use.
      Don't document forward declarations and move them down a bit to make them
      Use a lowercase 'a' in 0xbab100.
      Make BablClassType an enum instead of an unsigned int contaning enum
      Fix misformated entry.
      Make BablClassType an int again, it doesn't make sense as an enum as the
      New installed header file that contains portability macros.
      New installed file with babl_init() and babl_destroy() declarations.
      Don't redeclare functions declared with the BABL_CLASS() or
      Instead of having BABL_CLASS() plus variants and making the macros
      Don't have BABL_ALPHA_THRESHOLD public yet.
      Move up forward declaration of BablList.
      Move forward declaration of BablList to the beginning...
      New installed header file containing class and typesystem definitions and
      Formating.
      Make babl.h look clean.
      Don't #include <stdlib.h>
      extensions/gegl-fixups.c #include <stdlib.h>
      Remove babl_name() and babl_introspect() which slipped in here.
      Fix bogus ChangeLog formating in two of my recent entries.
      s/babl_foo_init/babl_foo_class_init/
      s/babl_image/babl_image_new/
      Add #define babl_foo babl_foo_from_name macros, that should fix
      New file collecting the type constants, includes and the union for the
      Do a s/babl_destroy/babl_exit since 'destroy' is better paired
      Namespace the include guard.
      Add include guards.
      Since babl_foo_from_id() will not be part of the public API we can
      Do a complete overhaul of the babl API.
      Include headers in babl.h as system headers
      Add .gitignore files generated with git svn create-ignore
      Include config.h in some files that missed it
      Remove trailing comma in enum declaration
      enum values must be less than INT_MAX (sign bit is illegal)
      Some vendor C compilers choke on C++ comments
      Some vendor compilers can't compile non-constant elements of compound struct initializers
      Handle variadic macros in a portable way
      NULL-statements caused by trailing commas are non-portable
      Support hpux use of shl load/unload and dsos with .sl suffixes
      Don't use depecrated features or reduntant declarations in Makefile.am
      Rewrite xml-insert.sh in portable bourne-shell
      Don't try to pass gcc flags to vendor compilers
      Avoid the need for define __func__ "unknown" on some vendor compilers
      Update NEWS for 0.1.0
      Update ChangeLog with previous commit
      Makefile.am: We don't have a COPYING.LESSER anymore
      babl/Makefile.am: Add forgotten header files
      extensions: util.h is part of the source
      Update AUTHORS for 0.1.0
      Bug 568576 â?? [PATCH] undefined operation fix
      Update AUTHORS and NEWS for 0.1.0
      Finish update of AUTHORS..
      Update NEWS with release date
      Update ChangeLog
      docs: Convert SVN references to git
      docs: Add .libs directories to BABL_PATHs
      Bump version to 0.1.0
      0.1.0 released

Mukund Sivaraman (4):
      Added missing dlclose()s.
      Added missing va_end()s.
      getenv() can return NULL.
      Sparse fixes.

Sam Hocevar (1):
      ensure that the "w3m must be available" message is properly displayed:

Sven Neumann (14):
      Applied patch from Jan Heller that introduces list and hash table
      babl/babl-component.c babl/babl-conversion.c babl/babl-db.c
      added Jan Heller and obfuscated the email addresses.
      new file defining BABL_DETECT_CFLAGS() macro.
      this function has no return value, declare it as void.
      extensions/util.h removed trailing whitespace.
      formatting.
      initialize format.visited.
      changed fallback macro to have the same return type as rint().
      also use AM_CPPFLAGS and CPPFLAGS for building sse-fixups.
      `:='-style assignments are not portable
      babl/babl-component.h babl/babl-conversion.h babl/babl-extension.h
      babl/babl.h renamed babl_format_get_num_of_components() to
      based on a patch from Gary V. Vaughan, include "config.h" before any other

Tor Lillqvist (1):
      Make the "test" array static.

Zhang Junbo (5):
      added the format "frequency double".
      changed RrGrBr... into RrRiGrGiBrBiArAi.
      implenmented frequency_to_rgba.
      some work on frequency_to_rgba.
      changed RrRiG... back to RrGrBrArRiGiBiAi.

�yvind Kolås (31):
      Applied patch from dmacks netspace org closing bug #519796
      do not add @DL_LIBS@ to link line of babl.
      applied patch from Jan Heller that improves readability by using the newly
      Applied patch from Jan Heller that ports BablFishPath class to the new
      Applied patch from Jan Heller that improves logic of go_fishing code
      Applied patch from Jan Heller.
      removed babl-classes.h removed and mostly folded into ... .. this file,
      split up into ... Separate header files.
      updated. updated. improved introduction and feature list.
      typo fix
      reindented code, documented BABL_ERROR.
      added TODO moved TODO list from here to here, also edited it a bit.
      added a html comment shortening the news shown. assed link to changelog in
      s/BABL_ERROR/BABL_ACCURACY/ s/BABL_ERROR/BABL_ACCURACY/ added a missing
      s/BABL_TOLERANCE/ s/BABL_ACCURACY/BABL_TOLERANCE/
      removed markup mistake that introduced horizontal scrolling in gecko.
      moved the BABL_TOLERANCE documentation paragraph in under Environment
      fixed indentation and misplaced ' spotted by Jan Heller.
      moved the babl directory overview here from the GEGL site.
      0.0.20 released
      0.0.22 released
      post release increment of version to 0.0.23
      added dummy model "frequency" and dummy format "frequency float" to be
      applied patch from dmacks at netspace.org cleaning up some of the build
      added typedef size_t gsize to the set of gtypes lifted from glib. spotted
      renamed to ..
      added missing, needed conversion.
      added some more missing conversions.
      make all components 0.0 when alpha < 0.00001.
      use the lookup tables to speed up the conversion 8still error of 0.002677
      show in red the conversions that are worse than the current BABL_TOLERANCE



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]