gnome-disk-utility annotated tag 0.2, created. 0.2
- From: davidz src gnome org
- To: svn-commits-list gnome org
- Subject: gnome-disk-utility annotated tag 0.2, created. 0.2
- Date: Mon, 2 Mar 2009 16:32:36 -0500 (EST)
The annotated tag, 0.2 has been created
at bf3701a0342b8a9f32f7b49542db6c602f6d6d4b (tag)
tagging 44a449f651994b08b0695c0cd40b4f01817f217b (commit)
tagged by David Zeuthen
on Mon Mar 2 16:30:22 2009 -0500
- Log -----------------------------------------------------------------
Released gnome-disk-utility 0.2
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
iEYEABECAAYFAkmsT+4ACgkQKn8s4BN7nF5bywCfccqibGRR+9Up1MSNzVXKcsjP
uVIAnjpUdpcNAjjwR1o4iaLmoBIUNZ6m
=wwvI
-----END PGP SIGNATURE-----
David Zeuthen (180):
initial commit
replace mount, unmount, eject icons and implement these actions
initial port to DeviceKit-disks
add an abstraction on top of gdu-device
show empty space in the tree
show mount point for devices
update the user interface on "changed" signal on a GduPresentable
move all the info bits into appropriate classes
refactor the code a bit and update to latest DeviceKit-disks API
inhibit disks daemon from shutting down
factor out individual pages in the notebook into their own classes
begin working on partitioning
work a lot on partitioning
remove some debug spew
add basic ui for "create partition table" part of the partitioning tab
minor UI fixes and enhancements
move summary to bottom; use it for progres/failures instead of the cluebar
factor out the disk widget into a separate class
implement the modify partition section
factor out create, modify, createtable of partitioning into separate pages
fix what page should be shown if the currently shown page changes
add support for CreatePartitionTable
include hexnumber in mbr partition type names and unify some codepaths
on dismiss, clear the GtkLabel for the error message to reclaim space
add some useful tips describing the selected secure erase option
also add tips for fs and partscheme comboboxes
add warnings for extended partitions when dealing with mbr
add support for creating ntfs and swap
strip out some names
add support for file systems on the main block devices
attempted to give the ui some loving
put a shadow around the scrolled window for the treeview
add support for encrypted block devices
use the new UnlockEncrypted and LockEncrypted API in DeviceKit-disks
implement changing secrets on encrypted devices
add the "[ ] Encrypt underlying device" option
support saving passphrase to keyring on creation of an encrypted device
don't unref objects we don't own
export new property "device-is-busy"
when actively selecting an entry in the tree, focus the tree
display connection type, speed and media compatibility
handle the use case where a whole disk is unrecognized
major rewrite of how the UI works
make confirmation dialogs reference the drive/media and default to "Cancel"
properly reset pages with sane defaults
rename the Actions menu to Edit
drive-media is now exported as two properties from the daemon
add S.M.A.R.T. monitoring and selftest support
also show drive temperature in Fahrenheit
add first stab at proper linux-md (software raid) handling
add support for assembling and stopping linux md raid arrays
do more work on linux-md Software RAID
fix 'make distcheck'
retrieve and show last_self_test_result as the daemon now returns this as well
don't dup invalid strip when RetrieveSmartData() fails
ext3 filesystems can be renamed while mounted
replace the page concept with a section concept
use a spin button (in addition to the hslider) when creating partitions
fix warnings on x64_64
catch up to latest DeviceKit-disks API
the daemon can no longer be inhibited
update to new SMART API in DKD and provide UI for attributes
use new widget GduTimeLabel that is properly updated as time flows
add some work-in-progress graphing for SMART data
work a bit more on the smart graphs
some more work on the graphs
update list of translated files so distcheck works
write a TODO file
rip out the get_info() method, it's no longer used
properly show swap space
in the details view for mounted devices, show a link for opening nautilus
adjust details for linux md arrays
add name for the sdio connection interface
rework GduDevice op error handling and raise all errors through GduShell
remove GduDevice functions to match the D-Bus API
fixup API for historical smart data retrieval
move smart data and smart attributes into separate classes
rename function to start a Linux MD Software RAID array
properly quote the mount point when launching the file manager
turn on more compiler warnings and fix up some code to get 0 warnings
don't free data on error paths
update mapping from job-id to human readable name
retry unlocking in idle handler to ensure job-spinner is hidden
on unlock and passphrase change, indicate when a wrong passphrase is given
print name of device in encryption dialogs
remove encryption dialogs when device is removed
add a "Take ownership of file system" check box to make ext3 etc. useful
pick up new property 'device-is-system-internal'
catch up with authorization and ABI changes in DeviceKit-disks
attempt to clean up error handling
implement UI for FilesystemCheck
retrieve information about fs and encryption support from the daemon
fix off-by-one bug in known-filesystems property parsing
update to latest DeviceKit-disks ABI that changed encrypted to luks
update to new D-Bus errors in latest DeviceKit-disks
update to new API where FilesystemSetLabel is renamed to SetLabel
revert "update to new API where FilesystemSetLabel is renamed to SetLabel"
some of the PolicyKit actions in the daemon was renamed
use the name "LVM2 Physical Volume" instead of "RAID" for LVM2_member
add name for LVM2_member in various utility functions
add new icons from Mike Langlie
export information about optical discs
implement eject and move a few methods around
first cut at a useful dialog if the fs is busy on unmounting
move utility functions depending on GTK+ into a separate file
split deps into separate CFLAGS and LIBS
forgot to add gdu-process.[ch]
split useful non-ui bits into a shared library called libgdu
forgot to add new files for libgdu
initial stab at adding gtk-doc support to libgdu
add docs for GduError
create a header file with shared type definitions
add docs for the GduPresentable interface
hide constructors not supposed to be public
use #ifndef for GDU_POOL_H to hide it in the generated docs
move all type definitions of private structures into gdu-shared.h
move all callbacks to a separate file and move to separate section of docs
remove trailing space in @short_description for GduPresentable
add docs for GduPool
add missing signal docs for GduPresentable
add more docs explaning the point of GduPresentable
add docs for GduDrive, GduVolume and GduVolumeHole
make some methods on GduDevice private
add docs for GduActivatableDrive
move some UI bits into a new libgdu-gtk library
move disk utility source to separate directory and rename app to Palimpsest
forgot to add gdu.h
fix signal reg since the daemon now uses object paths instead of strings
fix marshaller type
add API to get objects by device file
add API_IS_SUBJECT_TO_CHANGE_FUCK_ME_HARDER_ETC checks for libgdu / libgdu-gtk
fix 'make distcheck'
update licensing so code is LGPLv2+ and icons are GPLv2+
return a GIcon instead of an icon name
export API to get LUKS secret and reword the keyring description
export API for new cryptotext LUKS properties exposed by the DK-disks daemon
export name+uuid for linux-md devices
add new gdu_presentable_get_id function
rework device detection to be more robust and rework how Linux MD is handled
fix up private data handling in all classes
use new linux-md-home-host and linux-md-component-home-host properties
use a better icon size when listing RAID components
add dummy member to private struct since GObject don't like empty privs
add gdu-unmountable icon but don't use it yet...
don't include the size in the name for a Linux MD raid array
use drive-removable-media-* for volumes from drives with removable media
avoid leading white-space for drive name when vendor is NULL or blank
don't crash if GetAll() for device properties fails
use powers of ten for device sizes
fix a few memory leaks
handle when slaves are added/removed to a Linux MD array
update HACKING now that we have moved to git.gnome.org
various header file and cosmetic fixes
fix up docs
add dummy member to empty private struct
add support for media detection bits recently added to DeviceKit-disks
update for audio disc API changes in DeviceKit-disks
include KiB, MiB and GiB in the long string representations of size
add an extra line when displaying details about a presentable
fix up naming and icons for optical drives and optical discs
don't grey the icon for unallocated/unrecognized data
slightly rework and clean up the UI
default to creating Master Boot Record partition tables
add support for ext4 and add description for XFS file system
also use y as mnemonic for "Encrypt Device" check box everywhere
choose the right icon for floppy media
update to latest DeviceKit-disks API and rework API for GduDrive
use new device-presentation-name and -icon-name properties in DeviceKit-disks
make sure we emit signals on add/change signals on GduPresentable
fix a few memory leaks
update to latest DKD polkit actions and fix up Linux MD activation
catch up with latest polkit action changes in DKD
avoid using dbus_g_error_get_name() to determine if authorization is needed
bump version to 0.2
add support for handling when the daemon is inhibit
fix up docs
fix up POTFILES.in
update NEWS for release
update HACKING, README and TODO
add a nag dialog
Mike Langlie (2):
add new mount, unmount and eject icons
more cool icons from Mike
-----------------------------------------------------------------------
hooks/post-receive
--
Disk Utility for GNOME
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]