[librsvgmm] Rename render_cairo() to render()
- From: Daniel Elstner <daniel src gnome org>
- To: svn-commits-list gnome org
- Subject: [librsvgmm] Rename render_cairo() to render()
- Date: Thu, 18 Jun 2009 18:04:09 -0400 (EDT)
commit e7c7cb75f80ab7263c672ed734c97c3cf6a14e66
Author: Daniel Elstner <daniel kitta gmail com>
Date: Thu Jun 18 23:55:57 2009 +0200
Rename render_cairo() to render()
* librsvg/src/rsvg.hg (Rsvg::Handle::render): Rename method from
render_cairo() to render(), because having the rendering library
in the method name is more of an historic artifact than anything
else.
(Rsvg::Handle::render_sub): Rename method from render_cairo_sub()
to render_sub().
librsvg/src/rsvg.hg | 6 +++---
1 files changed, 3 insertions(+), 3 deletions(-)
---
diff --git a/librsvg/src/rsvg.hg b/librsvg/src/rsvg.hg
index 4b54f1b..bf039c3 100644
--- a/librsvg/src/rsvg.hg
+++ b/librsvg/src/rsvg.hg
@@ -99,10 +99,10 @@ public:
rsvg_handle_get_position_sub)
_WRAP_METHOD(bool has_sub(const Glib::ustring& id) const, rsvg_handle_has_sub)
- _WRAP_METHOD(bool render_cairo(const Cairo::RefPtr<Cairo::Context>& cr) const,
+ _WRAP_METHOD(bool render(const Cairo::RefPtr<Cairo::Context>& cr) const,
rsvg_handle_render_cairo)
- _WRAP_METHOD(bool render_cairo_sub(const Cairo::RefPtr<Cairo::Context>& cr,
- const Glib::ustring& id) const,
+ _WRAP_METHOD(bool render_sub(const Cairo::RefPtr<Cairo::Context>& cr,
+ const Glib::ustring& id) const,
rsvg_handle_render_cairo_sub)
_WRAP_METHOD(Glib::ustring get_title() const, rsvg_handle_get_title)
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]