[libchamplain] Rename Champlain::MapSourceFactory->get_default() to Champlain::MapSourceFactory->dup_default()



commit f44632794efba1f8b900e4bdff7822d174adff27
Author: Emmanuel Rodriguez <emmanuel rodriguez gmail com>
Date:   Sun Jun 7 12:02:35 2009 +0200

    Rename Champlain::MapSourceFactory->get_default() to Champlain::MapSourceFactory->dup_default()
---
 bindings/perl/Champlain/examples/gtk2.pl |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/bindings/perl/Champlain/examples/gtk2.pl b/bindings/perl/Champlain/examples/gtk2.pl
index ca32066..d146055 100755
--- a/bindings/perl/Champlain/examples/gtk2.pl
+++ b/bindings/perl/Champlain/examples/gtk2.pl
@@ -125,7 +125,7 @@ sub create_combo_box {
 	my $active = 0; # Tells which map source is active
 	my $index = 0;
 	my $current_source = $map->get('map-source')->get_id;
-	my $factory = Champlain::MapSourceFactory->get_default;
+	my $factory = Champlain::MapSourceFactory->dup_default;
 	foreach my $desc (sort { $a->{name} cmp $b->{name} } $factory->get_list) {
 		my $iter = $model->append();
 		$model->set($iter, 



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]