[pango] Created tag 1.25.1
- From: Behdad Esfahbod <behdad src gnome org>
- To: svn-commits-list gnome org
- Cc:
- Subject: [pango] Created tag 1.25.1
- Date: Mon, 10 Aug 2009 16:48:32 +0000 (UTC)
The signed tag '1.25.1' was created.
Tagger: Behdad Esfahbod <behdad behdad org>
Date: Mon Aug 10 12:46:20 2009 -0400
1.25.1
Changes since the last tag '1.24.5':
Behdad Esfahbod (269):
Merge harfbuzz-ng
Implement the first substitute()
[harfbuzz/GSUB] towards a partially working GSUB
[GSUB] Fix reverse lookup loop like we did in the old code before
[GSUB] Implement Extension subtables
[GSUB] Implement Alternate subtables
[GSUB] Start Ligature subtable support
[GSUB] Hook new GSUB up in Pango
[GSUB] Implement ligature substitutions
[GSUB] Minor refactoring
[GSUB] Towards Context subtitutes
[GSUB] minor
[HarfBuzz] Start a TODO file
[GSUB] Shuffle
[GSUB] ContextSubst format 1
[HB] Remove get_size()
[HB] Remove DEFINE_NON_INSTANTIABLE
[HB] Add TODO item
[HB] Fix typo
[GSUB] Finish ContextSubstFormat1
[GSUB] Add GSUB::substitute_lookup()
[GSUB] Implement ContextSubstFormat2
[GSUB] Implement ContextSubstFormat3
[GSUB] Start ChainContextSubst
[HB] Remove obsolete comment
[HB] Use templates for Null objects
[HB] Automate int-type size assertion
[HB] Add OffsetTo template.
[HB] Use OffsetTo<> in more places
[HB] Use OffsetTo<> for Coverage
[HB] Add ArrayOf<>
[HB] Use ArrayOf<> in GSUB
[HB] Simplify more arrays
[HB] Update copyright years
[HB] Add TODO item
[HB] Simplify buffer
[HB] Renames
[GSUB] Unify ContextSubst matching
[HB] Move Context matching logic out of GSUB
[HB] Unify first glyph property checking
[GSUB] Further optimize the main switch
[HB] Propagate property of first glyph
[HB] Couple size checks
[HB] Use four bytes for Null Tag, not 5
[HB] Cleanup format unions
[HB] More shuffling
[HB] Split Layout-common tables into new files
[HB] Remove stale TODO
[HB] Start ChainContext and ReverseChainSingleSubst lookups
[HB] Cosmetic
[HB] Add check to avoid infinite recursion
[HB] Towards sharing Context and ChainContext code
[HB] More churning towards ChainContext lookups
[HB] More template goodness
[HB] Add HeadlessArrayTo<>
[HB] A step closer to working ChainContext
[HB] Further modularize Context matching
[HB] One more step to go, for fully working GSUB and ChainContext
[HB] Implement backtrack matching
[HB] ChainContext complete
[HB] Fix context_length checking
[HB] Correctly skip glyphs when applying (Chain)Context lookups
[HB] Minor cleanup
[GSUB] Fix context_length handling in Ligature too
[HB] Cleanup TODOs
[HB] Tweak some constants and fix Coverage
[GSUB] Oops, fix Extension check
[HB] Don't use G_LIKELY!
[GSUB] Implement ReverseChainSingleSubst
[GSUB] Protect against mismatching Extension subtable types
[HB] Minor
[GSUB] Minor
[HB] Start GPOS!
Switch Pango to new, defunt, GPOS
[HB] Simplify casts
[HB] Internally rename position() and substitute() to apply()
[HB] Rename LOOKUP_ARGS to APPLY_ARGS
[HB] More reference cast simplification
[HB] Use enums
[GPOS] Start filling apply() functions in
[GPOS] PairPosFormat1
[GSUB] PairPosFormat2
[GPOS] CursivePosFormat1
[HB] Indentation
[HB] Remove unused methods
[HB] Indentation
[GDEF] Simplify Device access
[HB] Move lookup types enum into subtable class
[GPOS] Fix GPOS feature lookup lookups and application
[GPOS] Fix more brokenness
[GPOS] Finally it's working, up to Cursive
[HB] Remove all references to the old code!
[HB] Rename harfbuzz-buffer to hb-buffer
[HB] Remove last dependence on the old code base!
[HB] Add TODO item
[HB] Add TODO item
[GPOS] Start MarkBasePosFormat1
[GPOS] Remove apply_value() return value
[GPOS] Implement Device support in AnchorFormat3
[GPOS] Implement MarkArray interface
[GPOS] MarkBasePosFormat1
[GPOS] MarkMarkPosFormat1
[HB] Ouch. Add files.
[GPOS] Remove printf. MarkMarkPos1 is working
[HB] Share Extension lookup code between GSUB and GPOS
[HB] Remove apply_subtables() again
[GPOS] MarkLigPosFormat1
[GDEF] Add some get_carret_value() code
[HB] Add TODO items
[HB] Minor
[HB] Check for GDEF/GSUB/GPOS versions
[HB] Simplify version check in GSUB/GPOS
[HB] Remove unused data types
[HB] Simplify tag
[HB] Add FixedVersion cast to int
[HB] Remove stale TODO mark
[HB] Remove old code!
[HB] Remove stale makefile.msc too
[HB] Update text files
[HB] simplify macros
[HB] Simplify some basic things
[HB] Simplify more
[HB] Simplify Tag
[HB] More cleanup
[HB] Would have helped if I actually knew C++ before using it...
[HB] Update copyright years
[HB] Remove one XXX, add another
[HB] Clean more
[HB] Cleanup buffer
[HB] More buffer cleanup
[HB] Remove more macros
[HB] Add get_attach_points()
[HB] Implement get_lig_carets()
[HB] Start MarkFilteringSet support
[HB] More de-C++'ization
[HB] Support parsing MarkFilteringSets introduced in OpenType 1.6
[HB] Simplify MarkAttachmentType handling
[GDEF] Support MarkFilteringSets
[HB] When looking back/forward, skip marks only
[GPOS] Fix mark matching
[GPOS] Fix PairPos signedness
[HB] Fix glyph properties
Fall back to TT kerning if no GPOS
[GPOS] Remove unused variables
[HB] Remove useless include
[GPOS] Add vertical TODO
[GPOS] Fix property checking
[HB] Improve buffer. Don't dup out buffer unless out is longer than in
[GPOS] Advance buffer cursor in SinglePos lookups. Ouch!
Bug 585164 â?? 'man preload' shows man page for pango-view
XX
Bug 585806 â?? crash during pango_fc_font_map_shutdown
Bug 589133 â?? Firefox 3.5 complains about invalid weak references
Merge branch '1.24'
Bump version to 1.25.0
Bug 589113 â?? Some characters rotated incorrectly in vertical text
Remove DOS newline
Bug 410169 â?? gravity problem with Common chars
[docs] Add index of symbols new in 1.24 and 1.26
Merge branch 'master' into harfbuzz-ng
Revert "XX"
[atsui] Port to use CoreText instead of ATS
Bug 590042 â?? pango-view.1 manpage should not be gzipped
Apply patch from Jonathan Kew
[HB] Fix buffer enlargement. Ouch
[HB] Adapt to new buffer API
[HB] Rename internal vars
[HB] Move direction to buffer
[HB] Add a "blob" manager
[HB] Remove hinting setting and use ppem==0 to mean "no hinting"
[HB] Use calloc instead of malloc where feasible
[HB] Fix for dfont's with multiple faces
[HB] Simplify refcounting functions
[HB] Add abstract font and face API
[HB] Simplify object creation
[HB] Assorted compiler macros
[HB] Remove glib dependency
[Makefile] Fix MOSTLYCLEANFILES
[HB] Add get_reference_count()
[HB] Move typedef's around
[HB] Port buffert to new object API
[OT] Match struct with HB's
[HB] Cleanup public buffer structs
[HB] Cleanup TODO
[HB] Rename _duplicate to _copy
[HB] Add XXX marks
[HB] Add top-level header files
[HB] Port ot-layout to new public API
[HB] Move OT file handling out of ot-layout
[OT] Rename C++ header files from *.h to *.hh
[HB] Rename hb-font.c to hb-font.cc
[HB] Add sub-blobs
[HB] Simplify sub-blob support
[HB] Use face_t directly instead of ot_layout_t
[HB] Make it all work again
[HB] Remove use of typeof()
[HB] Start sanitize()
[HB] More sanitize()
[HB] Optimize sanitize()
[HB] Add comment
[HB] Finish GSUB sanitize()
[HB] Simplify indirect sanitize()
[HB] Merge more templates
[Hb] Use reinterpret casts instead of direct casts to char *
[HB] More cast cleanup
[HB] Fix couple of bugs
[HB] More casts
[HB] Sanitize DeviceTable
[HB] GPOS sanitize()
[HB] Fix mix warnings
[HB] Hookup NEUTER()
[HB] Remove stale TODO
[HB] Fix Extension sanitize()
[HB] GDEF sanitize()
[HB] Tag sanitize()
[HB] open-file sanitize()
[HB] More sanitize infrastructure
Merge branch 'master' into harfbuzz-ng
[HB] Shuffle code around
[HB] Minor cleanup
[HB] Add XXX
[HB] Add Sanitizer
[HB] Fix leak
[HB] Hook Sanitizer up. Hell's breaking loose right now
[HB] Avoid infinite recusion in Extension sanitize()
[HB] Fix warnings
Fix warnings
[HB] Save edit even if not writeable
[HB] Rename open-types to open-type; beauty
[HB] Add sanitize debugging facilities
[HB] Add missing sanitize
[HB] Fix fatal Sanitizer bug
[HB] More debugging output
[HB] Fix a couple other sanitize() bugs
[HB] Fix another sanitize() bug; hopefully it's the last one
Update doc templates
[HB] turn debugging off
[HB] Fix build of main.cc
[HB] Minor
[HB] Improve debug output and fix mprotect bug
[HB] Fix blob unlock
[HB] Improve debug output
[HB] Add a few TODO items
[HB] Minor
[HB] Improve debug output
[OT] Make sure we own face generic data before using it
[OT] Fix crash with non-SFNT fonts
[OT] Remove SFNT special-casing. HB knows how to do that
[HB] Use glib again
[HB] Fix blob to use a actual mutex
[HB] Remove a few 'inline's, though the compiler mostly ignores them
[HB] Fix unaligned access
[HB] Remove stale XXX
[HB] Rebrand XXX as TODO
[HB] Remove another stale XXX
[HB] Remove unused var
[HB] Fix various XXX issues
[HB] Remove clumsy macros and improve API
[HB] Fix bug introduced recently
[HB] Rename hb_ot_layout_feature_mask_t to hb_mask_t
[HB] Remove hb_ot_layout_table_find_feature()
[HB] Print mark sets in main.cc
[HB] Remove done TODO item
[HB] Add a NEXT() macro
[HB] Remove unused code
[HB] Indent
Revert "Build introspection again"
[OT] Remove list of private (and gone) symbols from public def file
Release 1.25.1
Carlo Bramini (1):
Bug 582851 -- Little fix for compiling with Cygwin
Colin Walters (1):
Build introspection again
Tor Lillqvist (1):
Bug 588060 -- Fonts missing on Cygwin
[
Date Prev][
Date Next] [
Thread Prev][
Thread Next]
[
Thread Index]
[
Date Index]
[
Author Index]