[pango] (233 commits) ...[HB] Add a few TODO items



Summary of changes:

  23fe8a3... Merge harfbuzz-ng (*)
  6c68a82... Implement the first substitute() (*)
  25f2af6... [harfbuzz/GSUB] towards a partially working GSUB (*)
  3be9238... [GSUB] Fix reverse lookup loop like we did in the old code  (*)
  0313140... [GSUB] Implement Extension subtables (*)
  2d1c3ed... [GSUB] Implement Alternate subtables (*)
  644d920... [GSUB] Start Ligature subtable support (*)
  0bb5d46... [GSUB] Hook new GSUB up in Pango (*)
  8afbf62... [GSUB] Implement ligature substitutions (*)
  e3d3752... [GSUB] Minor refactoring (*)
  5e2e37c... [GSUB] Towards Context subtitutes (*)
  24eb2f6... [GSUB] minor (*)
  21d6ce8... [HarfBuzz] Start a TODO file (*)
  dc7f294... [GSUB] Shuffle (*)
  9ca1c67... [GSUB] ContextSubst format 1 (*)
  384c824... [HB] Remove get_size() (*)
  9042dae... [HB] Remove DEFINE_NON_INSTANTIABLE (*)
  35f3896... [HB] Add TODO item (*)
  6ec3231... [HB] Fix typo (*)
  761d13a... [GSUB] Finish ContextSubstFormat1 (*)
  75778ef... [GSUB] Add GSUB::substitute_lookup() (*)
  e9622c8... [GSUB] Implement ContextSubstFormat2 (*)
  241fbce... [GSUB] Implement ContextSubstFormat3 (*)
  b05941e... [GSUB] Start ChainContextSubst (*)
  c4f14a9... [HB] Remove obsolete comment (*)
  d34fc6f... [HB] Use templates for Null objects (*)
  c18aeca... [HB] Automate int-type size assertion (*)
  0f7838c... [HB] Add OffsetTo template. (*)
  fe6de17... [HB] Use OffsetTo<> in more places (*)
  2cb82da... [HB] Use OffsetTo<> for Coverage (*)
  3d6f115... [HB] Add ArrayOf<> (*)
  620d7f7... [HB] Use ArrayOf<> in GSUB (*)
  3532e39... [HB] Simplify more arrays (*)
  a44105a... [HB] Update copyright years (*)
  f1e6c04... [HB] Add TODO item (*)
  92c65d2... [HB] Simplify buffer (*)
  264a07c... [HB] Renames (*)
  9083606... [GSUB] Unify ContextSubst matching (*)
  ea8ac42... [HB] Move Context matching logic out of GSUB (*)
  5bdc1ff... [HB] Unify first glyph property checking (*)
  9222e07... [GSUB] Further optimize the main switch (*)
  8bd68ca... [HB] Propagate property of first glyph (*)
  aec04a3... [HB] Couple size checks (*)
  e2b95c6... [HB] Use four bytes for Null Tag, not 5 (*)
  3b7ab58... [HB] Cleanup format unions (*)
  cd966a0... [HB] More shuffling (*)
  fe01531... [HB] Split Layout-common tables into new files (*)
  0c11bc3... [HB] Remove stale TODO (*)
  eea8dd6... [HB] Start ChainContext and ReverseChainSingleSubst lookups (*)
  55fe0e4... [HB] Cosmetic (*)
  d32b9ea... [HB] Add check to avoid infinite recursion (*)
  d2c8763... [HB] Towards sharing Context and ChainContext code (*)
  f445e05... [HB] More churning towards ChainContext lookups (*)
  4dbe5b6... [HB] More template goodness (*)
  ac227e2... [HB] Add HeadlessArrayTo<> (*)
  d9acee5... [HB] A step closer to working ChainContext (*)
  21be5df... [HB] Further modularize Context matching (*)
  e1b4d68... [HB] One more step to go, for fully working GSUB and ChainC (*)
  b20970d... [HB] Implement backtrack matching (*)
  e20c11f... [HB] ChainContext complete (*)
  16fb96b... [HB] Fix context_length checking (*)
  55fdb2a... [HB] Correctly skip glyphs when applying (Chain)Context loo (*)
  7641ec6... [HB] Minor cleanup (*)
  6cc2d15... [GSUB] Fix context_length handling in Ligature too (*)
  e9e1705... [HB] Cleanup TODOs (*)
  29f0ff9... [HB] Tweak some constants and fix Coverage (*)
  73460ad... [GSUB] Oops, fix Extension check (*)
  1927fb2... [HB] Don't use G_LIKELY! (*)
  bba893b... [GSUB] Implement ReverseChainSingleSubst (*)
  cda2b36... [GSUB] Protect against mismatching Extension subtable types (*)
  014a756... [HB] Minor (*)
  4781df2... [GSUB] Minor (*)
  68f88f1... [HB] Start GPOS! (*)
  a483de8... Switch Pango to new, defunt, GPOS (*)
  293b1f9... [HB] Simplify casts (*)
  c08a686... [HB] Internally rename position() and substitute() to apply (*)
  3112f9e... [HB] Rename LOOKUP_ARGS to APPLY_ARGS (*)
  4c83d55... [HB] More reference cast simplification (*)
  51d8154... [HB] Use enums (*)
  9c25dfb... [GPOS] Start filling apply() functions in (*)
  10ddad5... [GPOS] PairPosFormat1 (*)
  da5b04a... [GSUB] PairPosFormat2 (*)
  852a038... [GPOS] CursivePosFormat1 (*)
  066d6ab... [HB] Indentation (*)
  2b57f9a... [HB] Remove unused methods (*)
  0b092ed... [HB] Indentation (*)
  e972781... [GDEF] Simplify Device access (*)
  25db8f6... [HB] Move lookup types enum into subtable class (*)
  b77c499... [GPOS] Fix GPOS feature lookup lookups and application (*)
  ac8ad1e... [GPOS] Fix more brokenness (*)
  15a0220... [GPOS] Finally it's working, up to Cursive (*)
  336bb32... [HB] Remove all references to the old code! (*)
  c141180... [HB] Rename harfbuzz-buffer to hb-buffer (*)
  5687dd7... [HB] Remove last dependence on the old code base! (*)
  6fb8dab... [HB] Add TODO item (*)
  25494c5... [HB] Add TODO item (*)
  93e5da2... [GPOS] Start MarkBasePosFormat1 (*)
  361cdf3... [GPOS] Remove apply_value() return value (*)
  164137a... [GPOS] Implement Device support in AnchorFormat3 (*)
  180781e... [GPOS] Implement MarkArray interface (*)
  7c4677a... [GPOS] MarkBasePosFormat1 (*)
  6e1a266... [GPOS] MarkMarkPosFormat1 (*)
  541e8ad... [HB] Ouch.  Add files. (*)
  a968876... [GPOS] Remove printf.  MarkMarkPos1 is working (*)
  fb963a1... [HB] Share Extension lookup code between GSUB and GPOS (*)
  31f627d... [HB] Remove apply_subtables() again (*)
  191cfb7... [GPOS] MarkLigPosFormat1 (*)
  d2b11bb... [GDEF] Add some get_carret_value() code (*)
  eca339b... [HB] Add TODO items (*)
  5c8fd8c... [HB] Minor (*)
  d36c93e... [HB] Check for GDEF/GSUB/GPOS versions (*)
  8259e87... [HB] Simplify version check in GSUB/GPOS (*)
  f89367b... [HB] Remove unused data types (*)
  8ff8278... [HB] Simplify tag (*)
  d11f8e6... [HB] Add FixedVersion cast to int (*)
  4b90aa8... [HB] Remove stale TODO mark (*)
  a7a7154... [HB] Remove old code! (*)
  f4ad4d8... [HB] Remove stale makefile.msc too (*)
  ed60b2d... [HB] Update text files (*)
  8690ed7... [HB] simplify macros (*)
  d63d5c6... [HB] Simplify some basic things (*)
  c53ed30... [HB] Simplify more (*)
  c783d19... [HB] Simplify Tag (*)
  40c6f89... [HB] More cleanup (*)
  6e506f4... [HB] Would have helped if I actually knew C++ before using  (*)
  8c864af... [HB] Update copyright years (*)
  8f0881c... [HB] Remove one XXX, add another (*)
  fdb536b... [HB] Clean more (*)
  76d05e8... [HB] Cleanup buffer (*)
  7b3f038... [HB] More buffer cleanup (*)
  298dadb... [HB] Remove more macros (*)
  8075817... [HB] Add get_attach_points() (*)
  fb8da04... [HB] Implement get_lig_carets() (*)
  3b1a840... [HB] Start MarkFilteringSet support (*)
  d877d91... [HB] More de-C++'ization (*)
  a6e2371... [HB] Support parsing MarkFilteringSets introduced in OpenTy (*)
  95c3fff... [HB] Simplify MarkAttachmentType handling (*)
  746860b... [GDEF] Support MarkFilteringSets (*)
  fe78909... [HB] When looking back/forward, skip marks only (*)
  74d8c52... [GPOS] Fix mark matching (*)
  dc08fb7... [GPOS] Fix PairPos signedness (*)
  6f9bd9a... [HB] Fix glyph properties (*)
  07c0e3b... Fall back to TT kerning if no GPOS (*)
  4921800... [GPOS] Remove unused variables (*)
  157af6b... [HB] Remove useless include (*)
  810f421... [GPOS] Add vertical TODO (*)
  3dbd374... [GPOS] Fix property checking (*)
  9fdfc9a... [HB] Improve buffer.  Don't dup out buffer unless out is lo (*)
  eae0fec... [GPOS] Advance buffer cursor in SinglePos lookups.  Ouch! (*)
  2bf2d82... Bug 585164 â?? 'man preload' shows man page for pango-view (*)
  c939f6a... XX (*)
  a1fb363... Merge branch 'master' into harfbuzz-ng (*)
  2ea6180... Revert "XX" (*)
  59f8868... Apply patch from Jonathan Kew (*)
  603479e... [HB] Fix buffer enlargement.  Ouch (*)
  11c229d... [HB] Adapt to new buffer API (*)
  7f734d9... [HB] Rename internal vars (*)
  7444dad... [HB] Move direction to buffer (*)
  112f0d7... [HB] Add a "blob" manager (*)
  2ea6693... [HB] Remove hinting setting and use ppem==0 to mean "no hin (*)
  86f7ff9... [HB] Use calloc instead of malloc where feasible (*)
  7257d66... [HB] Fix for dfont's with multiple faces (*)
  3ebf3e5... [HB] Simplify refcounting functions (*)
  661ade9... [HB] Add abstract font and face API (*)
  3082596... [HB] Simplify object creation (*)
  30791d4... [HB] Assorted compiler macros (*)
  0ae1b78... [HB] Remove glib dependency (*)
  fe17dd9... [Makefile] Fix MOSTLYCLEANFILES (*)
  7f5ea9c... [HB] Add get_reference_count() (*)
  b028576... [HB] Move typedef's around (*)
  b522838... [HB] Port buffert to new object API (*)
  019d335... [OT] Match struct with HB's (*)
  55b6ef4... [HB] Cleanup public buffer structs (*)
  e8238d1... [HB] Cleanup TODO (*)
  4351462... [HB] Rename _duplicate to _copy (*)
  fac4166... [HB] Add XXX marks (*)
  5bb23c0... [HB] Add top-level header files (*)
  6624880... [HB] Port ot-layout to new public API (*)
  ed1f17c... [HB] Move OT file handling out of ot-layout (*)
  c71d6fc... [OT] Rename C++ header files from *.h to *.hh (*)
  48cc6e9... [HB] Rename hb-font.c to hb-font.cc (*)
  ab5a714... [HB] Add sub-blobs (*)
  da2a762... [HB] Simplify sub-blob support (*)
  b638ece... [HB] Use face_t directly instead of ot_layout_t (*)
  832cb0e... [HB] Make it all work again (*)
  2f19c9a... [HB] Remove use of typeof() (*)
  dc6fe7c... [HB] Start sanitize() (*)
  f786c9d... [HB] More sanitize() (*)
  15e1f26... [HB] Optimize sanitize() (*)
  8c48985... [HB] Add comment (*)
  477a991... [HB] Finish GSUB sanitize() (*)
  a501ac4... [HB] Simplify indirect sanitize() (*)
  c8c0426... [HB] Merge more templates (*)
  5e8a31e... [Hb] Use reinterpret casts instead of direct casts to char  (*)
  7c897c7... [HB] More cast cleanup (*)
  7d0dc63... [HB] Fix couple of bugs (*)
  ff00470... [HB] More casts (*)
  b78fad2... [HB] Sanitize DeviceTable (*)
  36c7317... [HB] GPOS sanitize() (*)
  b2eb172... [HB] Fix mix warnings (*)
  7a0a97b... [HB] Hookup NEUTER() (*)
  14ac615... [HB] Remove stale TODO (*)
  091b0e7... [HB] Fix Extension sanitize() (*)
  7e7f9f5... [HB] GDEF sanitize() (*)
  c436b68... [HB] Tag sanitize() (*)
  f92f7d3... [HB] open-file sanitize() (*)
  6a4933a... [HB] More sanitize infrastructure (*)
  d327d7f... Merge branch 'master' into harfbuzz-ng (*)
  782943e... [HB] Shuffle code around (*)
  02c12b3... [HB] Minor cleanup (*)
  64563fc... [HB] Add XXX (*)
  c04edb5... [HB] Add Sanitizer (*)
  d55d065... [HB] Fix leak (*)
  23663fe... [HB] Hook Sanitizer up.  Hell's breaking loose right now (*)
  cb97149... [HB] Avoid infinite recusion in Extension sanitize() (*)
  50295f0... [HB] Fix warnings (*)
  c63d3b1... Fix warnings (*)
  b4cfda4... [HB] Save edit even if not writeable (*)
  076b06f... [HB] Rename open-types to open-type; beauty (*)
  b4c1057... [HB] Add sanitize debugging facilities (*)
  7762880... [HB] Add missing sanitize (*)
  a990ba0... [HB] Fix fatal Sanitizer bug (*)
  4928a22... [HB] More debugging output (*)
  2e28925... [HB] Fix a couple other sanitize() bugs (*)
  85c2e96... [HB] Fix another sanitize() bug;  hopefully it's the last o (*)
  f250cc4... Update doc templates (*)
  413af41... [HB] turn debugging off (*)
  c96b2a6... [HB] Fix build of main.cc (*)
  0fc28b7... [HB] Minor (*)
  77bde84... [HB] Improve debug output and fix mprotect bug (*)
  1aab84b... [HB] Fix blob unlock (*)
  895a985... [HB] Improve debug output (*)
  1761cd1... [HB] Add a few TODO items (*)

(*) This commit already existed in another branch; no separate mail sent



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]