[rygel] (81 commits) ...Add a button to enable/disable media server.



Summary of changes:

  9bb186e... Put user configuration access into a separate object. (*)
  5ff76f4... Configuration should be part of public API. (*)
  a7f6fd4... GConf path prefix shouldn't be a public prop. (*)
  19b29a5... Depend on Gtk+ if UI build is not disabled. (*)
  9801ff1... Put Configuration into a separate static library. (*)
  ec5cd68... Beginning of a preferences UI. (*)
  bbfcca1... Add an "Apply" button. (*)
  9010c09... Our dialog implements it's own run method. (*)
  9181c45... Dialog should be all visible from the beginning. (*)
  17ff1f4... Skeleton for handling of dialog response. (*)
  6cb4659... Put the cstuff in the config library. (*)
  ac6e162... Add widgets to set 'host-ip' and 'port' configuration. (*)
  85b01ac... Add "Enable Xbox support" option. (*)
  7033873... A bit of refactoring. (*)
  013b7b3... Don't put label as part of CheckButton. (*)
  5a5e2e8... Refactor more: HBox and Label now handled by add_pref_widge (*)
  d6660bf... Don't put anything in gconf. (*)
  3a4546d... Rename Configuration to ConfigReader. (*)
  110ce3a... Make GConf client and path accessible to subclasses. (*)
  adf9ad6... All plugins need to link to gconf now. (*)
  e23ce89... Allow get_string() params/return to be null. (*)
  ed7552b... Convenient methods to read boolean and integer. (*)
  e9b1389... Use the convenience methods to read values from gconf. (*)
  1a01d64... Make convenience methods public. (*)
  1146b26... New class for editing of user configuration. (*)
  de493a4... Don't capitalize the gconf keys unless it's an abbrev. (*)
  4ef780b... Add convenience methods to set IP, port and xbox support. (*)
  6285f4e... Define constants for known keys. (*)
  6b58c3d... Differentiate between name and title of config options. (*)
  47cc318... Keep the config_editor in the object scope. (*)
  8529cb2... Actually save the configuration. (*)
  99fb8b0... Save the boolean options as well. (*)
  b012d0d... Also save the integers. (*)
  568cb6d... Rename Preferences to PreferencesDialog. (*)
  019daaa... Introducing PreferencesVBox. (*)
  39f2f54... PreferencesDialog doesn't need to keep config_editor. (*)
  0557d8c... PreferencesVBox should provide a title for itself. (*)
  1c4d633... Put the PreferencesVBox in Notebook. (*)
  15a7a11... Keep section name in a object field. (*)
  76c48a1... Make some fields/methods of PreferencesVBox, protected. (*)
  8bd2443... Introducing GeneralPrefVBox. (*)
  cd69a1e... Minor indentation fix. (*)
  95ef7c6... Treat empty strings from gconf as nulls. (*)
  29ff775... Pass the title and section args in correct order (*)
  65cacec... Don't expose 'enable-xbox' prop to user (*)
  3c523dd... Provide consts for title and UDN keys (*)
  73b773f... Put code to add a pref page in a separate method (*)
  089ceb5... Introducing PluginPrefVBox. (*)
  acb10bb... Add pref vbox for all existing plugins. (*)
  779fcd9... Merg 'section' and 'title' props of PluginPrefVBox (*)
  adc453a... More use of consts defined for gconf keys (*)
  772b91c... Add option to enable/disable plugins (*)
  50c201f... Don't use GConf.Client.get_bool () (*)
  0449734... Don't load disabled plugins (*)
  b7adf47... Remove the unused convenience methods (*)
  3ca65b8... ConfigReader + ConfigEditor = Configuration (*)
  bae7463... UDN is supposted to be a constant (*)
  c8f3edc... HIG: Put the OK button in the end (*)
  ea9687b... Exit on delete event on PreferencesDialog (*)
  616f0af... Rename PreferencesVBox to PreferencesPage (*)
  1f32c84... Moving towards Glade + GtkBuilder approach. (*)
  5b198ca... Convert UI file to Gtk+ 2.16. (*)
  7402b87... Better names for widgets. (*)
  3b4c7f0... Assign response IDs to buttons. (*)
  cd58b02... Better names for some widgets. (*)
  0ec058c... Port the code to use dynamic UI (*)
  f995cae... Use the correct response IDs. (*)
  836ea9b... Put a nice title on the dialog (*)
  b9506a9... Dialog should be at least 400 pixels by default (*)
  ef2ed6d... Put the table inside an alignment (*)
  26bfc36... Random size/alignment improvements (*)
  24f6c86... Remove the unneeded VBox (*)
  8dc59e6... Add transcoding options (*)
  4e5b664... Add transcoding options to Configuration (*)
  ae5b2e7... Better names for transcoding check buttons (*)
  1c82936... Config UI loads/saves the transcoding options (*)
  9dbba34... General options are loaded/saved on demand (*)
  f9bbc5b... Bring back the tooltips (*)
  6ea6f83... Glade3 wants to re-arrange some widgets, let it! (*)
  14792d0... Disable widgets when they don't make sense (*)
  0661eb9... Add a button to enable/disable media server. (*)

(*) This commit already existed in another branch; no separate mail sent



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]