gtk+ r19362 - in trunk: . gtk



Author: hasselmm
Date: Mon Jan 14 00:12:53 2008
New Revision: 19362
URL: http://svn.gnome.org/viewvc/gtk+?rev=19362&view=rev

Log:
Explain name choice for gtk_tool_item_toolbar_reconfigured.

* gtk/gtktoolitem.c: Add comment expaining name choice for
gtk_tool_item_toolbar_reconfigured.


Modified:
   trunk/ChangeLog
   trunk/gtk/gtktoolitem.c

Modified: trunk/gtk/gtktoolitem.c
==============================================================================
--- trunk/gtk/gtktoolitem.c	(original)
+++ trunk/gtk/gtktoolitem.c	Mon Jan 14 00:12:53 2008
@@ -1179,6 +1179,13 @@
 void
 gtk_tool_item_toolbar_reconfigured (GtkToolItem *tool_item)
 {
+  /* The slightely inaccurate name "gtk_tool_item_toolbar_reconfigured" was
+   * choosen over "gtk_tool_item_tool_shell_reconfigured", since the function
+   * emits the "toolbar-reconfigured" signal, not "tool-shell-reconfigured".
+   * Its not possible to rename the signal, and emitting another name than
+   * indicated by the function name would be quite confusing. That's the
+   * price of providing stable APIs.
+   */
   g_return_if_fail (GTK_IS_TOOL_ITEM (tool_item));
 
   g_signal_emit (tool_item, toolitem_signals[TOOLBAR_RECONFIGURED], 0);



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]