gio-standalone r678 - trunk/gio



Author: alexl
Date: 2007-10-31 13:21:11 +0000 (Wed, 31 Oct 2007)
New Revision: 678
ViewCVS link: http://svn.gnome.org/viewcvs/gio-standalone?rev=678&view=rev

Added:
   trunk/gio/gnativevolumemonitor.c
   trunk/gio/gnativevolumemonitor.h
Removed:
   trunk/gio/guniondrive.c
   trunk/gio/guniondrive.h
   trunk/gio/gunionvolume.c
   trunk/gio/gunionvolume.h
Modified:
   trunk/gio/Makefile.am
   trunk/gio/gfile.c
   trunk/gio/gfile.h
   trunk/gio/gfileinfo.h
   trunk/gio/glocalfile.c
   trunk/gio/gunionvolumemonitor.c
   trunk/gio/gunixmounts.c
   trunk/gio/gunixvolume.c
   trunk/gio/gunixvolume.h
   trunk/gio/gunixvolumemonitor.c
   trunk/gio/gunixvolumemonitor.h
   trunk/gio/gvolume.h
   trunk/gio/gvolumeprivate.h
Log:
2007-10-31  Alexander Larsson  <alexl redhat com>

        * gio/Makefile.am:
        * gio/guniondrive.[ch]: Removed.
        * gio/gunionvolume.[ch]: Removed.
	Remove GUnionDrive/Volume

        * gio/gunionvolumemonitor.c:
	Simplify union volume monitor, now we
	only have one native volume monitor and
	we use the actual volumes/drives from the
	child monitors instead of wrapping them

        * gio/gnativevolumemonitor.[ch]:
	Base class for native volume monitors.
	Includes priority and get_volume_for_mountpoint
	
        * gio/gfile.[ch]:
        Add g_file_find_enclosing_volume

        * gio/gfileinfo.h:
	Remove volume name fs attribute
	Add readonly fs attribute
	
        * gio/glocalfile.c:
	Implement readonly attribute
	remove volume name attribute
	Implement find_enclosing volume
	
        * gio/gunixmounts.c:
	Add a volume for "/".
	
        * gio/gunixvolume.[ch]:
	Set better name for /
	
        * gio/gunixvolumemonitor.[ch]:
	Derive from GNativeVolumeMonitor
	Implement get_volume_for_mountpoint
	
        * gio/gvolume.h:
	GVolume typedef moved to gfile.h
	
        * gio/gvolumeprivate.h:
	Add g_volume_get_for_mount_path






[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]