gnome-power-manager r2073 - in trunk: . data docs libhal-glib po src test



Author: rhughes
Date: 2007-03-20 23:04:03 +0000 (Tue, 20 Mar 2007)
New Revision: 2073
ViewCVS link: http://svn.gnome.org/viewcvs/gnome-power-manager?rev=2073&view=rev

Added:
   trunk/src/gdb-gpm.sh
   trunk/src/gpm-engine.c
   trunk/src/gpm-engine.h
Removed:
   trunk/src/gpm-battery.c
   trunk/src/gpm-battery.h
   trunk/src/gpm-power.c
   trunk/src/gpm-power.h
Modified:
   trunk/ChangeLog
   trunk/data/gnome-power-manager.schemas.in
   trunk/docs/dbus-interface.html
   trunk/docs/dbus-interface.xml
   trunk/libhal-glib/libhal-gmanager.c
   trunk/po/POTFILES.in
   trunk/src/Makefile.am
   trunk/src/gpm-ac-adapter.h
   trunk/src/gpm-array.c
   trunk/src/gpm-backlight.c
   trunk/src/gpm-button.c
   trunk/src/gpm-cell-array.c
   trunk/src/gpm-cell-array.h
   trunk/src/gpm-cell.c
   trunk/src/gpm-cell.h
   trunk/src/gpm-conf.h
   trunk/src/gpm-control.c
   trunk/src/gpm-control.h
   trunk/src/gpm-cpufreq.c
   trunk/src/gpm-debug.c
   trunk/src/gpm-debug.h
   trunk/src/gpm-feedback-widget.c
   trunk/src/gpm-info.c
   trunk/src/gpm-info.h
   trunk/src/gpm-main.c
   trunk/src/gpm-manager.c
   trunk/src/gpm-marshal.list
   trunk/src/gpm-notify.c
   trunk/src/gpm-notify.h
   trunk/src/gpm-prefs-core.c
   trunk/src/gpm-profile.c
   trunk/src/gpm-profile.h
   trunk/src/gpm-srv-brightness-kbd.c
   trunk/src/gpm-statistics-core.c
   trunk/src/gpm-tray-icon.c
   trunk/src/gpm-tray-icon.h
   trunk/src/gpm-warning.c
   trunk/src/gpm-warning.h
   trunk/test/Makefile.am
Log:
2007-03-20  Richard Hughes  <richard hughsie com>

* src/gpm-power.c:
* src/gpm-power.h:
* src/gpm-battery.c:
* src/gpm-battery.h:
Remove this crappy code.

* po/POTFILES.in:
* src/Makefile.am:
* src/gpm-engine.c: (ac_adaptor_changed_cb),
* src/gpm-engine.h:
* src/gpm-main.c: (main):
* src/gpm-manager.c: (gpm_manager_sync_policy_sleep),
* src/gpm-info.c: (gpm_info_set_collection_data),
* src/gpm-info.h:
* src/gpm-marshal.list:
* src/gpm-tray-icon.c: (gpm_tray_icon_set_collection_data),
* src/gpm-tray-icon.h:
* src/gpm-warning.c: (gpm_warning_get_state_csr),
* src/gpm-warning.h:
* src/gpm-cell-array.c: (gpm_cell_array_get_unit),
* src/gpm-cell-array.h:
* src/gpm-cell.c: (gpm_cell_refresh_all),
* test/Makefile.am:
Add the engine component, so we can remove GpmBattery and GpmPower.

* libhal-glib/libhal-gmanager.c: (hal_gmanager_init):

* src/gpm-conf.h:
* data/gnome-power-manager.schemas.in:
Re-organsise the schema with better names, and with a tree structure.
We have lots of keys, these need some structure.
Yes, I'm aware we are not migrating settings, this is a major change.

* docs/dbus-interface.xml:
Correct some spelling error.

* src/gpm-ac-adapter.h:
* src/gpm-backlight.c: (gpm_backlight_sync_policy),
* src/gpm-button.c: (emit_button_pressed):
* src/gpm-cpufreq.c: (gpm_cpufreq_sync_policy),
* src/gpm-srv-brightness-kbd.c: (conf_key_changed_cb),
Make the AcAdapter callback simpler.

* src/gdb-gpm.sh:
Add this file so I can lauch gdb with fewer keystrokes. Yes, I'm lazy.

* src/gpm-array.c: (gpm_array_compute_integral):
Don't assert if we try to integrate from X->X, i.e. the same number.

* src/gpm-cell.h:
* src/gpm-control.c:
* src/gpm-control.h:
* src/gpm-feedback-widget.c: (gpm_feedback_init):
* src/gpm-prefs-core.c: (gpm_prefs_setup_action_combo),
* src/gpm-statistics-core.c: (gpm_statistics_init):
General tidyups.

* src/gpm-debug.c: (gpm_debug_add_option), (gpm_error_real),
* src/gpm-debug.h:
Don't use GTK+ error dialogues for errors, just print to the console.

* src/gpm-profile.c: (gpm_profile_get_time),
* src/gpm-profile.h:
Use the engine, don't connect to HAL ourselves.

* src/gpm-notify.c: (notify_closed_cb), (gpm_notify_create),
* src/gpm-notify.h:
Make many more dialogues interactive. We still don't handle multiple
dialogs well, this to to fix real soon.





[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]