[tim-janik/beast] autogen.sh python2 check error (#45)

checking for python3.6... (cached) /usr/bin/python
checking for a version of Python >= '2.1.0'... yes
checking for a version of Python >= 2.7... Traceback (most recent call last):
  File "<string>", line 1, in <module>
TypeError: '>=' not supported between instances of 'str' and 'float'
configure: error: this package requires Python >= 2.7.
If you have it installed, but it isn't the default Python
interpreter in your system path, please pass the PYTHON_VERSION
variable to configure. See ``configure --help'' for reference.

./autogen.sh  28.25s user 4.43s system 70% cpu 46.267 total

I tried PYTHON_VERSION=2.7 ./autogen.sh and PYTHON_VERSION=2.7 ./configure, same result, but ./autogen.sh PYTHON=/usr/bin/python2.7 does work.

You are receiving this because you are subscribed to this thread.
Reply to this email directly, view it on GitHub, or mute the thread.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]