Re: ebeast: electron + beast

On 22.02.2017 13:43, Stefan Westerfeld wrote:

On Wed, Feb 22, 2017 at 01:04:00AM +0100, Tim Janik wrote:
I've just pushed the 'ebeast' branch onto github.


It contains the start of an electron based Beast UI ('ebeast') plus Bse JS bindings.

Please give 'make run -C ebeast' a try and provide feedback. I've tried to set
things up to be used and built as easily as possible. The next step here is to
make use of electron-packager to implement 'make install -C ebeast'.

Ok, make app works, but make run hangs (nothing happens after this):

$ make run
make[1]: Verzeichnis „/home/stefan/src/2nd-tree/beast/ebeast/v8bse“ wird betreten
make[1]: „v8bse.node“ ist bereits aktuell.
make[1]: Verzeichnis „/home/stefan/src/2nd-tree/beast/ebeast/v8bse“ wird verlassen
LD_PRELOAD="/home/stefan/src/2nd-tree/beast/bse/.libs/" \
./node_modules/electron/dist/electron .

Seems that there is a crash involved, as a core file appears in the ebeast dir

Seems that argcp is a nullptr here,

Eeek, sorry, I ran into this a couple days ago, fixed it locally in Rapicorn and
totally forgot about it.
Just pull the fix from Rapicorn master now, you've diagnosed this correctly.

(gdb) print argcp
$1 = (int *) 0x0

and should not be dereferenced.

   Cu... Stefan

Yours sincerely,
Tim Janik
Free software author.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]