I used the wrong email address so this may be double posted. Sorry any inconvenience.
I’ve finished a patch so SafeUri.UriToFilename and SafeUri.FilenameToUri are written in managed code, eliminating the need to call Glib. I have some private helper methods, enums, and arrays that I’ve added to the SafeUri class. I was wondering what kind of naming policy there is for these helper items. I’ve named the helper methods according to their original name in Glib (g_unescape_uri_string as an example). Should I name them something different?
Secondly should these helper methods stay in SafeUri or should they be moved into some other class?