[Banshee-List] Database is locked error...

I've been trying to get Banshee working for about a week now but
consistently get this error.  I've both compiled Banshee from svn source
as well as used the stock debian version.  Both of them complain about
the SQLite database being locked.
For the svn source version I also downloaded the sqlite libraries and
recompiled them.  I've not yet downloaded the mono source to create that
from scratch.  Will that be necessary?

This is output from the stock debian version:

An unhandled exception was thrown: database is locked

  at Mono.Data.SqliteClient.SqliteCommand.GetNextStatement (IntPtr
pzStart, System.IntPtr& pzTail, System.IntPtr& pStmt) [0x00000]
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteReader (CommandBehavior
behavior, Boolean want_results, System.Int32& rows_affected) [0x00000]
  at Mono.Data.SqliteClient.SqliteCommand.ExecuteNonQuery () [0x00000]
  at Banshee.Database.QueuedSqliteCommand.Execute () [0x00000]
.NET Version: 2.0.50727.42

Assembly Version Information:

System.Xml (
System.Transactions (
gconf-sharp (
System.Data (
Mono.Data.SqliteClient (
pango-sharp (
Mono.Cairo (
Hal (
Banshee.Widgets (
Last.FM (
NDesk.DBus.Proxies (
NDesk.DBus (
Mono.Posix (
NDesk.DBus.GLib (
gnome-sharp (
gdk-sharp (
System (
atk-sharp (
glib-sharp (
gtk-sharp (
Banshee.Base (
banshee (
mscorlib (

Platform Information: Linux 2.6.22-3-686 i686 unknown GNU/Linux

Disribution Information:


The stock version is what I originally tried, then removed it all and
compiled the svn version and the majority of supporting libraries
(except Mono) but still got the same error.  I've also removed the
database in case it was corrupt or had the wrong permissions and it gets
recreated with a size of zero.

Dan Brown

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]