Re: [Patch] Fix progress dialogue on error (Was: Good news)

On 2018.01.07 15:10, Peter Bloomfield wrote:
On 01/07/2018 02:33:48 PM Sun, Jack wrote:
And it was pointed out to me recently that there are two different possibilities for out of source builds. One is with the build dir completely outside the source dir. The other is with the build dir somewhere under the top source dir. I don't think they need to be treated differently, but I not certain.

I've tested the autotools build with 'builddir != srcdir' under Fedora, both out-of-tree and with the builddir under srcdir, and both worked. I also tried with libbalsa-marshal.[cho] removed in the srcdir, and that worked too.

Not sure what's going on here.

Actually, perhaps nothing. I only pointed out the two possible "out of source" build types just in case someone else found any difference.

Also, my last few compiles have gone fine, without the marshalling compile errors. I suppose it was either a transient error (isn't that a great term for waving your hands and saying "never mind") or it was due to some remnants of an earlier build.

I'll certainly squawk if I find any new problems, but the only problem I still see now is the fetch dialog not quitting if one of the servers gets a timeout error. Albrecht's patch certainly looked like it should work, but perhaps the timeout I'm getting is taking some other code path. The easy way to test is with any yahoo based server - tell it to use TLS required. At least for me, that consistently causes the error. (My current three yahoo servers are all, but I wouldn't think that would matter if they all end up redirecting to servers actually under yahoo's control.)


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]