Re: Importing old Mail

On Sun, 23 Nov 2003 20:25:59 +0000 Peter Bloomfield wrote:

> On 11/23/2003 05:28:12 AM, Daniel Schregenberger wrote:
> > Hello!
> > 
> > I'd like to try balsa (2.0.15) but I could'nt import my old  
> > mails. They're in mbox format, but I could provide them in  
> > different formats (like MH) too. I searched the archives  
> > without finding a hint and the link in the FAQ is dead.
> > 
> > Here's what I get when I try to import the mail using "File >  
> > New > Local mbox mailbox...": - an error window: "Unable to  
> > Open Mailbox! Please check the mailbox settings." - and an  
> > information window: "/home/npfdd/oldmail/Band is not a  
> > mailbox."
> > 
> > Any help appreciated.
> You don't really *import* mail files into Balsa, you just set up  
> access to them (which is what you did with File > New > Local  
> mbox mailbox...).


> The message you saw is triggered by some problem in opening the  
> file.  I'm guessing you're already sure that the path is correct  
> and that there's an mbox at the end of it, and that you have at  
> least read permission on it.  One thing you could try is making a  

Yes. The file is where I specified and the permissions are ok.
I'm not quite sure tough how standard compliant the mbox file is, but
other programs like mhonarc or sylpheed had no problems opening it, so I
suppose it should work.

> copy of the file somewhere in your default mail tree (~/mail ??).   
> Balsa should find the copy automatically during its startup, and  
> you might get a more useful diagnostic if there's still a  
> problem.

I tried this: There are only a number of assertion-messages on the
console, I get in addition to the two error-dialogs mentioned:

(balsa:8724): Gtk-CRITICAL **: file gtkdnd.c: line 1844
(gtk_drag_begin): assertion `target_list != NULL' failed

(balsa:8724): GLib-GObject-CRITICAL **: file gobject.c: line 1425
(g_object_set_data_full): assertion `G_IS_OBJECT (object)' failed

I even tried to just overwrite one of the existing mailboxes with one of
my old ones. No success. On the other hand I may write messages with
balsa and they get stored after sending.
Trying to reformat them with formail also failed, the error messages
disappeared, but it didn't show me any mails in the boxes.

I couldn't find any 'verbose' switch to balsa. If you need more
information, please tell me, I could even post one of the mbox files if
this would help.

Thanks for your help. This is a strange problem! :)

-- Daniel

PS: I'm using gentoo 1.4 where balsa 2.0.15 is marked "unstable" in the
meantime I also tried 2.0.14 which is considered stable. Same result.

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]