gpg feedback

Hi all

Just downloaded balsa 2.0.10 to test out the gpg functionality.

First off, the configure script couldn't find gpgme, but continued on 
as normal, however I noticed in the summary that it wasn't going to be 
installed, maybe it should exit with an error as I did explicitly ask 
it to be included?

Then I installed gpgme 0.3.15 into a non-standard directory.  I thought 
I could just supply that directory name to the configure command but 
that didn't work, I eventually stumbled onto making sure that 
gpgme-config was in the path, and finally things worked!

I then started to test sending messages to myself.  Our mail server is 
using mimedefang to restrict attachments, so I had some fun.  To send a 
signed message to myself, I had to make mimedefang allow 
application/pgp-signature attachments.  Works great!  Now encrypted 
messages on the other hand need to allow application/pgp-encrypted 
which is ok, but also application/octet-stream with an inline 
disposition.  Now this second attachment is a bit of a problem to me, 
as I couldn't find an example of how to allow it.  I'll be upgrading 
mimedefang soon so when I do that I'll try to sort it out, till then I 
will do without encrypting messages.

I also got to and installed the enigmail plugin to mozilla mail.  I 
tried to send both a signed and an encrypted message to balsa, but it 
didn't recognise them as being signed or encrypted.  I think it doesn't 
use attachments(probably the other rfc that has been talked about...)

However on sending a signed message from balsa, mozilla enigmail 
correctly noticed the message was signed(I didn't test an encrypted 
message because of the problem above).

Hope this helps.


[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]