Re: Problem with national characters and gtk 1.2.10

On 2001.09.05 13:34:01 +0200 Albrecht Dreß wrote:
> Am 05.09.2001 12:40:47 schrieb(en) Olaf Frączyk:
> > locale set to pl_PL. In balsa language is set to Polish.
> I suspect this is not sufficient... To get a working environment with


Thank you for answer.
But this is sufficient. It worked fine with gtk 1.2.8 and previous.
I didn't test 1.2.9 because it is broken.
Anyway, I checked with appended ISO-8859-2 but it changes nothing, and the
problem persists.
This is a little bit different situation.
German language uses the same charset (iso-8859-1) as english language.
With gtk were many problems with handling locales using other than default
iso-8859-1 charset.
In my applications, which are used in my company I don't use locales et
all. They have hardcoded fonts (or are configurable using config files). I
know it is not nice, but this was the only way to be sure they will work
correctly. (But even in this case, using some gtk-themes you may loose
iso-8859-2 characters).
Now, it is better, but still not perfect. I hope in gtk 2.0 everything will
work ok.



[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]