Re: Inbox opens as read-only

Sorry if this is a duplicate, i've tried to post-it from another adresse
(not subscribed...)

Hi Marc.
You must change the permissions of the /var/cache and /var/cache/mail
directory to drwxrwxrwt (01777) to enable balsa to lock the mailboxes...

On RedHat, you should also look at the "Configure file permission and
ownership" menu of linuxconf (under the control tab).  If one of the
directories mentioned above is listed, you must also change the permissions
settings there, otherwise linuxconf will reset the old permissions on those
directories every time it is run.

On a side note, if the permissions on those directories are change back to
the old settings while balsa is running and some modifications have been
made (lets say because you happen to launch linuxconf while checking your
mail), Balsa hangs when you try to commit the changes or to close the
mailbox, and you have to kill it... not very elegant...

You wrote:

> Hi,
> I have my system mail spool (/var/cache/mail/marc) set as my inbox.  For
> reason, Balsa (1.0.0 installed via RPM) will open the file only as
> This means, of course, that I can't delete messages, etc.  Does anyone
have any 
> idea why this is happening?  Pine operates fine on this mailbox.
> FWIW, I'm running a freshly installed RH7 distribution, with my
> directory copied from an old install.  Balsa 1.0-pre 2 or 3, and many
> versions (installed via downloaded sources that I compiled), worked fine
> that installation.
> Thanks for any help!
> Marc

Sebastien Nadeau,
PGP Keys:  RSA:0xEB2542F9 DSS:0x0A013BBC
"A Microsoft Certified Systems Engineer is to computing 
What a McDonalds Certified Food Specialist is to fine cuisine."

[Date Prev][Date Next]   [Thread Prev][Thread Next]   [Thread Index] [Date Index] [Author Index]